AsRock Z77 Pro4 - Will it work?

Discussion in 'Mountain Lion Desktop Support' started by PeZoR, Feb 23, 2013.

  1. PeZoR

    PeZoR

    Joined:
    Feb 23, 2013
    Messages:
    4
    Mobo:
    Custom Gamer
    CPU:
    i5 3570K
    Graphics:
    Sapphire 7870 OC
    Feb 23, 2013 at 2:58 PM #1
    PeZoR

    PeZoR

    Joined:
    Feb 23, 2013
    Messages:
    4
    Mobo:
    Custom Gamer
    CPU:
    i5 3570K
    Graphics:
    Sapphire 7870 OC
    Hey Guys!

    I decided to try making a Hackintosh out of my actual Windows machine, but I'm not sure if my Motherboard supports this?
    It's an Asrock Z77 Pro4, furthermore the CPU is an Intel 3570K, GPU is an Sapphire 7870 OC.
    I would describe myself as Pro-User, but unfortunately only in Windows Spheres, but as said I want to try Mac Os X in everyday usage, because I like the User Interface quite much.

    So now to my Question: Will everything work after the installation? Is there someone who already was successful with the installation?
    Which Options will I have to tick in Multibeast?

    I hope there is someone who can help me!

    Greets

    PS: Sorry if there are some mistakes in my text, I'm out of Austria (no, not Australia :D).
    PPS: Here is a list of all my components: http://geizhals.at/eu/?cat=WL-234003
     
  2. stehor

    stehor

    Joined:
    Feb 3, 2011
    Messages:
    1,405
    Mobo:
    asrock pro 3 bois 2.10
    CPU:
    i5 3570k macmini6,1
    Graphics:
    hd4000
    Feb 23, 2013 at 8:46 PM #2
    stehor

    stehor

    Joined:
    Feb 3, 2011
    Messages:
    1,405
    Mobo:
    asrock pro 3 bois 2.10
    CPU:
    i5 3570k macmini6,1
    Graphics:
    hd4000
    yes it will please edit profile/signature with all hardware specs ram hdd dvd rom ect. look in user builds
     
  3. PeZoR

    PeZoR

    Joined:
    Feb 23, 2013
    Messages:
    4
    Mobo:
    Custom Gamer
    CPU:
    i5 3570K
    Graphics:
    Sapphire 7870 OC
    Feb 23, 2013 at 9:43 PM #3
    PeZoR

    PeZoR

    Joined:
    Feb 23, 2013
    Messages:
    4
    Mobo:
    Custom Gamer
    CPU:
    i5 3570K
    Graphics:
    Sapphire 7870 OC
    OK, thanks for the answer!

    I edited my Profile Information, I hope everything is as it should be now! :thumbup:

    One more questions: Could you or anyone else say me which options I should tick in Multibeast?

    Thanks,
    Greets
     
  4. stehor

    stehor

    Joined:
    Feb 3, 2011
    Messages:
    1,405
    Mobo:
    asrock pro 3 bois 2.10
    CPU:
    i5 3570k macmini6,1
    Graphics:
    hd4000
    Feb 23, 2013 at 10:15 PM #4
    stehor

    stehor

    Joined:
    Feb 3, 2011
    Messages:
    1,405
    Mobo:
    asrock pro 3 bois 2.10
    CPU:
    i5 3570k macmini6,1
    Graphics:
    hd4000
    sent u a screen shot use this 1 it has nullcpumanagement kext or u get a kp. ur mobo doesnt have native power management
     
  5. MiniITX

    MiniITX

    Joined:
    Sep 26, 2012
    Messages:
    1,359
    Mobo:
    ASRock H67M-ITX/HT
    CPU:
    i5 2500K
    Graphics:
    HD3000
    Mac:
    iMac, MacBook Pro, Mac mini
    Mobile Phone:
    iOS
    Feb 24, 2013 at 1:44 PM #5
    MiniITX

    MiniITX

    Joined:
    Sep 26, 2012
    Messages:
    1,359
    Mobo:
    ASRock H67M-ITX/HT
    CPU:
    i5 2500K
    Graphics:
    HD3000
    Mac:
    iMac, MacBook Pro, Mac mini
    Mobile Phone:
    iOS
    To avoid any post installation issues flash the BIOS with modded BIOS ROM > http://biosrepo.wordpress.com/asrock/z77/

    Sleep on ASRock motherboard works only with a DSDT with correct edits. Let me know if you need any help.
     
  6. PeZoR

    PeZoR

    Joined:
    Feb 23, 2013
    Messages:
    4
    Mobo:
    Custom Gamer
    CPU:
    i5 3570K
    Graphics:
    Sapphire 7870 OC
    Feb 24, 2013 at 3:31 PM #6
    PeZoR

    PeZoR

    Joined:
    Feb 23, 2013
    Messages:
    4
    Mobo:
    Custom Gamer
    CPU:
    i5 3570K
    Graphics:
    Sapphire 7870 OC
    Hmm...

    What advantages do I get if I flash my Bios instead of ticking Easybeast installation in Multibeast?
    I don't like flashing Bios'es cause i bricked a few because the progress got interrupted... :banghead:

    How are the Costum Bios'es of that page flashed? Is there a .exe or how get they flashed?

    Greez
     
  7. MiniITX

    MiniITX

    Joined:
    Sep 26, 2012
    Messages:
    1,359
    Mobo:
    ASRock H67M-ITX/HT
    CPU:
    i5 2500K
    Graphics:
    HD3000
    Mac:
    iMac, MacBook Pro, Mac mini
    Mobile Phone:
    iOS
    Feb 25, 2013 at 3:42 AM #7
    MiniITX

    MiniITX

    Joined:
    Sep 26, 2012
    Messages:
    1,359
    Mobo:
    ASRock H67M-ITX/HT
    CPU:
    i5 2500K
    Graphics:
    HD3000
    Mac:
    iMac, MacBook Pro, Mac mini
    Mobile Phone:
    iOS
  8. PeZoR

    PeZoR

    Joined:
    Feb 23, 2013
    Messages:
    4
    Mobo:
    Custom Gamer
    CPU:
    i5 3570K
    Graphics:
    Sapphire 7870 OC
    Aug 14, 2013 at 11:10 PM #8
    PeZoR

    PeZoR

    Joined:
    Feb 23, 2013
    Messages:
    4
    Mobo:
    Custom Gamer
    CPU:
    i5 3570K
    Graphics:
    Sapphire 7870 OC
    Hello again!

    I finally tried to set up the Hackintosh and have a big problem.
    I have the Unibeast Stick ready with Mountain Lion, but i can only boot into OS X with GraphicsEnabler=0... :(

    That means that i have no Graphic Accelleration and can't use the full 1920x1080 resolution of my monitor.

    Any tips from you?

    Greets from Austria
     
  9. MiniITX

    MiniITX

    Joined:
    Sep 26, 2012
    Messages:
    1,359
    Mobo:
    ASRock H67M-ITX/HT
    CPU:
    i5 2500K
    Graphics:
    HD3000
    Mac:
    iMac, MacBook Pro, Mac mini
    Mobile Phone:
    iOS
    Aug 15, 2013 at 7:49 PM #9
    MiniITX

    MiniITX

    Joined:
    Sep 26, 2012
    Messages:
    1,359
    Mobo:
    ASRock H67M-ITX/HT
    CPU:
    i5 2500K
    Graphics:
    HD3000
    Mac:
    iMac, MacBook Pro, Mac mini
    Mobile Phone:
    iOS
    The GPU you are using requires a flag GraphicsEnabler=No to work properly. Graphics should work fine with that flag.
    Read some threads using forum search.
     
  10. JJonas808

    JJonas808

    Joined:
    Oct 19, 2015
    Messages:
    25
    Mobo:
    ASRock Extreme4 Z77
    CPU:
    i7 3770k
    Graphics:
    MSI GTX 980 ti
    Mac:
    Mac Pro
    Mobile Phone:
    Android
    Oct 21, 2015 at 7:00 PM #10
    JJonas808

    JJonas808

    Joined:
    Oct 19, 2015
    Messages:
    25
    Mobo:
    ASRock Extreme4 Z77
    CPU:
    i7 3770k
    Graphics:
    MSI GTX 980 ti
    Mac:
    Mac Pro
    Mobile Phone:
    Android
    I know this thread is older, but I'm on an ASRock Pro4 Z77 too...and a total noob here.

    Do you still have that screenshot? Which options to tick in Multi? BTW, mine seems to sleep just fine, though I haven't even ran Multibeast yet. Particularly want to get the ethernet working, so I can go online with it :)

    **EDIT:: Oops...just realized this is the Mountain Lion Forum--I am going for a Yosemite install***

    I'm builiding a dual-boot, with W7 x64 already on a SSD (Yosemite on separate SSD). Should I still flash the BIOS? Worried about my W7 configuration not working properly.

    Thanks!
     

Share This Page