Contribute
Register

AsRock X299 Creator

Joined
Jul 20, 2014
Messages
925
Motherboard
AsRock X299 Creator-1.50
CPU
i9-10900X
Graphics
RX 6800 XT
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Thanks, i upgraded from x299 deluxeii to creator board because i did not want the 3rd nvme sticking out and 5Gb lan never worked. At first it did not boot at all!. then i used supplied efi folder in this thread. everything booted successful. then i copied my old serial number smuuid reboot again. and every plugin is activated.
Nice
Change your signature ;)
 
Joined
Nov 11, 2010
Messages
43
Motherboard
x299 creator
CPU
i9 9900x
Graphics
radeon vii
*SOLVED*

figured out 44 lanes m2 2 disabled
-----------------------------------------------------------------------------------------------


ok now here comes my issue.
anyone using 3 nvme?

i have populated 3 nvme. the middle one bios wont detect. my cpu is i9 9900x
it has
Max # of PCI Express Lanes
44

i have tried graphic card on slot one and three bios wont detect my nvme_2. also have disabled thunderbolt 10G Lan.

same problem.
 
Last edited:
Joined
Apr 3, 2017
Messages
51
Motherboard
ASRock X299 Creator
CPU
i9-10920X
Graphics
Radeon VII
Mac
  1. MacBook
  2. MacBook Pro
  3. Mac mini
  4. Mac Pro
Classic Mac
  1. Classic
  2. iBook
  3. Plus
  4. Power Mac
  5. PowerBook
  6. SE
Mobile Phone
  1. iOS
Thanks, i upgraded from x299 deluxeii to creator board because i did not want the 3rd nvme sticking out and 5Gb lan never worked. At first it did not boot at all!. then i used supplied efi folder in this thread. everything booted successful. then i copied my old serial number smuuid reboot again. and every plugin is activated.
Is thunderbolt working for you? I still have the issue where even usb-c items won't "get power" from that port. Even though its enabled in the bios. I had it working once early on back in the early portions of this thread, but its been disabled since early summer. Just curious if its working for you.
 
Joined
Nov 11, 2010
Messages
43
Motherboard
x299 creator
CPU
i9 9900x
Graphics
radeon vii
Is thunderbolt working for you? I still have the issue where even usb-c items won't "get power" from that port. Even though its enabled in the bios. I had it working once early on back in the early portions of this thread, but its been disabled since early summer. Just curious if its working for you.
i am using tb3 to tb2 and using apogee element24 soundcard it works perfect and also can hotplug.
 
Joined
Apr 3, 2017
Messages
51
Motherboard
ASRock X299 Creator
CPU
i9-10920X
Graphics
Radeon VII
Mac
  1. MacBook
  2. MacBook Pro
  3. Mac mini
  4. Mac Pro
Classic Mac
  1. Classic
  2. iBook
  3. Plus
  4. Power Mac
  5. PowerBook
  6. SE
Mobile Phone
  1. iOS
i am using tb3 to tb2 and using apogee element24 soundcard it works perfect and also can hotplug.
Thanks for letting me know. Do you see "power" during preboot / bios loading to the ports? Or not until OS X loads? (I don't even get power at the bios level).

I have 3 nvme so I'll try that at some point. I *did* put one in slot 1 right around the time I lost those ports so maybe that's related. Currently I have them in slot m1 and slot m3
 
Joined
Apr 3, 2017
Messages
51
Motherboard
ASRock X299 Creator
CPU
i9-10920X
Graphics
Radeon VII
Mac
  1. MacBook
  2. MacBook Pro
  3. Mac mini
  4. Mac Pro
Classic Mac
  1. Classic
  2. iBook
  3. Plus
  4. Power Mac
  5. PowerBook
  6. SE
Mobile Phone
  1. iOS
@hotbullet - also if you use radeonboost combined with some PP_ parameters in your config (disablePowerContainment) you can get much better metal/opencl performance on your VII (My Geekbench metal is around 95k).

Some think this only applies to benchmarks, but I think I'm seeing better performance in fcpx, redcine, capture one and affinity so I believe it applies to actual workflows too
 
Joined
Nov 11, 2010
Messages
43
Motherboard
x299 creator
CPU
i9 9900x
Graphics
radeon vii
@hotbullet - also if you use radeonboost combined with some PP_ parameters in your config (disablePowerContainment) you can get much better metal/opencl performance on your VII (My Geekbench metal is around 95k).

Some think this only applies to benchmarks, but I think I'm seeing better performance in fcpx, redcine, capture one and affinity so I believe it applies to actual workflows too
Interesting how much metal score do you get before radeonboost and PP ? i get only 50k. after reading your post i radeonboost.kext jumped to 75k. I have no idea how to PP. you need what software? Also at the moment i am thinking and actually trying to add asus m.2 hyper on my board. because my cpu is 44 lanes and if you have 44 lane cpu m2_2 is disabled.
 
Joined
Apr 3, 2017
Messages
51
Motherboard
ASRock X299 Creator
CPU
i9-10920X
Graphics
Radeon VII
Mac
  1. MacBook
  2. MacBook Pro
  3. Mac mini
  4. Mac Pro
Classic Mac
  1. Classic
  2. iBook
  3. Plus
  4. Power Mac
  5. PowerBook
  6. SE
Mobile Phone
  1. iOS
Interesting how much metal score do you get before radeonboost and PP ? i get only 50k. after reading your post i radeonboost.kext jumped to 75k. I have no idea how to PP. you need what software? Also at the moment i am thinking and actually trying to add asus m.2 hyper on my board. because my cpu is 44 lanes and if you have 44 lane cpu m2_2 is disabled.
Between 55-60k usually. You can read about the adjustments from the author. You are basically just setting device properties for the PCI device, so that the driver decides how to use that device. Disablepowercontainment is a good one for the vii, letting it handle its power levels on its own. https://forums.macrumors.com/threads/tired-of-low-geekbench-scores-use-radeonboost.2231366/

I'll attach a screenshot and xml of what I have for mine. You use the device properties section of open core and specify the PCI path for your gpu. If its in the top slot, it should be like so...

Note that this is what I've used since May or so, I haven't changed/tested any actual power play table modification.

XML:
<key>PciRoot(0x2)/Pci(0x0,0x0)/Pci(0x0,0x0)/Pci(0x0,0x0)/Pci(0x0,0x0)</key>
            <dict>
                <key>CFG_NVV</key>
                <integer>2</integer>
                <key>CFG_PTPL2_CNT</key>
                <integer>16</integer>
                <key>CFG_PTPL2_MAX</key>
                <integer>300</integer>
                <key>CFG_PTPL2_MIN</key>
                <integer>90</integer>
                <key>CFG_TPS1S</key>
                <integer>1</integer>
                <key>PP,PP_DisableULV</key>
                <integer>0</integer>
                <key>PP,PP_WorkLoadPolicyMask</key>
                <integer>32</integer>
                <key>PP_ACDCGpioDisabled</key>
                <integer>0</integer>
                <key>PP_DiDtSQPatternWidthOverride</key>
                <integer>14</integer>
                <key>PP_DiDtSQStallPatternOverride</key>
                <integer>16383</integer>
                <key>PP_DisableDIDT</key>
                <integer>1</integer>
                <key>PP_DisablePCCLimitControl</key>
                <integer>1</integer>
                <key>PP_DisablePowerContainment</key>
                <integer>1</integer>
                <key>PP_DisableULV</key>
                <integer>0</integer>
                <key>PP_FclkGfxClkRatio</key>
                <integer>1036831949</integer>
                <key>PP_PhmUseDummyBackEnd</key>
                <integer>0</integer>
                <key>PP_WorkLoadPolicyMask</key>
                <integer>32</integer>
            </dict>
 

Attachments

  • viiboost.png
    viiboost.png
    141.1 KB · Views: 37
Joined
Nov 11, 2010
Messages
43
Motherboard
x299 creator
CPU
i9 9900x
Graphics
radeon vii
my board is running fine but i just would like to know what is the main difference in kext or ssdt that this one has from the original x299 board. what is mandatory step to make this work, i have been reading all the post in this thread and lots more to go on, thanks

my journey started same like first picture of oli.


oli.mathieu and Loloflatsix thanks for making this possible.​

 
Last edited:
Top