Contribute
Register

AsRock X299 Creator

Joined
Apr 3, 2017
Messages
51
Motherboard
ASRock X299 Creator
CPU
i9-10920X
Graphics
Radeon VII
Mac
  1. MacBook
  2. MacBook Pro
  3. Mac mini
  4. Mac Pro
Classic Mac
  1. Classic
  2. iBook
  3. Plus
  4. Power Mac
  5. PowerBook
  6. SE
Mobile Phone
  1. iOS
Two things about your files :
In the config.plist you don't have Trim patch enable for your SSDs
A recent change in SSDT-AWAC happens for our mobo
I will take care of the nvram soon.

Thanks for the note on AWAC.

I had the "thirdpartydrives" property enabled, which should enable trim on AHCI ssds. according to the docs, you shouldn't need this for NVME as trim is enabled by the OS. Is there another patch you are talking about?

My emulated Nvram seemed to break after the last 10.15.4 update. Also, my TB3 usb has gone missing again (shows in ioreg but no power to devices)
 
Joined
Apr 3, 2017
Messages
51
Motherboard
ASRock X299 Creator
CPU
i9-10920X
Graphics
Radeon VII
Mac
  1. MacBook
  2. MacBook Pro
  3. Mac mini
  4. Mac Pro
Classic Mac
  1. Classic
  2. iBook
  3. Plus
  4. Power Mac
  5. PowerBook
  6. SE
Mobile Phone
  1. iOS
Joined
Jul 20, 2014
Messages
925
Motherboard
AsRock X299 Creator-1.50
CPU
i9-10900X
Graphics
RX 6800 XT
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
I had the "thirdpartydrives" property enabled, which should enable trim on AHCI ssds. according to the docs, you shouldn't need this for NVME as trim is enabled by the OS. Is there another patch you are talking about?
I didn't know that . Thanks
My emulated Nvram seemed to break after the last 10.15.4 update. Also, my TB3 usb has gone missing again (shows in ioreg but no power to devices)
Mine is still here ...
Check your fast boot / memory test settings under overclocking -> dram
You advise me to activate the fast boot ? ... i'll try
RAM Xmp enable/disable ➧ same slow boot
CPU tuboBoos 3.0 Native/Enable ➧ same slow boot
If it's BIOS setting, it would logically a CPU setting, because it boot normally with another CPU 7940X, isn't it ?

Enabling Nvram is also a failure ... I feel I strictly followed the manual
[EDIT] it's now working ... don't ask me how:lol:
Thanks again
 
Last edited:
Joined
Apr 3, 2017
Messages
51
Motherboard
ASRock X299 Creator
CPU
i9-10920X
Graphics
Radeon VII
Mac
  1. MacBook
  2. MacBook Pro
  3. Mac mini
  4. Mac Pro
Classic Mac
  1. Classic
  2. iBook
  3. Plus
  4. Power Mac
  5. PowerBook
  6. SE
Mobile Phone
  1. iOS
@Loloflatsix @dolgarrenan @Ellybz - Have you been able to get native nvram working on the x299 creator? I've been experimenting with the PMCR ssdt fix for z390, (and all variants of OC quirks related). Still no luck, and curious if you've had any?
 
Joined
Jul 20, 2014
Messages
925
Motherboard
AsRock X299 Creator-1.50
CPU
i9-10900X
Graphics
RX 6800 XT
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Hello
Quick Update
OpenCore 0.5.9 with GUI (attached file has no Serials)

Issues remaining
1 - The BIG one is the slow boot with the i9-10900X CPU. Windows is fine, MacOS is fine with i9-7940X or i9-10940X!!
Help is truly needed :wave:
2 - no native Ram Support (Startup disk pref pane doesn't work). But with CTRL+ENTER in OC GUI I managed to define the default boot drive.
3 - I can't Update to 10.15.5, I suspecting the cloning software ➧ I will start a fresh instal from USB
EDIT
4 - if I chose another boot drive via the Bootmenu ➧ this seems persistent (becomes the new 1st boot priority)
5 - each time I plug another boot drive (via USB or SATA), it becomes the new 1st boot priority

have a nice day
 

Attachments

  • X299 AsRock Creator OC59 MacOS10.15.4.zip
    7.1 MB · Views: 85
Last edited:
Joined
Jul 20, 2014
Messages
925
Motherboard
AsRock X299 Creator-1.50
CPU
i9-10900X
Graphics
RX 6800 XT
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
About i9-10900X
I ran Intel® Processor Diagnostic Tool and failed one test
I return it and buy a new one ....
Keep you posted
 

Attachments

  • TESTRESULTS 10900X.TXT
    8.8 KB · Views: 76
Joined
Jul 20, 2014
Messages
925
Motherboard
AsRock X299 Creator-1.50
CPU
i9-10900X
Graphics
RX 6800 XT
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Shared PCIe lanes
USB discovery ports
X299 Creator - Partage de Lignes PCI.png
 
Joined
Jul 20, 2014
Messages
925
Motherboard
AsRock X299 Creator-1.50
CPU
i9-10900X
Graphics
RX 6800 XT
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Trouble AGAIN
I change my CPU to an 9900X ... The same OC folder work
Last week I bought a brand new 10900X and it boots very slowly ( I can read the verbose and english is not my native language :lol: )... like I've already mentioned at the begentnig of this thread

here's the open core log file (DEBUG VERSION 0.6.0)
If anyone see any error and know how to resolve it
Thanks in advance
 

Attachments

  • opencore-2020-08-25-044809.txt
    256 KB · Views: 63
Top