Contribute
Register

ASRock deskmini 310/com issue

Status
Not open for further replies.
Joined
Feb 16, 2018
Messages
15
Motherboard
ASUS PRIME-Z370-P
CPU
i5-8400
Graphics
GTX 1060
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
I have installed High Sierra (17G5019) on AsRock deskmini 310/com.

Main components:
  • ASRock deskmini 310/com website
  • i3 8100
  • Samsung PM961 256G M.2 NVME
  • ADATA 8G DDR4 2400
  • Broadcom BCM94352Z wifi/Bluetooth
What i've done:
  • macOS High Sierra 10.13.6(17G5019)
  • UniBeast-8.3.2
Bios Set:
  • Load UEFI Defaults
  • Advanced
    • CPU Configuration / Intel Virtualization Technology: Disabled
    • Chipset Configuration
      • VT-d: Disabled
      • Onboard HD Audio: Enabled
    • USB Configuration, XHCI Hand-off, Enabled
    • Super IO Configuration, Serial Port, Disabled
  • Security
    • Secure Boot, Disabled(by default)
Issue: when i'm arrived on "choose the language", keyboard and mouse don't work.
Solution: Put USBInjectAll.kext in /EFI/CLOVER/kexts/Other/, and use USB 2.0 port on deskmini310. (PS: when you install clover on your deskmini by MultiBeast, you should copy USBInjectAll.kext too)

There are something to work.

  1. [√] lan(Intel Gigabit I219V)
  2. [√] audio(Realtek ALC233)
  3. [√] USB 3.0 port
  4. [√] wifi/Bluetooth(Broadcom BCM94352Z)
  5. [√] graphics(UHD630)
MultiBeast 10.4.0

1) lan(Intel Gigabit I219V)
  • Drivers >
    • Network > Intel > IntelMausiEthernet v2.4.0
2) audio(Realtek ALC233)

restart
  • Drivers > Audio
    • H310 / B360 / H370 / Q370 Audio Device ID Patch
restart
  • Drivers > Audio
    • Universal VodooHDA v2.9.0d10
select the audio output device: 'Not connected' , and it will be ok :)

3) USB 3.0 port
  • Download the latest Clover Configurator Global Version
  • Mount EFI
  • Right-click open config.plist with Clover Configurator
  • Click Kernel and Kext Patches under SECTIONS of Clover Configurator
  • Click the “+” button near the bottom to add this patch:
    • Name*: com.apple.driver.usb.AppleUSBXHCI
    • Find* [HEX]: 837D880F 0F83A704 0000
    • Replace* [HEX]: 837D880F 90909090 9090
    • Comment: USB 10.13.6+ by PMHeart
    • MatchOS: 10.13.x
  • Save config.plist
4) Broadcom BCM94352Z

wifi:
Download RehabMan / OS-X-Fake-PCI-ID, install two files to /Library/Extensions

FakePCIID.kext
FakePCIID_Broadcom_WiFi.kext

use Kext Utility and reboot
add config-bcm94352-130.plist to your config.plist

Bluetooth:
Download RehabMan / OS-X-BrcmPatchRAM, install two files to EFI/CLOVER/kexts/Other or /System/Library/Extensions

BrcmFirmwareRepo.kext
BrcmPatchRAM2.kext

5) graphics(UHD630)

add Lilu.kextWhateverGreen.kext to EFI/CLOVER/kexts/Other, add -lilubetaall to boot arguments

use Clover Configurator Global Version set your SMBIOS as iMac18,1

use Hackintool to patch:

386548


after this patch, you should use DP port and hdmi port is not enable.
 

Attachments

  • config.plist
    10.4 KB · Views: 500
  • EFI.zip
    25.5 MB · Views: 644
Last edited:
Joined
Mar 29, 2013
Messages
122
Motherboard
Asrock b85m itx
CPU
i7-4770s
Graphics
HD 4600
Hi,

Did you get High Sierra working now?

Did you try following the older Deskmini 110 guide?

Deskmini Hackintosh instructions 170421 - TonyMacX86

I too am looking to get a Deskmini 310 and would be grateful to hear if you got it working and if there are any outstanding issues.
 
Joined
Feb 16, 2018
Messages
15
Motherboard
ASUS PRIME-Z370-P
CPU
i5-8400
Graphics
GTX 1060
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Joined
Mar 11, 2016
Messages
18
Motherboard
HM77
CPU
I5-3210M
Graphics
HD4000
Mac
Classic Mac
Mobile Phone
can you share your efi files with me ? i get some problemes with deskmini 310... thanks!
 
Joined
Nov 5, 2018
Messages
7
Motherboard
Asrock Deskmini 310
CPU
I7-8700
Graphics
UHD 630
Hi jmukirin

Is it ok for you to share your EFI/EFI and EFI/Clover files? (kexts, config.plist etc...)

It would be really helpful for building hackintosh on this machine, thank you.
 
Joined
Oct 14, 2013
Messages
8
Motherboard
ASRock DeskMini310
CPU
i5-8400
Graphics
UHD 630
Mac
  1. iMac
Mobile Phone
  1. Android
almost, you can see my post update
Hi,did U solved shutdown restart ?
I have bought the same machine with 8400 to replace macmini.
 
Joined
Nov 11, 2018
Messages
10
Motherboard
ASRock
CPU
i5-8500
Graphics
UHD 630
I'm trying to install Majove on my Deskmini 310.

Main components:
- i5 8500
- Samsung 970evo 500G M.2 NVME
- TeamGroup 8G DDR4 2400 x2

When boot macOS Install from my ssd, I stuck into boot loop. It says installing. See the picture.


Then reboot. I choose verbose mode in clover, but the log is too fast too take a picture.

Do u have any advice? Please tell me. Thank you!
 

Attachments

  • 6584FD20F366DDE62E98BA07F75C796F.jpg
    6584FD20F366DDE62E98BA07F75C796F.jpg
    1.4 MB · Views: 257
Joined
Nov 11, 2018
Messages
10
Motherboard
ASRock
CPU
i5-8500
Graphics
UHD 630
I'm trying to install Majove on my Deskmini 310.

Main components:
- i5 8500
- Samsung 970evo 500G M.2 NVME
- TeamGroup 8G DDR4 2400 x2

When boot macOS Install from my ssd, I stuck into boot loop. It says installing. See the picture.


Then reboot. I choose verbose mode in clover, but the log is too fast too take a picture.

Do u have any advice? Please tell me. Thank you!

Fixed. Change ssd to apfs, then everthing is ok.
 
Status
Not open for further replies.
Top