Contribute
Register

ASRock Deskmini 110 issues

Joined
Aug 18, 2016
Messages
33
OS X was able to detect my 8GB x 2 memory on my H110M-STX until I installed Multibeast.
I used Clover Configurator to fix it by inserting the relevant memory sections...

Which Broadcom BT/WiFi card are you using?
 

tonymacx86

Administrator
Staff member
Joined
Nov 18, 2009
Messages
8,597
Motherboard
Z370N WIFI
CPU
Core i7 8700K
Graphics
Radeon RX Vega 56
Mac
MacBook Air
Classic Mac
Apple, PowerBook
Mobile Phone
iOS
A BIOS fix has been released by Asrock for the H110M-STX:
http://www.asrock.com/mb/Intel/H110M-STX/?cat=Beta

Each of bios settings below is necessary, or the installation process will suffer unexpected error and fail.

1. If your CPU supports VT-d, disable it

2. IOAPIC 24-119 Entries, disable it

3. If your system has Secure Boot Mode, disable it

4. If your system has IO Serial Port, disable it

5. Set XHCI Handoff to Enabled

Hope this helps!
 
Joined
Aug 18, 2016
Messages
33
Tony, Tony, Tony, the BIOS fix works!!! Thank you. How did you make ASRock to create this BIOS specifically to support MAC OS X installation?

Now I can boot into macOS without the need of a USB Bluetooth adapter!

Test Log
H110M-STX BIOS fix
Version = 1.41
Date = 9/14/2016
Size = 5.87MB

BIOS fix Description
1.Support MAC OS X installation
2.COM Port set to disable

Download - http://www.asrock.com/mb/Intel/H110M-STX/?cat=Beta

BIOS Settings applied
CPU VT-d = disabled
IOAPIC 24-119 Entries = disabled
Secure Boot Mode= disabled
IO Serial Port = My H110M-STX does not has IO Serial Port, i do not see such a setting in BIOS
XHCI Handoff = Enabled

Test Result
macOS tested = 10.11.6

Before applying the BIOS Fix = USB Bluetooth adapter must be plugged in. Otherwise, macOS goes Kernel Panic (IOBluetoothHostControllerUARTTransport)

After applying the BIOS Fix = USB Bluetooth adapter no longer required. macOS boot successfully
 
Joined
May 11, 2013
Messages
35
Motherboard
ASUS P8H61-i r2.0
CPU
I3-6100
Graphics
Intel HD530
Mac
Mac mini
That was fast ! I expected it "someday" not a few days. Mine is still running smooth and silent. Good to have for future reference though. Thanks guys.
 
Joined
Aug 21, 2016
Messages
6
Motherboard
Asrock H110M-STX
CPU
I5-6500
Graphics
Intel HD530
Mac
iMac
IO Serial Port = My H110M-STX does not has IO Serial Port, i do not see such a setting in BIOS
What they did was to disable it in the BIOS. The issue initially was it was enabled by default although we do not have a com port at all. They must have just set the BIOS default to disable.

They must have responded to my help desk ticket and forum post (I'm BigMcLargeHuge over there)! I got a reply on September 7th that they were looking into it and I guess they decided to do it. Of course I've already edited my DSDT and now have my Hackintosh nearly finished. I just need to test the Broadcom Wifi and Bluetooth. It is a splendid little box and the
 
Joined
Nov 9, 2014
Messages
4
Mac
Classic Mac
Mobile Phone
Hey, I bought one of these machines after seeing this post. I've got El Capitan 10.11.6 installed but I'm having some issues. I've got LAN & graphics working but I can't get Audio working. I've tried the ALC283 package in MultiBeast but that's not working for me. Could you do a tutorial post please @mopidicks?
 
Joined
Aug 18, 2016
Messages
33
I just checked my build and I don't have the ALC283 working too. Let me try to fix it in the next few days....
 
Joined
May 11, 2013
Messages
35
Motherboard
ASUS P8H61-i r2.0
CPU
I3-6100
Graphics
Intel HD530
Mac
Mac mini
To get that working I had to do it twice. The second time I mounted the clover EFI partition then I added the alc283 (nuc only) kext with Multibeast by itself. No other picks from MB. Then I had headphone front jack audio to my receiver and it survives rebooting. I learned it from using the Skylake NUC Guide thread for El Cap.
 
Joined
Nov 9, 2014
Messages
4
Mac
Classic Mac
Mobile Phone
Thanks for the replies. I've tried installing the ALC283 kext twice like you said making sure the EFI partition was mounted but I still can't get it working. I've also tried a new install from scratch following that Skylake NUC guide, just without changing the SSDTs, etc. Any ideas? :)
 
Joined
Oct 16, 2011
Messages
18
Motherboard
Asrock H110M-STX
CPU
Core i5 6500
Graphics
Intel HD 530
Mac
Mac mini
Mobile Phone
Android
Any news? My Deskmini+Dell wifi/bt will arrive next week!
 
Top