Contribute
Register

AR8161 LAN on new MoBo revisions (ga-z77-ds3h and ga-h77-ds3h, others)

Joined
Jan 11, 2012
Messages
43
Motherboard
GA-H77-DS3H
CPU
i7 3770
Graphics
Galaxy GeForce GTX 670
Mac
MacBook
Mobile Phone
iOS
Hey guys and gals,
I decided to buy the GA-H77-ds3h because it was recommended in the CustoMac Buyer's Guide. Good board overall, installation was pretty easy. However, the problem is that the latest revision of this board (and the Z77 variant) includes a different LAN card than the original. The original had an AR8151 and the new one has the AR8161. Maolj's AtherosL1c doesn't work with the AR8161 so for now anyone who bought this motherboard might be a little angry. I'm not that pissed off about it, because I'm sure eventually Maolj's kext will be updated to work with this networking chip. And I also have a mini-pcie to pciex1 adapter coming in the mail that I will use with my re-branded BCM4322 wifi card. That will be fine while we wait for the new LAN driver. But I don't know if iCloud and MacAppStore will work with it, I'll let you guys know. Does anyone have experience porting Linux drivers to Mac OS? I wanted to get a thread started for other people with the same problem, to make a place for testing and hopefully get in contact with Maolj himself so we can all work together. I don't know if this person has a blog or website, can't find much info about him/her. I saw a few threads with the same issue but they are all dead-ends and don't mention that an actual PERSON made the driver and he/she might not be aware of the issue. So, Maolj, if you are out there, please update us. And everyone else, maybe collectively we can get the ball rolling.
 
Joined
Oct 24, 2012
Messages
1
Motherboard
Hackintosh
CPU
i5-3570K
Graphics
Integrated
Mac
Classic Mac
Mobile Phone
I am hoping the same as I followed a sample build for my first hackintosh and have resigned to order the TP-Link 450Mbps Dual Band Wireless N PCI-E Adapter (TL-WDN4800) until a kext update is available.
 
Joined
Oct 25, 2012
Messages
5
Motherboard
GA-Z77-DS3H v1.0
CPU
i5-3570k
Graphics
Intel HD 3000 / nVidia GTX 560 Ti
Mac
Classic Mac
Mobile Phone
Exactly the same issue here, though it does looks like I've got revision 1.0 of the MoBo, but the chipset of the NIC matches yours. Unfortunately, everything I've tried has failed and now have to purchase a sep. NIC to get any internet access. Hopefully there is an update!
 
Joined
Aug 10, 2012
Messages
11
Motherboard
GIGABYTE h77-ds3h ver. 1.1
CPU
i3 intel
Graphics
gigabyte built in
Mac
MacBook Pro
Classic Mac
iMac
Mobile Phone
Other
that card works right out of the box without any drivers.
 
Joined
Oct 25, 2012
Messages
5
Motherboard
GA-Z77-DS3H v1.0
CPU
i5-3570k
Graphics
Intel HD 3000 / nVidia GTX 560 Ti
Mac
Classic Mac
Mobile Phone
that card works right out of the box without any drivers.
What card? The build-in NIC? It def. doesn't. In fact, in OSX it doesn't even show up as hardware that I can see. A few others have reported the problem with the change in the chipset for the NIC has caused problems with this MoBo very recently. I was definitely under the impression that it would work seamlessly though!
 
Joined
Aug 10, 2012
Messages
11
Motherboard
GIGABYTE h77-ds3h ver. 1.1
CPU
i3 intel
Graphics
gigabyte built in
Mac
MacBook Pro
Classic Mac
iMac
Mobile Phone
Other
TP-Link 450Mbps Dual Band Wireless N PCI-E Adapter (TL-WDN4800) will work on ml before you use multibeast installation are applied to your computer. After the first boot up of Ml i use my internet to download Multibeast.
 
Joined
Jan 11, 2012
Messages
43
Motherboard
GA-H77-DS3H
CPU
i7 3770
Graphics
Galaxy GeForce GTX 670
Mac
MacBook
Mobile Phone
iOS
TP-Link 450Mbps Dual Band Wireless N PCI-E Adapter (TL-WDN4800) will work on ml before you use multibeast installation are applied to your computer. After the first boot up of Ml i use my internet to download Multibeast.
Can you verify that iCloud and App Store work with the add-in card?
 
Joined
Jan 11, 2012
Messages
43
Motherboard
GA-H77-DS3H
CPU
i7 3770
Graphics
Galaxy GeForce GTX 670
Mac
MacBook
Mobile Phone
iOS
Exactly the same issue here, though it does looks like I've got revision 1.0 of the MoBo, but the chipset of the NIC matches yours. Unfortunately, everything I've tried has failed and now have to purchase a sep. NIC to get any internet access. Hopefully there is an update!
Which card did you buy? Wired or WiFi? Personally I'd prefer wired because I have a home media server setup with high bit rate content streaming to various computers my family members use (combination of windows media center with ceton cable tuner and plex). So wifi is too laggy between everyone in the house.
I am enjoying this board though. I might buy an M-sata ssd because it seems like that port is going to waste, and I'm using up all the other sata ports.
 
Joined
Oct 23, 2012
Messages
49
Motherboard
MSI H97M-G43
CPU
i7 4790 @ 3,6 GHz
Graphics
KFA2 GTX 1070 EX
Mac
iMac
Mobile Phone
iOS
Can you verify that iCloud and App Store work with the add-in card?
No it definitely won't, because the Ethernet is not working just for now. I also got the ds3h rev. 1 and FCP X works frickin' awesome with my 3570, AppStore and iCloud aren't though.

Thats why I ordered a RTL8169 Chipset based PCI Ethernet card, which should arrive by Tuesday. Hopefully I will get the AS and iCloud to work as it is a pain in the a** to not have a kext for the ar8161 as of yet. ;)
 
Joined
Oct 24, 2012
Messages
40
Motherboard
Gigabyte Z77-DS3H Rev 1.1 F7 bios
CPU
Intel i5 3750K
Graphics
GeForce GT 610
Mac
MacBook Pro
Classic Mac
Mobile Phone
Android
Just wanted to jump in and say I have the same issue. No ethernet on a Giga Z77-DS3H / i5 3570K build. I am heading out to COMPUSA right now to see if I can find a PCI card that will work.

P.S. I also need firewire. Any recommendations?

Thanks,
Frank
 
Top