Contribute
Register

Aquantia LAN port support

MacMan

Administrator
Staff member
Joined
Feb 2, 2010
Messages
8,232
Motherboard
ASUS ROG STRIX Z370-E GAMING - 1601 - UEFI
CPU
i7-8700K
Graphics
Vega 64
Mac
MacBook Pro, Mac Pro
Classic Mac
Power Mac, PowerBook
Mobile Phone
iOS
Joined
Feb 2, 2011
Messages
5
Motherboard
Z87X-UD4H
CPU
i7-4770K
Graphics
RX 560
Mac
iMac, MacBook Air, Mac mini
Mobile Phone
iOS
I've just installed a Sonnet Solo 10G PCIe Card on OSX Mojave and works without any patch.

Also tested the speed, and it's working at 10GbE. Tested with:

Switch 10Gbe: QNAP QSW-1208-8C-US
Synology 1817+ with 10Gbe card
Cat 6 cables
 
Last edited:
Joined
Aug 24, 2013
Messages
2
Motherboard
Gigabyte Z370
CPU
i7-8700K
Graphics
Vega 64
The following is still needed if using an AQC107 card that isn't natively recognized by macOS.

The only AQC107 cards that I know of that work without the following are:
Syba card
Sonnet card
Synology card


Code:
            <dict>
                <key>Comment</key>
                <string>AQC107 patch v3</string>
                <key>Disabled</key>
                <false/>
                <key>Find</key>
                <data>
                YnVpbHQtaW4=
                </data>
                <key>InfoPlistPatch</key>
                <false/>
                <key>Name</key>
                <string>AppleEthernetAquantiaAqtion</string>
                <key>Replace</key>
                <data>
                YmJiYmJiYmI=
                </data>
            </dict>
Are you saying, pastrychef, that the synology 10 gbe cards are working for you?

I have synology E10G17-F2, but my hackintosh won't boot when the card is in the pci-e slot.
I'm planning on returning it and getting the Sonnet Solo 10g instead, but would prefer to keep and use the synology nic.
 
Last edited:

pastrychef

Moderator
Joined
May 29, 2013
Messages
8,154
Motherboard
Asus ROG Strix Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Vega 56
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
Are you saying, pastrychef, that the synology 10 gbe cards are working for you?

I have synology E10G17-F2, but my hackintosh won't boot when the card is in the pci-e slot.
I'm planning on returning it and getting the Sonnet Solo 10g instead, but would prefer to keep and use the synology nic.
I haven't personally tested the Synology. I've just read of success from others. Here's the card that's supposed to work:
 
Joined
Aug 24, 2013
Messages
2
Motherboard
Gigabyte Z370
CPU
i7-8700K
Graphics
Vega 64
Fair enough - I'll look into it. Thanks for the link!
Are you running 10 gbe yourself?
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
8,154
Motherboard
Asus ROG Strix Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Vega 56
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
Fair enough - I'll look into it. Thanks for the link!
Are you running 10 gbe yourself?
Yes. I'm currently using the Syba card. Previously, I used the Gigabyte AQC107 card but that one required flashing and patching of a kext. Before that, I had an Intel X540-T2.

It's connected to a NAS that uses an Intel X540-T2.
 
Top