Contribute
Register

AppStore and iCloud WORKING on H77/Z77 DS3H rev1.1!! (Not Onboard)

Status
Not open for further replies.
Joined
Oct 23, 2012
Messages
49
Motherboard
ASUS Z87-K
CPU
i7 4790 @ 3,6 GHz
Graphics
AREZ Strix Radeon RX VEGA56 OC
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Hey you guys!

Finally, just finally I solved the iCloud and AppStore problem with the rev.1.1 MoBos H77/Z77 DS3H!

Right now (as we all know;)) the onboard AR8161 Ethernet is not supportet, so I just got the TG-3269 PCI Ethernet Card for about 15$ from Amazon. I just installed the RTL8169 driver (just google the kext, the one from MB 5.1.3 did not work for me) and changed my SMBIOS to iMac 12,1...do not use MacPro3.1 which is installed by default, it will not work with this SMBIOS!!

Side note: When using MacPro3.1 en1 won't ever change to en0, also do not use EFI Strings as it messes up the integrated Graphics (in my case the 4000 - I didn't try a GFX Card though)

Before you reboot, delete Ethernet and/or your Wlan Connection from System Preferences/Network

Reboot and add Ethernet at first!
(Then right after that add your WLAN)

PS: I have added the working kext in the attachments.

Of course you can also try other PCI Cards, but I just wanted to post this guide on how to enable AS and iC as this is a very cheap Ethernet card which you can get to work with few effort.

Enjoy your en0 xD

If you have questions, feel free to post them here into this thread :)

Have a nice day ya all
austrianhack :)

I've attached the kext for all the lazy ones ;P
 

Attachments

  • kextrtl8169austrianhack.zip
    185 KB · Views: 284
Joined
Oct 4, 2012
Messages
43
Motherboard
GA-Z77-DS3H
CPU
i3-3225
Graphics
GT 740
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
Very very NICE!
I linked your thread to another major thread where this is all being discussed. I'm doing the exact same pci card. I'll let you know how it goes.

Thank you very much for sharing. Extremely helpful post!
 
Joined
Oct 23, 2012
Messages
49
Motherboard
ASUS Z87-K
CPU
i7 4790 @ 3,6 GHz
Graphics
AREZ Strix Radeon RX VEGA56 OC
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Hey metaldoom,

thanks very much for the nice words :)

Anyways, my TP - LINK 3269 has been extremely stable with the kext I provided in my previous post! No KP or other random crashes at all :)
 
Joined
Oct 4, 2012
Messages
43
Motherboard
GA-Z77-DS3H
CPU
i3-3225
Graphics
GT 740
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
I tried this link after seeing so many positive results (although the 1.0.1 release of the kext):
http://www.insanelymac.com/forum/to...heros-ar813132515261627172-driver-for-107108/

But after having no luck, I followed austrianhack's post exactly as written and it worked flawlessly and natively!
Two days with no issues using the same ethernet pci card listed below. TP-Link 3269

For future readers I would certainly recommend trying the insanleymac link above. But our friend austrianhack seems to have the solution if all else fails.

Thanks again. Very much!
 
Joined
Apr 22, 2011
Messages
3
Motherboard
Intel
CPU
E6500
Graphics
Gforce
Mac
Classic Mac
Mobile Phone
I tried this link after seeing so many positive results (although the 1.0.1 release of the kext):
http://www.insanelymac.com/forum/to...heros-ar813132515261627172-driver-for-107108/

But after having no luck, I followed austrianhack's post exactly as written and it worked flawlessly and natively!
Two days with no issues using the same ethernet pci card listed below. TP-Link 3269

For future readers I would certainly recommend trying the insanleymac link above. But our friend austrianhack seems to have the solution if all else fails.

Thanks again. Very much!

I used the experimental drivers in the link, and it worked like a charm for me. I also took out the BuiltInEthernet key from Chameleon and now can browse the internet with my onboard NIC.
 
Joined
Oct 4, 2012
Messages
43
Motherboard
GA-Z77-DS3H
CPU
i3-3225
Graphics
GT 740
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
I used the experimental drivers in the link, and it worked like a charm for me. I also took out the BuiltInEthernet key from Chameleon and now can browse the internet with my onboard NIC.

Thanks for the feedback datdamnamp, again the experimental drivers are first choice of course. The ethernet card was $10 though, so I'll just keep it as it is and call it noob proof LOL
 
Joined
Oct 23, 2012
Messages
49
Motherboard
ASUS Z87-K
CPU
i7 4790 @ 3,6 GHz
Graphics
AREZ Strix Radeon RX VEGA56 OC
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Sorry for not being able to post in this topic for quite a while...

So how are things doing? Great, actually! After 3 months of using my Adapter in Mountain Lion I have not had a single KP or andy crash at all. iCloud and AppStore are still working great, I just don't use em that much ;D

Right now I am installing Lion - yesterday I installed Snow Leopard on my rig aaaaand the adapter works great!


I will let you guys know if everything worked correctly in Lion too....

If you have any questions, feel free to post them here :)

-austrianhack
 
Joined
Oct 23, 2012
Messages
49
Motherboard
ASUS Z87-K
CPU
i7 4790 @ 3,6 GHz
Graphics
AREZ Strix Radeon RX VEGA56 OC
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
It's been a long time now since I started my 4th hackintosh project (H77-DS3H).
Everything had been working really nice until the day when my TP - LINK 3269 Lan Card started to cause frequent kernel panics and stopped the computer from booting up correctly (most of the time there were only ''error - beeps'' coming from the MoBo and the Monitor wouldn't even show a signal/the PC would restart constantly).

As a matter of fact it damaged my motherboard (at first I assumed it was something else but the network card - in the end the only components that didn't work anymore were the LAN Card and the MoBo itself) I found out that one of the capacitors on the LAN Card had blown up....

I'm writing this on my ''replacement - hacktintosh'', featuring the Gigabyte Z77 - DS3H which came in really handy because of its light overclocking (got my i5 3570k to 4.3 GHz).
I got the rev1.1 (same ethernet chip as the H77 - DS3H 1.1) but luckily there has been a fully working ethernet kext for the onboard LAN for over a year now :)

Just thought I'd post this as (maybe) some people are thinking of buying this LAN Card in combination with the MoBo mentioned above. (Which doesn't mean that this card will damage your Motherboard - but at least you could encounter Kernel Panics from time to time ;) )

Greetings
 
Status
Not open for further replies.
Top