Contribute
Register

AppleHDA HDMI Audio [Guide]

Joined
Dec 6, 2016
Messages
47
Motherboard
Gigabyte Z170N-WIFI
CPU
i5-6600K
Graphics
RX 6600
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
Cannot replicate the error. Attach is the script edited config.plist. Copy
config.plist/KernelAndKextPatches/KextsToPatch/Item 0 to your config.plist.
Install, restart, reply with new files.
Well, partial success... After installing config.plist/KernelAndKextPatches/KextsToPatch/Item 0 to my config.plist (the file is attached) and reboot the Samsung HDMI device appears in Sound-output.
But can't hear any sound playing a video or music!
So I've ran your script again against the installed config.plist. The first entry got removed after the script ran, and the script shows the same error. (The resulting config.plist is packed in CLOVER.zip).
I'm also attaching other outputs, all of these are after rebooting with your item in KextsToPatch installed.
 

Attachments

  • Problem_reporting.zip
    3.7 MB · Views: 54
Joined
Sep 27, 2012
Messages
334
Motherboard
Asrock Z270X ITX Fatality
CPU
I7-7700K
Graphics
HD 630 + RX 560
Mac
  1. MacBook Air
Mobile Phone
  1. Android
To confirm, the script does add and suggest a GFX0 to IGPU patch right? I already had one on there when I ran the command (Which fixed dual display for me btw, so thanks), which is why I am asking. Also, should I keep intelgraphicsfixup?
 

toleda

Moderator
Joined
May 19, 2010
Messages
22,921
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
Well, partial success.
HDMI audio working
can't hear any sound playing a video or music!
User error, see Post #1/I. Before You Install HDMI Audio/3 and 4
ran your script again against the installed config.plist.
Broke HDMI audio, why??
script shows the same error.
Expected, the script issue is caused by your system; no idea why.
after rebooting with your item in KextsToPatch installed.
Working HDMI audio, no further action required.
 

toleda

Moderator
Joined
May 19, 2010
Messages
22,921
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
Joined
Jul 19, 2011
Messages
24
Motherboard
Asus Z170M-PLUS
CPU
Intel Core i7 6700K 4.00 GHz
Graphics
Gigabyte GeForce GTX 1060 Windforce OC
Mobile Phone
  1. Android
No idea. What does NividiaGraphicsFixup.kext do for your system?
Clearly NividiaGraphicsFixup.kext does not enable working HDMI audio, post the developer for clarification.
An experiment; remove NividiaGraphicsFixup.kext, restart, reply with new files.

I've removed lilu.kext and NividiaGraphicsFixup.kext
when running your script after removing them it installs SSDT-HDMI-NVIDIA-PEG0.aml in efi/clover/acpi/patched
restart but still no hdmi audio

files attatched
 

Attachments

  • Hdmi Audio 1.zip
    911.2 KB · Views: 70
Joined
Jul 19, 2011
Messages
24
Motherboard
Asus Z170M-PLUS
CPU
Intel Core i7 6700K 4.00 GHz
Graphics
Gigabyte GeForce GTX 1060 Windforce OC
Mobile Phone
  1. Android

See Post #1/VIII. Nvidia GeForce Graphics/1. Nvidia 10xx/9xx/7xx/6xx/5xx/4xx/1. 10xx/Nvidia web driver; no HDMI audio ...
I've already seen that, so changed from hdmi cable to a displayport to hdmi cable but still no audio
 
Joined
May 17, 2016
Messages
30
Motherboard
GA-Z270-HD3
CPU
i5-7500
Graphics
RX560
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
Hi,

  1. I am currently not getting Audio on HDMI. I am able to get sound via motherboard port as well as the frontend headphone port.
  2. OS X Version 10.13.1, MB: GA-Z270-HD3, BIOS version F7, CPU: I5-7500K, Graphics: IGPU 630
  3. AppleALC. Fixed HDEF, Picked Layout ID:1 (as you suggested on an earlier thread), placed (most recent versions of) AppleALC.kext and Lilu.kext in EFI/Clover/Kext/10.13
  4. Copy of IOReg attached.
  5. diskutil ouput Attached.
  6. AppleHDA.kext attached.
  7. Screenshots attached. Do not see Intel High Definition Audio (may be the problem)…
  8. No Script used. Also tried disabling HDAS to HDEF and running the script provided in https://www.tonymacx86.com/threads/applehda-hdmi-audio-guide.234735/ Did not work so reverted back.
  9. No SSDT patched. DSDT attached.does this m
  10. Done.
Two questions.
1. Does disabling HDAS to HDEP patch, break the sound on the audio port?
2. I have two screens I switch between. TV and Monitor. Use same HDMI cable. Does this method support two devices?

Please help. Thanks.
 

Attachments

  • Archive.zip
    2.5 MB · Views: 67
Top