Contribute
Register

AppleHDA HDMI Audio [Guide]

toleda

Moderator
Joined
May 20, 2010
Messages
24,364
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
iMac, MacBook Pro, Mac mini
Classic Mac
512K, LC, Power Mac
Mobile Phone
iOS
Joined
Jan 20, 2019
Messages
19
Motherboard
Lenovo T440p iGPU
CPU
i5-4300M
Graphics
HD 4600 - 1080p
Mobile Phone
Android
HDMI audio not posible, agree?

Not the question asked. The question was:
All tests done with receiver connected and ON.
 

toleda

Moderator
Joined
May 20, 2010
Messages
24,364
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
iMac, MacBook Pro, Mac mini
Classic Mac
512K, LC, Power Mac
Mobile Phone
iOS
All tests done with receiver connected and ON.
Two issues:
1. When and why did the audio device change from Panasonic-TV/HDMI (Post #1000) to AV Receiver/DP (Post #1006)
2. Post #1007 IOReg shows macOS saw the HDMI codec and then it disappeared; result, no sound
 
Joined
Jan 20, 2019
Messages
19
Motherboard
Lenovo T440p iGPU
CPU
i5-4300M
Graphics
HD 4600 - 1080p
Mobile Phone
Android
Two issues:
1. When and why did the audio device change from Panasonic-TV/HDMI (Post #1000) to AV Receiver/DP (Post #1006)
2. Post #1007 IOReg shows macOS saw the HDMI codec and then it disappeared; result, no sound
Passive miniDP2HDMI = Panasonic-TV/HDMI
Active MiniDP2HI = AV Receiver/DP

Post #1007 I cannot say.

A new Ioreg when only external monitor is active & after some edits in ssdt - now Receiver show "PCM" on display but no audio:


'''
 

Attachments

Last edited:

toleda

Moderator
Joined
May 20, 2010
Messages
24,364
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
iMac, MacBook Pro, Mac mini
Classic Mac
512K, LC, Power Mac
Mobile Phone
iOS
Here you go
ssdt was requested with original Problem Reporting files
Contact the ssdt developer, problems with:
Method (_SB.PCI0.HDEF._DSM, 4, NotSerialized), hda-gfx injection is not used with HD4600
Method (_SB.PCI0.HDAU._DSM, 4, NotSerialized), not needed with WhateverGreen and AppleALC
 
Joined
Dec 10, 2010
Messages
33
Motherboard
Intel NUC6i3syh
Graphics
hd 520
Mobile Phone
Android
hi, after upgrading to mojave 10.14.3 hdmi audio is lost, only have headphones jack working using appleALC and fakepciid intel method, but...i noticed that if the computer boots up and the monitor ( LG TV ) is turned off and then after booting i turn the tv on everything goes fine: both audio hdmi and jack are present and work. hdmi hot unplug and plug back gives no result if tv is turned on before computer- only audio thru jack aux...any ideas thanks.

system: Intel NUC6i3syh with HD520 graphics
monitor - LG TV
mac OS: mojave 10.14.3 ( 18D109 )
installed using Rehabman Nuc installation method with appleALC and fakepciid intel hdmi audio.
 

Attachments

Last edited:

toleda

Moderator
Joined
May 20, 2010
Messages
24,364
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
iMac, MacBook Pro, Mac mini
Classic Mac
512K, LC, Power Mac
Mobile Phone
iOS
after upgrading to mojave 10.14.3 hdmi audio is lost
You have identified the problem correctly, Intel HDMI audio codec is not present if TV is on during boot.
Turning the TV on after boot is a hot pug and macOS recognizes the Intel HDMI audio codec
installed using Rehabman Nuc installation method with appleALC and fakepciid intel hdmi audio
Suggest posting to RehabMan's Mojave NUC6 Installation thread.
 
Top