Contribute
Register

Apple Thunderbolt 3 to Thunderbolt 2 adapter Skylake Z170X

Joined
Sep 11, 2012
Messages
32
Motherboard
GA-Z170X-UD5-TH
CPU
i7 6700k
Graphics
GTX 670, GTX 1080
Mac
MacBook Air, Mac mini, Mac Pro
Mobile Phone
iOS
Hello All,

Does anyone have succes with the Apple TB3 to TB2 adapter on GA-Z170X-UD5-TH?

(Also running Nvidia GPU and NVMe Based Samsung 961 SSD, does the PCIe slot matter?)

When I plug in the device (read: boot with the adapter in the port and TB to ethernet attached to it) it get's recognised as an USB device with USB1.0 speeds. It also gives me a message that TB is not supported on my Mac. the exact message a Macbook with USB-C would give when plugging in this accessory.

I did the firmware updates for TB in windows, and I have the latest BIOS installed.

My guess, that is possibly 100% wrong, is that the switching from USB to TB does not work properly on macOS. And as this is my only TB3 device I'm not sure if they all have a USB fallback.. (Because some TB3 devices are reported to work fine) So would if possible disabling USB on the USB-C connectors enable me to use this TB3 device?

If any additional info is needed please let me know.
 
Joined
May 14, 2017
Messages
16
Motherboard
GA-Z170X-UD5 TH
CPU
i7-6700K
Graphics
GTX 1060
Mac
Mac Pro
Mobile Phone
iOS
Hello All,

Does anyone have succes with the Apple TB3 to TB2 adapter on GA-Z170X-UD5-TH?

(Also running Nvidia GPU and NVMe Based Samsung 961 SSD, does the PCIe slot matter?)

When I plug in the device (read: boot with the adapter in the port and TB to ethernet attached to it) it get's recognised as an USB device with USB1.0 speeds. It also gives me a message that TB is not supported on my Mac. the exact message a Macbook with USB-C would give when plugging in this accessory.

I did the firmware updates for TB in windows, and I have the latest BIOS installed.

My guess, that is possibly 100% wrong, is that the switching from USB to TB does not work properly on macOS. And as this is my only TB3 device I'm not sure if they all have a USB fallback.. (Because some TB3 devices are reported to work fine) So would if possible disabling USB on the USB-C connectors enable me to use this TB3 device?

If any additional info is needed please let me know.

I'm having an issue where my TB2 drive mounts about 1 out of 5 times. I can't tell if it's the adapter or not. I have a UBS-C 3.1 drive that mounts every time. That leads me to think that it might be the adapter?????
 
Joined
Sep 11, 2012
Messages
32
Motherboard
GA-Z170X-UD5-TH
CPU
i7 6700k
Graphics
GTX 670, GTX 1080
Mac
MacBook Air, Mac mini, Mac Pro
Mobile Phone
iOS
I'm having an issue where my TB2 drive mounts about 1 out of 5 times. I can't tell if it's the adapter or not. I have a UBS-C 3.1 drive that mounts every time. That leads me to think that it might be the adapter?????
Well for me it does not even work at all.. what other hardware are you using? and what BIOS settings..
I'm not exactly sure how switching between USB and TB3 works, but this apple adapter is seen as an USB1.1 device and maybe it being able to show as an USB device is holding my TB3 port from switching it to TB3 instead of staying at the USB protocol..

For your problem.. I have no idea.. :/
 
Joined
May 14, 2017
Messages
16
Motherboard
GA-Z170X-UD5 TH
CPU
i7-6700K
Graphics
GTX 1060
Mac
Mac Pro
Mobile Phone
iOS
I picked up the startech TB3 to TB2 adapter yesterday and that seems to have solved my problem. Had the TB2 drive mount every time I restarted. Hopefully that will hold up over time. Too short of sample to say 100% solved yet.... I will check my BIOS settings when I am at home and let you know.
 
Joined
Sep 11, 2012
Messages
32
Motherboard
GA-Z170X-UD5-TH
CPU
i7 6700k
Graphics
GTX 670, GTX 1080
Mac
MacBook Air, Mac mini, Mac Pro
Mobile Phone
iOS
Thank you, I hope we are on the same BIOS I remember I'm on the last one (21 IIRC) and a lot of the BIOS settings regarding TB3 have changed.. I should never have updated...
 

Top