Contribute
Register

Apple security update 2017-001 changes build number disabling nvidia driver - Driver updated!

Status
Not open for further replies.
Joined
May 3, 2016
Messages
7
Motherboard
Gigabyte GA-Z97X-UD3H
CPU
i7-4790K
Graphics
RX 580
Mac
  1. Mac mini
Mobile Phone
  1. iOS
I got some "Invalid signature -67030 for kext" when running the script, any ideas??
 
Joined
Feb 12, 2017
Messages
20
Motherboard
Gigabyte Z170 Gamink K3
CPU
Intel 6700K
Graphics
Nvidia GeForce GTX 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
Did you run the script with sudo ?
eg : sudo <shell path>./webdriver.sh -m
work fine for me
Yes I ran script with sudo, but after reboot I’m still on OS X native driver not nvidia

UPDATE: I added -m 17B1002 at the end...and it worked!! I was definitely holding it wrong:)
Thanx a lot for the script
 

Attachments

  • Screen Shot 2017-11-29 at 20.19.37.jpg
    Screen Shot 2017-11-29 at 20.19.37.jpg
    120.2 KB · Views: 770
Last edited:
Joined
May 21, 2016
Messages
26
Yes I ran script with sudo, but after reboot I’m still on OS X native driver not nvidia

I did "./webdriver.sh -m 17B1002" and that worked for me. The script said it was setting the required version to 17B1002 but for you it says B1002. Maybe it should work the way you've done it but it might be worth trying to specify the whole build number as shown…?
 
Joined
Oct 31, 2010
Messages
23
Motherboard
Asus TUF Gaming Z790-Plus WIFI D4
CPU
i7-13700K
Graphics
RX 6600 XT
Mac
  1. iMac
Mobile Phone
  1. Android
  2. iOS
Update and reboot
run the script with sudo
eg : sudo <shell path>/webdriver.sh -m 17B1002
work fine for me
 
Joined
Aug 4, 2016
Messages
7
Motherboard
Asus Z390-a
CPU
i7 8700k
Graphics
gtx 1070 ti
Mac
  1. MacBook Air
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
This doesn't work for me. I need to install the webdriver but it's not the right build number. Anyone know something I can do? I do not have the web driver installed so I cannot apply this fix?
 
Joined
May 30, 2016
Messages
568
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
  4. Mac Pro
Classic Mac
  1. iMac
  2. SE/30
Mobile Phone
  1. iOS
This doesn't work for me. I need to install the webdriver but it's not the right build number. Anyone know something I can do? I do not have the web driver installed so I cannot apply this fix?
This fix only works for people who have the webdriver already installed, it will not install if you already have the security update installed on your system.
 
Joined
Apr 11, 2017
Messages
2
Is there any way to install the web drivers on this new build? Unfortunately I uninstalled them after the update, thinking I could just reinstall the .pkg file. The script posted in this thread doesnt seem to work for fresh installs.
 
Status
Not open for further replies.
Top