Contribute
Register

Apple releases Snow Leopard Graphics Update 1.0

Status
Not open for further replies.

tonymacx86

Administrator
Staff member
Joined
Nov 17, 2009
Messages
7,215
Motherboard
PRIME Z490-A
CPU
i5 10600K
Graphics
Vega 56
Mac
  1. MacBook Air
Classic Mac
  1. Apple
  2. PowerBook
Mobile Phone
  1. iOS
Installed and working fine on my systems. According to Apple...

The Snow Leopard Graphics Update contains stability and performance fixes for graphics applications and games, including fixes that:
• address frame rate issues occurring in Portal and Team Fortress 2 on certain Macs
• resolve an issue that could cause Aperture 3 or StarCraft II to unexpectedly quit or become unresponsive
For more information about this update, please visit this website:
http://support.apple.com/kb/HT4286

Direct link to download: http://support.apple.com/kb/DL1083

ATI Users- don't update without fixing your kexts:
Netkas has now released a QE/CI patch for the new graphics update for 4890/4870x2 cards (4870/4850 don't need this). Get it from his web-site: http://netkas.org/
 

AC3

Joined
Aug 3, 2010
Messages
175
Mac
Classic Mac
Mobile Phone
Tested on my system as well and confirmed working. I don't have any tools/programs to test graphics so I don't know if this has led to any performance improvement.

This update doesnt eliminate the need to use ATY_init, right?

-AC3
 
Joined
Jul 13, 2010
Messages
7
Motherboard
Asus P7P55D-E Evo
CPU
i7-860
Graphics
Asus GTX580
Mac
  1. MacBook
Classic Mac
Mobile Phone
  1. Android
  2. iOS
Hi, updated and working perfect.

I test with cinebench, no great changes, before 31fps, after 33fps.
 
Joined
Jul 6, 2010
Messages
2,591
Motherboard
Asus Z170M-Plus
CPU
i5-6600K
Graphics
R9 280
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. iOS
Installed it on my HD5770 machine.
Testet it with Starcraft 2 and CS:Source, got really big performance improvements, especially with enabled FSAA.

Starcraft 2 (1920x1200, Ultra)
Before: about 15 FPS
Now: about 25-30 FPS
Win: about 45 FPS

CS Source: (1920x1200, everything max)
Before: about 20 FPS (with 8x FSAA enabled, without about 80)
Now: 80-100 FPS (8x FSAA)

Nice! :)
 

tonymacx86

Administrator
Staff member
Joined
Nov 17, 2009
Messages
7,215
Motherboard
PRIME Z490-A
CPU
i5 10600K
Graphics
Vega 56
Mac
  1. MacBook Air
Classic Mac
  1. Apple
  2. PowerBook
Mobile Phone
  1. iOS
Joined
Feb 21, 2010
Messages
69
Motherboard
Gigabyte P55M-UD4
CPU
i7-860
Graphics
Nvidia GT240
Mac
  1. MacBook Air
  2. MacBook Pro
Classic Mac
Mobile Phone
  1. Android
  2. iOS
This seems to cause compatibility issues with the Cuda 3.1.10 drivers. I'm now getting a message that the Cuda drivers require an update, but none is available.

Tim
 
Joined
Jul 3, 2010
Messages
298
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
  2. Mac mini
  3. Mac Pro
Mobile Phone
  1. iOS
tonymacx86 said:
Installed and working fine on my systems. According to Apple...

The Snow Leopard Graphics Update contains stability and performance fixes for graphics applications and games, including fixes that:
• address frame rate issues occurring in Portal and Team Fortress 2 on certain Macs
• resolve an issue that could cause Aperture 3 or StarCraft II to unexpectedly quit or become unresponsive
For more information about this update, please visit this website:
http://support.apple.com/kb/HT4286

Direct link to download: http://support.apple.com/kb/DL1083

Tony is that with or without Graphics enabler? I removed ATY kext and it crashed on startup. Did you remove yours and are you in 64 bit mode now?
 
Joined
May 9, 2010
Messages
227
Motherboard
Gigabyte Z690 Gaming X
CPU
i5-12600K
Graphics
RX 6800 XT
Mobile Phone
  1. Android
After installation of the graphics update, on my Sapphire ATi 4890, QE/CI became disabled (tested by dropping widget on dock - no animation). Also, can't play any Steam games, as card comes up as an Unsupported Video Card. Have tried re-installing netkas 10.6.4 patch but features still remain disabled. QE/CI and Steam were working before patch installation.

As tonymac uses an Nvidia card and the same Gigabyte motherboard as me, I can only assume this problem is unique to ATi cards, or just unique to my Mac (running SL 10.6.4). Anyway, will see what others report, and if there is a solution for this, over the next couple of days.
 
Joined
Jan 15, 2010
Messages
114
Motherboard
Asus Z77 Sabertooth
CPU
i7-3770K
Graphics
HD4000
Mac
  1. iMac
  2. Mac mini
  3. Mac Pro
Classic Mac
Mobile Phone
  1. iOS
Hi Mr Tonymacx86.

This graphics update is interesting, I have loaded it and it appears to work ok.

I am running it on with a MSI R5770 Hawk card loadd running in 32 bit mode (ATI_INIT).

I have also loaded it on my real imac and notice in S/L/E it has loaded ATI5000Controller.kext which was not there prior to the update, so methinks that is good news for the hackintosh which I am also able to call a macpro5,1 (new MacPro 2010) which previously cause chameleon to reboot when loading.

just hoping that you and Macmanx will be able to get the ATI 5XXX cards to run in 64 bit.

Brgds/Tonyd.
 
Status
Not open for further replies.
Top