Contribute
Register

Apple Releases macOS High Sierra 'Golden Master' GM Candidate to Beta Testers

Joined
Feb 5, 2014
Messages
103
Motherboard
Asus X-99 Pro USB 3.1
CPU
i7 5820K
Graphics
GTX 960
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. Android
10.13 beta (17A362a)
Everything ok here. Just waiting for the Web Drive... ;)
 

Attachments

  • Captura de ecrã 2017-09-15, às 16.13.07.png
    Captura de ecrã 2017-09-15, às 16.13.07.png
    492.7 KB · Views: 462
  • Captura de ecrã 2017-09-15, às 16.14.04.png
    Captura de ecrã 2017-09-15, às 16.14.04.png
    112.5 KB · Views: 545
  • Captura de ecrã 2017-09-15, às 16.16.05.png
    Captura de ecrã 2017-09-15, às 16.16.05.png
    65.6 KB · Views: 546
  • Captura de ecrã 2017-09-15, às 16.19.10.png
    Captura de ecrã 2017-09-15, às 16.19.10.png
    124.9 KB · Views: 523
  • Captura de ecrã 2017-09-15, às 16.22.12.png
    Captura de ecrã 2017-09-15, às 16.22.12.png
    62.7 KB · Views: 539
  • Captura de ecrã 2017-09-15, às 16.25.28.png
    Captura de ecrã 2017-09-15, às 16.25.28.png
    2.3 MB · Views: 481
  • Captura de ecrã 2017-09-15, às 16.55.11.png
    Captura de ecrã 2017-09-15, às 16.55.11.png
    91.6 KB · Views: 401
Joined
Feb 5, 2014
Messages
103
Motherboard
Asus X-99 Pro USB 3.1
CPU
i7 5820K
Graphics
GTX 960
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. Android
any news about the APFS ? can we upgrade on Hackintoshes too ? from the appstore of course
From the begin, I have always done all 10.13 updates by the Appstore in my hack, with a APFS partition :)
 

Attachments

  • Captura de ecrã 2017-09-15, às 16.55.11.png
    Captura de ecrã 2017-09-15, às 16.55.11.png
    91.6 KB · Views: 609

Stork

Admin
Staff member
Joined
Sep 21, 2010
Messages
13,522
Motherboard
Asus ProArt Z490 Creator
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Pro
  2. Mac mini
  3. Mac Pro
Classic Mac
  1. Power Mac
  2. PowerBook
Mobile Phone
  1. iOS
installing HS GM on the X58A worked just like "real" Mac Pro - install said 45 minutes, but 2 minutes into it, it reboots to installer again and this time takes 44 minutes to complete install. Depending on your system definition it may reboot more than once.
First to be installed is the Mac/iMac/MB/MBP/MBA firmware update to handle APFS. Second part of the install is the actual HS installation. The good news for Hacks is, if the installer can't "see" the Mac firmware to update, it skips the firmware update. Or, at least, that's how I read it based upon my experience with Mac Pros.
 
Joined
Jun 29, 2013
Messages
32
Motherboard
GA-Z77X-D3H 1.1
CPU
Intel Core I5 3570K @4.2GHz
Graphics
GTX 770 4GB OC
Mobile Phone
  1. Android
Updating to GM via App Store worked really well for me. Only problem I had was Clover not picking up the Install Partition (actually i think that is normal) and the need to use the beta boot arg for AppleALC and NvidiaGraphicsFixup
 

Going Bald

Moderator
Joined
Aug 14, 2010
Messages
23,180
Motherboard
GA-X58A-UD7-F7
CPU
W3670
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. iMac
Mobile Phone
  1. Android
First to be installed is the Mac/iMac/MB/MBP/MBA firmware update to handle APFS. Second part of the install is the actual HS installation. The good news for Hacks is, if the installer can't "see" the Mac firmware to update, it skips the firmware update. Or, at least, that's how I read it based upon my experience with Mac Pros.
Rebooting to install firmware update on non-existent firmware is an exercise in futility. What I had to do was to change my Mac Pro 5,1 system definition to Mac Pro 6,1 to get past the insistence on doing the firmware update.
Once it had completed the install I was able to put the original config.plist for Mac Pro 5,1 back in the EFI/Clover folder and reboot. There was no option to change the HFS+ to APFS, probably because it is installed on a spinning platter HDD rather than a SSD.
 
Joined
Nov 4, 2011
Messages
609
Motherboard
GA-Z170X-UD3 F23g
CPU
i7-6700K
Graphics
RX-580
Mac
  1. iMac
Disk Utility looks better in 10.13 than 10.12
I agree, it works, much better indeed. Upgraded to High Sierra GM 17A362a on APFS - no problems - It is working in all respects except video because Nvidia has as yet not released new drivers for High Sierra. I am using the Sierra 10.12.6 Nvidia drivers, "hacked" to work with High Sierra. Not optimal, but better than nothing.

Greets
 

Attachments

  • 17A262a.jpeg
    17A262a.jpeg
    58.9 KB · Views: 222
Last edited:

Going Bald

Moderator
Joined
Aug 14, 2010
Messages
23,180
Motherboard
GA-X58A-UD7-F7
CPU
W3670
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. iMac
Mobile Phone
  1. Android
GA-Z170X-UD5
try to install beta GM
error in second boot: An error occurred while verifying firmware

any idea?

Regards
I changed the system definition to get past the firmware check.
 

aol

Joined
Apr 14, 2011
Messages
507
Motherboard
GA-Z370-HD3P
CPU
i7-8700K
Graphics
RX570
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. iOS
GA-Z170X-UD5
try to install beta GM
error in second boot: An error occurred while verifying firmware

any idea?

Regards
Suggestions include temporarily disconnecting any Windows-formatted disks, and setting your firmware revision via Clover Configurator and config.plist to a newer firmware version so the firmware check sees "up to date firmware" and skips this piece.

I had this issue, disconnected my Windows drive, and got past it.

However now I am stuck at the invalid OSInstall.mpkg error, which I thought was fixed by not having EmuVariables64_uefi.kext in your booted clover drivers64UEFI folder (and was able to get other App Store updates installed this way) but verified I'm booting a Clover (latest, 4200) without it and still getting this error.

I should note that I'm booting a newly built USB stick with the latest full Beta installer written to it, and Clover 4200 in the EFI. My understanding is that the App Store will not have "updates" for GM candidates as it did for the developer and public betas. My understanding is that folks that are saying they're updating from the App Store are downloading the full installer (beta page -> download button, downloads to Applications) and running it from there. However, if I do that, it writes something briefly and almost instantaneously reboots and the update doesn't work. I had that issue with earlier public betas.

edit: got it sorted. Tried the full installer from App Store again and while it does very quickly reboot it did work. Had to reboot several times before installation finished. Throughout this process, I disconnected my Windows disk and booted a clover without EmuVariables64_uefi.kext. Reapplied Pascal fix using 10.12.6 policy file. Reapplied Toleda sound patch. Everything working as before on latest GM candidate. Can also confirm Plextor M8PeG NVME disk now seen by High Sierra with just the IOVNMeFamily 0x10->0x01 bin patch applied.
 
Last edited:
Top