Contribute
Register

Apple Magic Mouse And Apple USB Keyboard Problems...

Joined
Feb 4, 2014
Messages
111
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
GTX 780 Ti
This is the rig I'm using:

Case: BitFenix Prodigy M
Motherboard: Gigabyte Z87M-D3H (F9)
CPU: Intel i7 4770K (no overclocking)
GPU: Intel HD 4600
RAM: Kingston Hyper X Fury Black 2x4GB 1600MHz
OS: MAC OS X 10.9.4
Mouse: Apple Magic Mouse
Keyboard: Standard Apple USB keyboard with the number pad
Bluetooth Adapter: IOGear Bluetooth 4.0 USB Micro Adapter GBU521
OS: Mac OS X 10.9.5 installed with UniBeast and MultiBeast

I've connected the Apple USB keyboard and the IOGear adapter directly to two USB 2 ports on the motherboard itself.

The problem I'm encountering is the following: Sometimes, when the computer boots up and the login screen appears, the Hackintosh is not recognizing the keyboard, however, that's a rare case, but it does occur.

Most of the time, however, the Magic Mouse is not recognized. In that case, I always try to reconnect the Bluetooth adapter to another USB 2 port or to the USB 3 port on the side of the Prodigy case, and sometimes I just turn the Mouse off and then on again. Only problem is that these methods do not guarantee a successful mouse recognition. And sometimes the mouse is recognized, but once I lift the mouse off the mousepad, the mousepointer moves instantly to the upper left corner once the mouse lands on the pad again.

What I also noticed is that sometimes the BIOS screen doesn't really appear, the first thing I see is the tonymac logo, sometimes I do see the BIOS screen in the beginning. It's just that it's a, at least to me, very random process...

Things go much better when I use my Logitech USB mouse and my Logitech USB keyboard. No problems there. I can boot it up and everytime it just works right out of the gate.

Is there anything I can do to fix this random behavior?
 
Top