Contribute
Register

Apple Chime at Startup Added to Clover

beelzebozo

Super Moderator
Joined
Mar 31, 2010
Messages
3,820
Motherboard
ASUS z170-Deluxe
CPU
i7 - 6700K
Graphics
RX 5700 XT
Mac
  1. iMac
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
Found out that startup.wav was made possible in the latest Clover build based off of https://github.com/Goldfish64/AudioPkg#BootChimeCfg.

Install the latest Clover build. Install AudioDxe-64.efi option for UEFI and stick sound.wav inside the theme folder of your choice.

When you get to the Clover GUI, you need to select Options and select Startup Sound Output; select your audio output. You can test by selecting the F7 key and you can also control the volume in increments as 0010 up to 0100. Recommended setting is 0060. You'll hear a sound that resembles an electric guitar chord when doing the test, however the startup.wav or Apple chime will sound when the Clover gui loads.

I've seen some mixed results over at Insanely where some people have had the startup.wav initialize as the Apple logo displays; however I think that is only possible with the Goldfish64 option. There is also an option for PlayAsync in the config.cfg update in Clover where it should be selected. This can be found in Gui, under Theme.

EDIT: Apparently needs to be 16 bit, 48 kHz, wav file (post)
 

Attachments

  • Clover_v2.4k_r4920.zip
    9 MB · Views: 1,118
  • sound.wav.zip
    424.9 KB · Views: 3,116
Last edited by a moderator:

Sniki

Moderator
Joined
Jan 5, 2016
Messages
2,207
Motherboard
HP Elite 8300 SFF
CPU
i7-3770
Graphics
HD3000
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Found out that startup.wav was made possible in the latest Clover build based off of https://github.com/Goldfish64/AudioPkg#BootChimeCfg.

Install the latest Clover build. Install AudioDxe-64.efi option for UEFI and stick sound.wav inside the theme folder of your choice.

When you get to the Clover GUI, you need to select Options and select Startup Sound Output; select your audio output. You can test by selecting the F7 key and you can also control the volume in increments as 0010 up to 0100. Recommended setting is 0060. You'll hear a sound that resembles an electric guitar chord when doing the test, however the startup.wav or Apple chime will sound when the Clover gui loads.

I've seen some mixed results over at Insanely where some people have had the startup.wav initialize as the Apple logo displays; however I think that is only possible with the Goldfish64 option. There is also an option for PlayAsync in the config.cfg update in Clover where it should be selected. This can be found in Gui, under Theme.
Thanks a lot !

I have been searching for the correct/original sound for boot as the one they included on the Clover Package is an Electric Guitar (Hard Rock) version.

Will test it on my Machines and report back with results.
 

tonymacx86

Administrator
Staff member
Joined
Nov 18, 2009
Messages
8,720
Motherboard
PRIME Z490-A
CPU
i5 10600K
Graphics
Vega 56
Mac
  1. MacBook Air
Classic Mac
  1. Apple
  2. PowerBook
Mobile Phone
  1. iOS
Here are a few more versions of the chime:
 

Attachments

  • Startup_WAVs.zip
    240.7 KB · Views: 1,428

tonymacx86

Administrator
Staff member
Joined
Nov 18, 2009
Messages
8,720
Motherboard
PRIME Z490-A
CPU
i5 10600K
Graphics
Vega 56
Mac
  1. MacBook Air
Classic Mac
  1. Apple
  2. PowerBook
Mobile Phone
  1. iOS
Joined
Feb 8, 2013
Messages
96
Motherboard
GA-H270N-Wifi
CPU
i7-7700K
Graphics
GTX 1070
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
Me too. Never got this to work actually. On some boards sometimes I get a noisy test sound, sometimes I hear nothing pressing F7 during the test. I never got any setup to the point where it plays the startup chime WAV.

Does NVRAM (native or emulated) have to be working 100% for this to work?

I've seen some mixed results
 
Joined
Apr 7, 2014
Messages
199
Motherboard
MSI Z370i Pro Gaming Carbon AC
CPU
i3-8100
Graphics
RX460
Mobile Phone
  1. iOS
Do you think it's possible to do this using the motherboard internal speaker? The tiny 4pin speaker for beeps?
Or maybe we could re-use some laptop speakers?
Is that motherboard port accessible on macOS? It would be nice if we can use it mainly for the boot chime.
 
Joined
Aug 22, 2014
Messages
172
Motherboard
Gigabyte Z390 Designare
CPU
i7-9700K
Graphics
RX 570
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Can you please explain how to install this with a existing installation (I'm using Dids latest Clover version) on Catalina? A bit more detail, i.e. where to place the AudioDxe-64.efi file and what to edit in the Config?

Much appreciated.
 
Joined
May 7, 2012
Messages
71
Motherboard
H310M-S2P
CPU
i3-8100
Graphics
RX 580 + UHD 630
1) Put AudioDxe.efi on drivers Clover's folder and audio file inside theme folder.

2) Insert at config.plist:
Code:
    <key>GUI</key>
    <dict>
        <key>PlayAsync</key>
        <true/>
    </dict>


3) Restart…

4) At Clover GUI, press O to access Options menu.

5) Go to Startup Sound Output.

6) Select an audio device and press F7 key to test:

– If u listen a glitched sound, great!!! Proceed to step 7.

– If u listen nothing, select another audio device and test again.

7) Restart and done!

 
Last edited:
Joined
Jan 26, 2012
Messages
160
Motherboard
GA Z97M-D3H
CPU
i3-4370
Graphics
GTX 760
Mac
  1. iMac
  2. Mac Pro
Classic Mac
  1. SE
Mobile Phone
  1. Android
Can you please explain how to install this with a existing installation (I'm using Dids latest Clover version) on Catalina? A bit more detail, i.e. where to place the AudioDxe-64.efi file and what to edit in the Config?

Much appreciated.

  1. Place AudioDxe-64.efi into drivers64 and drivers64UEFI.
  2. Place sound.wav into your theme folder, for example /EFI/CLOVER/theme/Clovy/.
 
Top