Contribute
Register

Apple Chime at Startup Added to Clover

beelzebozo

Super Moderator
Joined
Mar 31, 2010
Messages
3,813
Motherboard
Main Build: ASUS z170-Deluxe
CPU
i7 - 6700K
Graphics
GTX 1080
Mac
MacBook Pro
Classic Mac
Power Mac
Mobile Phone
iOS
Found out that startup.wav was made possible in the latest Clover build based off of https://github.com/Goldfish64/AudioPkg#BootChimeCfg.

Install the latest Clover build. Install AudioDxe-64.efi option for UEFI and stick sound.wav inside the theme folder of your choice.

When you get to the Clover GUI, you need to select Options and select Startup Sound Output; select your audio output. You can test by selecting the F7 key and you can also control the volume in increments as 0010 up to 0100. Recommended setting is 0060. You'll hear a sound that resembles an electric guitar chord when doing the test, however the startup.wav or Apple chime will sound when the Clover gui loads.

I've seen some mixed results over at Insanely where some people have had the startup.wav initialize as the Apple logo displays; however I think that is only possible with the Goldfish64 option. There is also an option for PlayAsync in the config.cfg update in Clover where it should be selected. This can be found in Gui, under Theme.
 

Attachments

Sniki

Moderator
Joined
Jan 5, 2016
Messages
1,696
Motherboard
Lenovo V330 - 15IKB
CPU
i5-8250U
Graphics
UHD 620 /1920x1080
Mobile Phone
iOS
Found out that startup.wav was made possible in the latest Clover build based off of https://github.com/Goldfish64/AudioPkg#BootChimeCfg.

Install the latest Clover build. Install AudioDxe-64.efi option for UEFI and stick sound.wav inside the theme folder of your choice.

When you get to the Clover GUI, you need to select Options and select Startup Sound Output; select your audio output. You can test by selecting the F7 key and you can also control the volume in increments as 0010 up to 0100. Recommended setting is 0060. You'll hear a sound that resembles an electric guitar chord when doing the test, however the startup.wav or Apple chime will sound when the Clover gui loads.

I've seen some mixed results over at Insanely where some people have had the startup.wav initialize as the Apple logo displays; however I think that is only possible with the Goldfish64 option. There is also an option for PlayAsync in the config.cfg update in Clover where it should be selected. This can be found in Gui, under Theme.
Thanks a lot !

I have been searching for the correct/original sound for boot as the one they included on the Clover Package is an Electric Guitar (Hard Rock) version.

Will test it on my Machines and report back with results.
 

tonymacx86

Administrator
Staff member
Joined
Nov 18, 2009
Messages
8,551
Motherboard
GA-Z270X-UD5
CPU
Core i3-7100
Graphics
HD 630
Mac
MacBook Pro, Mac mini
Classic Mac
Apple, PowerBook
Mobile Phone
iOS

tonymacx86

Administrator
Staff member
Joined
Nov 18, 2009
Messages
8,551
Motherboard
GA-Z270X-UD5
CPU
Core i3-7100
Graphics
HD 630
Mac
MacBook Pro, Mac mini
Classic Mac
Apple, PowerBook
Mobile Phone
iOS
Joined
Feb 8, 2013
Messages
87
Motherboard
GA-H270N-Wifi
CPU
i7-7700K
Graphics
GTX 1070
Mac
MacBook Pro
Mobile Phone
Android
Me too. Never got this to work actually. On some boards sometimes I get a noisy test sound, sometimes I hear nothing pressing F7 during the test. I never got any setup to the point where it plays the startup chime WAV.

Does NVRAM (native or emulated) have to be working 100% for this to work?

I've seen some mixed results
 
Joined
Apr 7, 2014
Messages
197
Motherboard
MSI Z370i Pro Gaming Carbon AC
CPU
i3-8100
Graphics
RX460
Mobile Phone
iOS
Do you think it's possible to do this using the motherboard internal speaker? The tiny 4pin speaker for beeps?
Or maybe we could re-use some laptop speakers?
Is that motherboard port accessible on macOS? It would be nice if we can use it mainly for the boot chime.
 
Joined
Jul 11, 2012
Messages
266
Motherboard
GA Z68XP-UD3
CPU
i3 2100
Graphics
EVGA GF 210 - 512Mb
Mac
iMac, Mac mini
Quite funny! In the twenty years I had real macs, I've always tried (and found how) to get rid of that startup sound... :D Especially boring when booting at night.
Good find, anyway, for those who want it. :)
 
Joined
Aug 22, 2014
Messages
34
Motherboard
Gigabyte GA-Z87-HD3
CPU
i5-4670K
Graphics
RX 570
Mac
MacBook Pro
Mobile Phone
Android, iOS
Can you please explain how to install this with a existing installation (I'm using Dids latest Clover version) on Catalina? A bit more detail, i.e. where to place the AudioDxe-64.efi file and what to edit in the Config?

Much appreciated.
 
Joined
May 7, 2012
Messages
24
Motherboard
H310M-S2P
CPU
i3 8100
Graphics
UHD 630+RX 560
1) Put AudioDxe.efi on drivers Clover's folder and audio file inside theme folder.

2) Insert at config.plist:
Code:
    <key>GUI</key>
    <dict>
        <key>PlayAsync</key>
        <true/>
    </dict>

3) Restart…

4) At Clover GUI, press O to access Options menu.

5) Go to Startup Sound Output.

6) Select an audio device and press F7 key to test:

– If u listen a glitched sound, great!!! Proceed to step 7.

– If u listen nothing, select another audio device and test again.

7) Restart and done!

 
Last edited:
Joined
Jan 26, 2012
Messages
160
Motherboard
GA Z97M-D3H
CPU
i3-4370
Graphics
GTX 760
Mac
iMac, Mac Pro
Classic Mac
SE
Mobile Phone
Android
Can you please explain how to install this with a existing installation (I'm using Dids latest Clover version) on Catalina? A bit more detail, i.e. where to place the AudioDxe-64.efi file and what to edit in the Config?

Much appreciated.
  1. Place AudioDxe-64.efi into drivers64 and drivers64UEFI.
  2. Place sound.wav into your theme folder, for example /EFI/CLOVER/theme/Clovy/.
 
Top