Contribute
Register

Apollo QUAD Thunderbolt 1 card and Gigabyte Z490 Vision D TB 3 port help...

Joined
Nov 24, 2012
Messages
37
Motherboard
Gigabyte Z490 Vision D
CPU
i9-10900K
Graphics
RX 570
Mac
  1. iMac
  2. Mac Pro
Hey, if anyone has the TB1 card in an early UNIVERSAL AUDIO Apollo and has it working on the Vision D can you send me a green shot of your Bios settings? I know some TB-1 devices may not work on the Z490 Vision D but hey you gotta try! My Satellite (TB 2) solo (TB 1-2 not sure) and PCI are all connecting fine and working 100%. Tried multiple cables and different adapters. Boot Once, GPIO on and various other attempts of different TB bios settings.
Also tried enable disable of various SSDT's : TB3HP / UIAC etc. A snapshot of enabled SSDT's might help as well.


THANKS!!
 
Last edited:
Joined
Nov 24, 2012
Messages
37
Motherboard
Gigabyte Z490 Vision D
CPU
i9-10900K
Graphics
RX 570
Mac
  1. iMac
  2. Mac Pro
I'm going to answer my own post as I'm sure some are going to learn from my misadventures!
If you have the same system use this post. OC 6.9 Everything is there
Gigabyte Z490 Vision D (Thunderbolt 3) + i5-10400 + AMD RX 580

As of May 2021 : Use the Gigabyte Z490 Vision D BIOS F5.x the current version F20 TB3 ports are not working!

1 : In the case of people getting the "Thunderbolt 3 devices are not supported on this Mac" it is stated many times all over but needs to be drilled home : A USB C cable is NOT a Thunderbolt 3 cable
2 : The UAD Thunderbolt 1 option card is currently not functioning with the SSDT-TB3HP.aml I swapped out my UAD Apollo QUAD (1st generation) TB-1 card with a new Apollo TB-3 card and BAM! there it is! TB-1 devices may not work with the this build as stated in CaseySJ's guide!
It should be pointed out the old Apollo TB-1 card works perfectly with the onboard TB-1 ports on a Gigabyte GA-Z77X-UP5-TH
3 : The SSDT-TB3HP.aml is also working for thew Satellite Quad TB-2 using either the Apple or Startech TB-3 to TB -2 adapters. (UAD recommends the Startech TB3TB2ADAPT )
4 : The Bios settings work as recommend in CaseySJ's amazing guide
5 : For now nothing appears under the Thunderbolt/USB4 Tree on the system information, the information does however appear under the PCI tree (See snapshot)

I am currently working on a solution to 96kHz garbled distorted audio in Logic X 10.6.2

If I use the UAD console only with internal clock I can use 44.1 48 88.2 and 96Khz and insert plugins and hear audio fine. If I am in Logic 10.6.2 and change the project settings to anything over 48Khz ie 88.2 96Khz the audio is garbled and distorted. Generally I record @48Khz anyway so it's not a 911 but if anyone has insight on it drop a note. I have tried to switch Logic output back and forth from internal audio back to Universal Audio.... no change.
 

Attachments

  • Screen Shot 2021-05-29 at 4.07.10 PM.png
    Screen Shot 2021-05-29 at 4.07.10 PM.png
    380.2 KB · Views: 119
  • Screen Shot 2021-05-23 at 8.54.34 AM.png
    Screen Shot 2021-05-23 at 8.54.34 AM.png
    444 KB · Views: 112
Last edited:
Joined
Nov 24, 2012
Messages
37
Motherboard
Gigabyte Z490 Vision D
CPU
i9-10900K
Graphics
RX 570
Mac
  1. iMac
  2. Mac Pro
All things comes to he (or She) that reads and tests...and re-tests!
I now have everything working 100% and can also record at 96Khz.
The last tidbit to figure out, was in Bios Thunderbolt menu
My Quad was finally working using TB-3 option card
( TB-1 not supported on the Giga Z490 Titan Ridge TB onboard chipset)

To get 96Khz working solid the following settings were made to my BIOS
Enable TBT ASPM - set to L1.1&1.2 This is something to do with Active State Power Management.
Enable LTR Something to do with Latency Reporting
Enable PTM
I have no idea why, but it works now and my UAD Quad with TB-3 Option Card works @96Khz.

Make sure to restart Your UAD devices on reboot!
Hoping this may help someone else in the same boat.
 

Attachments

  • IMG_0383.jpeg
    IMG_0383.jpeg
    5.4 MB · Views: 106
Last edited:
Joined
Nov 24, 2012
Messages
37
Motherboard
Gigabyte Z490 Vision D
CPU
i9-10900K
Graphics
RX 570
Mac
  1. iMac
  2. Mac Pro
UPDATE!
This is for those of you who may be in the same boat of confusion.
After an exhaustive amount of time trying more things I can now say ...I have no clue. None of the settings above seem to make any difference, but restarts and power toggle on the Apollo do. I now have a regimen from a cold boot in the morning.
1: Power up the Apollo and then the computer.
2: Open a Logic template I created @96Khz and leave the window open.
3: test a software synth @96Khz... almost always distorted and pitch detuned
4: Power toggle the Apollo while Logic is open (Logic give error window and defaults to HDMI audio)
5: On restart of Apollo Logic defaults back to the Universal Audio Driver and voila! 96Khz working fine.

I want to also note that with this issue I have noticed sample rate drift running at 44.1 and 48k if I don't restart my system and get 96K locked before I work for the day. It's a slight drift and almost unnoticeable at times, but has devastating sound stage and audio timing drifts while using Flex pitch and timing correction.
 
Joined
Jun 2, 2021
Messages
11
Motherboard
Gigabyte Z490 UD
CPU
i9-10900K
Graphics
W5500
Mac
  1. iMac
Hey, I've been having the same issues you mentioned with my Apollo Twin MK II TB2 when daisy chained to my LG Ultrafine Display. When directly plugged to my Titan Ridge Controller, I have no crackles all the way up to 192Khz. Are you daisy chaining to the Satellite? I'm thinking about getting one, but might just get the PCIe card instead if the issues persist.
 
Joined
Nov 24, 2012
Messages
37
Motherboard
Gigabyte Z490 Vision D
CPU
i9-10900K
Graphics
RX 570
Mac
  1. iMac
  2. Mac Pro
I daisy chain my Apollo QUAD rack mount (TB-3) with a UAD Satellite Quad (TB-2) but no displays or anything else. I see there are numerous reports of strangeness with TB Monitors. I will do a little research and try with and without the TB 2 Quad Satellite and report back in the next day or so.
As stated above, all works 100% if I toggle the Apollo power with Logic 10.6.3 open and allow the hot boot (or Reboot) to lock with logic.

One thing to consider of TB Sat vs PCI cards (maybe do a bit of follow up research to confirm)

I believe I read that the PCI cards don't supply any DSP power to the UA console for live tracking plugins, only for plugins inside your DAW. I'm not sure that is the same if you use LUNA (if you're on Mac)
 
Joined
Jun 2, 2021
Messages
11
Motherboard
Gigabyte Z490 UD
CPU
i9-10900K
Graphics
W5500
Mac
  1. iMac
Yeah I believe PCIe cards (and TB Satellites?) cannot be used as unison inserts in console. I think I'm gonna go with the PCIe card in the coming months, and will report back If I have success at higher sample rates with no clock drift.
 
Joined
Nov 24, 2012
Messages
37
Motherboard
Gigabyte Z490 Vision D
CPU
i9-10900K
Graphics
RX 570
Mac
  1. iMac
  2. Mac Pro
Okay....follow up.
So I tried booting as follows
1: Apollo 8 Quad (TB3) powered on before boot with the Sat Quad daisy chained (TB-2) 44 and 48 drift no 96khz
2: Apollo 8 Quad (TB3) powered on before boot without my Sat Quad daisy chained (TB-2) 44 and 48 drift no 96khz
3: Apollo 8 Quad (TB3) powered AFTER before boot without the Sat Quad daisy chained (TB-2) all works 44 and 48 and 96khz
4: Apollo 8 Quad (TB3) powered AFTER before boot with the Sat Quad daisy chained (TB-2) all works 44 and 48 and 96khz

So what Im seeing is the Titan Ridge Thunderbolt 3 card is working fine it just wants to see the Apollo after start up as a TB 3 hot boot. My system seems pretty stable so I haven't updated to the newest versions of O.C. Here's a pic of the SSDT's I'm currently using
 

Attachments

  • Screen Shot 2021-08-16 at 10.23.00 AM.png
    Screen Shot 2021-08-16 at 10.23.00 AM.png
    538.9 KB · Views: 58
Joined
Aug 23, 2012
Messages
3
Motherboard
ASUS P8Z77-V Pro Thunderbolt
CPU
Ivy Bridge 3770K 3,5GHz
Graphics
Nvidia GT 640
Mac
  1. Mac Pro
So i'm about to upgrade to a new Hackintosh from a Z77x chipset as i'm sick of USB issues, and I need my Apollo's to work.
You seem to be expereinced in that regard so can I confirm if everything is running stabely now? Do you recomend this mobo and setup or have you heard of anything else being more stable?
I have an Apollo 16,Quad, and firewire satellite I want running, so i'm assuming ill need to buy two Thunderbolt 3 cards for the Apollos to daisychain them. Clock drift doesn't sound very appealing!

Thanks for any help!
Tom
 
Joined
Nov 24, 2012
Messages
37
Motherboard
Gigabyte Z490 Vision D
CPU
i9-10900K
Graphics
RX 570
Mac
  1. iMac
  2. Mac Pro
I have everything running rock solid now. I use the onboard TB3 port with no modification daisy chained to a TB3 in my Apollo 8 Quad, TB 2 in my Sat Quad and the PCI solo card picks up the slack (which is rare) in my big mixes.
The biggest thing I found is your power up cycle. I was so used to powering my Apollo first with my old Z77 TB 1 system, (which ran for many years issue free) This time I power my Apollo UAD chain last after the computer is fully booted.
I still don't have Bluetooth working but it's not important for my setup.
iMessage and most Apple stuff is fine with the lack of Handoff and Airdrop again not important
USB ports seem to be fine for what I do with them (a few midi USB devices)

The new machine is a monster, and the old one was no slouch, but I find with the amount of power now I run my Logic Pro X IO buffer @ 32 samples and a ton of realtime plugins and have near imperceptible latency.
BFD Drums Kontakt lots of Plugins from Waves / Plugin Alliance etc.
I something forget to reset my I/O to 1024 to do bigger mixes, and usually hold off putting any UAD stuff on till final mix down, and Im finding I use them less and less.
UAD Plugs always have latency so I find my self moving away from the platform for my "go to's"
If you use the UA Luna DAW there's no latency and monitoring through the UA console there's none, but Im not buying into that ecosystem I feel the days of the need for outboard CPU power for plugins has come to an end. This free's up the possibility of getting into some nicer converters down the road.
 
Top