Contribute
Register

Apfs with fusion drive?

Status
Not open for further replies.
Joined
Dec 20, 2016
Messages
14
Motherboard
ASRock z270m itx/ac
CPU
I3 7100
Graphics
Intel graphics HD630
Mobile Phone
  1. iOS
Im trying to install High Sierra onto my diy fusion drive. Ive searched around and see there are a bunch of issues with apfs fusion drive I’ve tried even partitioning a portion of the drive to hfs+ and installed it but it still kept the partitions and I couldn’t resize it properly. Is there anyway to get High Sierra on a fusion drive even just with hfs+?

My fusion drive consist of 2 ssd 120gb and 1 hdd 2tb
 
Joined
Dec 20, 2016
Messages
14
Motherboard
ASRock z270m itx/ac
CPU
I3 7100
Graphics
Intel graphics HD630
Mobile Phone
  1. iOS
See also this advice from Apple regarding Fusion Drives on High Sierra. Includes Disk Utility/High Sierra Installer steps.
Thanks I tried that but disk utility fails I’m guessing maybe because its not an Apple approved fusion drives. Going to try using CCC to clone it from an external drive and see how that goes
 
Joined
Dec 20, 2016
Messages
14
Motherboard
ASRock z270m itx/ac
CPU
I3 7100
Graphics
Intel graphics HD630
Mobile Phone
  1. iOS
So i was able to get it to boot but it did not put a recovery partition on the fusion drive.
What I did
1. Created a bootable HighSierra on a external ssd
2. Booted into it and opened terminal and created my fusion drive.
3. Used Carbon Copy Cloner and clones the external ssd to the fusion drive.
4. Rebooted and was able to boot into the Fusion drive.
So there is no recovery partition and it did not convert it to apfs. Also Multibeast doesn’t work I’m assuming because I’m on a fusion drive so I had to copy the efi folder from my ssd to my efi partition on one of my fusion drives.
 
Joined
Jul 27, 2012
Messages
31
Motherboard
Gigabyte Z170 Gaming 3-EU
CPU
Intel Core i7-6700 3.4Ghz
Graphics
Nvidia GeForce GTX 1060
Mobile Phone
  1. Android
I've managed to install HS on my Fusion Drive using CCC, it boots correctly. When I install the NVidia Web Drivers, edit the config.plist and reboot I get a kernel panic (0xe). Any clue on why this is happening and how to fix it?
 
Status
Not open for further replies.
Top