Contribute
Register

anyone with asrock z77 pro3 motherboard?

Joined
Oct 3, 2012
Messages
181
Motherboard
Gigabyte X99-SLI
CPU
Xeon E5
Graphics
GT 640
Mac
Mac Pro
Mobile Phone
iOS
I think I followed the directions explained here but I am afraid I messed up my system. Before running the commands above I was able to boot from my Mavericks hd installed with Chimera. Now I can no longer boot from Mavericks and booting attempts from ElCapitan end up on a black screen after what looks like a normal boot (with progress bar going up to about 20% and then switching to a black screen (as if the hard drive activity came to a stop). I probably did something wrong but I have no idea what. I can boot from the USB installer with no problem at all.
I am attaching a Screeshotof Shell bcfg boot dump hoping someone can tell me if it looks the way it should. I also attached a copy of my config. plist
Any help would be greatly appreciated.

Asrock Z97 Extreme 4
 

Attachments

Joined
Jan 28, 2016
Messages
1
Mac
Classic Mac
Mobile Phone
If anyone else is having issues with typing in the UEFI Shell inside Clover (cursor keeps jumping to the beginning of the line randomly) , I found an even easier method. Just download easyUEFI in windows and you can delete and rearrange UEFI entries easily

http://www.easyuefi.com/index-us.html
 
Joined
Sep 20, 2015
Messages
24
Motherboard
Asus Maximus Hero VIII
CPU
I7 6700k
Graphics
HD530
the above fix for asrock boards using a linux distro with efibootmgr did not work for me, but i did find a fix that did from another guide on insanleymac. i post it in hopes that it may help someone else.

The goal of this procedure is to add Clover as a boot item in the BIOS UEFI Boot menu and to get rid of the Clover USB thumb as a boot option.

4.1.1. Restart the system and boot again with the Clover USB thumb drive. You'll see a screen similar to the below (depends on the chosen theme during Clover installation):





4.1.2. Go to Start UEFI Shell 64 (the highlighted icon) and hit enter. Shortly after you'll get the below screen:



Find bootx64.efi on HDD EFI partition with the combination of the following commands:

Shell> map fs*Show all partitions
Shell> fs0: (or fs1: or fs2: ...)Switch to fs0, fs1, fs2,... partitions
Shell> ls List the contents of current partition / directory
Shell> cd \efi\boot Change the directory to \efi\boot

Shell> ls

Then:


Shell> help bcfg -b -v Get help onbcfg command

Shell> bcfg boot dump List current boot options
Shell> bcfg boot add N bootx64.efi "Clover" Add bootx64.efi from the current dir (\efi\boot) as a boot option labeled "Clover" (You will see this name also in the UEFI BIOS Boot menu boot items). N is the boot option number: 0 if you want it to be the first, 1 to be the second, etc.
Shell> bcfg boot dump Check if Clover is added
Shell> reset Restart the system and load Clover from SSD / HDD
i completed this guide and was able to boot into clover from my ssd, however once it tries to boot osx it fails
 
Joined
Jul 23, 2011
Messages
64
Motherboard
Asrock P67 Extreme 4
CPU
2500k
Graphics
GT740
Mac
iMac
Mobile Phone
iOS
Well this is also one of a few issues I am having with....

I have have an asrock p67 extreme 4 and I noticed that I could only boot when thumb drive was plugged in....

I am using the UEFI booth method since this 6 series board had uefi


Did you have to do anything other than generate an ssdt to get the 2500k working?

I have to use cpus=1 and nv_disable=1 which I cant figure out how to get my geforce gtx 260 working without that
 
Joined
Jun 9, 2013
Messages
10,964
Motherboard
GA-H77N-WIFI
CPU
Core i7-3770
Graphics
Intel HD 4000
Mac
MacBook, Mac mini
Mobile Phone
Android
Well this is also one of a few issues I am having with....

I have have an asrock p67 extreme 4 and I noticed that I could only boot when thumb drive was plugged in....

I am using the UEFI booth method since this 6 series board had uefi


Did you have to do anything other than generate an ssdt to get the 2500k working?

I have to use cpus=1 and nv_disable=1 which I cant figure out how to get my geforce gtx 260 working without that
Have you installed Clover to your main OS X drive? Sounds like to me that the Bootloader isn't installed.
 
Joined
Oct 3, 2011
Messages
30
Motherboard
Asrock Z97 Extreme4
CPU
Intel Core i7 4790K @4.0Ghz
Graphics
Intel HD4600
I think I followed the directions explained here but I am afraid I messed up my system. Before running the commands above I was able to boot from my Mavericks hd installed with Chimera. Now I can no longer boot from Mavericks and booting attempts from ElCapitan end up on a black screen after what looks like a normal boot (with progress bar going up to about 20% and then switching to a black screen (as if the hard drive activity came to a stop). I probably did something wrong but I have no idea what. I can boot from the USB installer with no problem at all.
I am attaching a Screeshotof Shell bcfg boot dump hoping someone can tell me if it looks the way it should. I also attached a copy of my config. plist
Any help would be greatly appreciated.

Asrock Z97 Extreme 4
Hi Coquin!

Just want to know if you were able to solve the problem of not being able to boot from your ssd/hdd.
I have the same mother board AsRock Z97 Extreme 4 as you have. I hesitated to try the method of ctyler when I read your post that you messed up your system.

Can you please check the version of your bios?

Thank you in advance!
 
Joined
Oct 3, 2011
Messages
30
Motherboard
Asrock Z97 Extreme4
CPU
Intel Core i7 4790K @4.0Ghz
Graphics
Intel HD4600
the above fix for asrock boards using a linux distro with efibootmgr did not work for me, but i did find a fix that did from another guide on insanleymac. i post it in hopes that it may help someone else.

The goal of this procedure is to add Clover as a boot item in the BIOS UEFI Boot menu and to get rid of the Clover USB thumb as a boot option.

4.1.1. Restart the system and boot again with the Clover USB thumb drive. You'll see a screen similar to the below (depends on the chosen theme during Clover installation):





4.1.2. Go to Start UEFI Shell 64 (the highlighted icon) and hit enter. Shortly after you'll get the below screen:



Find bootx64.efi on HDD EFI partition with the combination of the following commands:


Shell> map fs*Show all partitions

Shell> fs0: (or fs1: or fs2: ...)Switch to fs0, fs1, fs2,... partitions
Shell> ls List the contents of current partition / directory
Shell> cd \efi\boot Change the directory to \efi\boot
Shell> ls

Then:

Shell> help bcfg -b -v Get help onbcfg command

Shell> bcfg boot dump List current boot options
Shell> bcfg boot add N bootx64.efi "Clover" Add bootx64.efi from the current dir (\efi\boot) as a boot option labeled "Clover" (You will see this name also in the UEFI BIOS Boot menu boot items). N is the boot option number: 0 if you want it to be the first, 1 to be the second, etc.
Shell> bcfg boot dump Check if Clover is added
Shell> reset Restart the system and load Clover from SSD / HDD
Thank you ctyler !
Your guide worked for me!
 
Joined
Apr 8, 2015
Messages
2
Motherboard
AsRock Z77 Extreme 4
CPU
I5 2500k
Graphics
Nvidia GTX 970 SLI
Mac
Classic Mac
Mobile Phone
*Edit* With the cpus=1 boot option i can run the installer, but I have to delete the dart=0 boot option(I don't know the use for this). I hope everything will run fine form now on :D *Edit*



Hay Guys, every time I run the installer, the apple logo appears and it tries to load, but at a quarter it stops and I get an error message
20160704_150221.jpg


After I unplugged my GPU and tried with my on board GPU, I received
this error message
20160705_161501.jpg
and in the second try I received the first error message again :(
I'm clueless and thanks for your help.
(I'll install El Capitan)
Specs: Z77 extreme 4
Core i5 2500k
EVGA Nvidia GeForce GTX 970 SSC
8GB Corsair Vengeance LP Singel Channel (2x4 GB Sticks)
Original MacBook pro 13" 360 GB HDD
 
Last edited:
Joined
Apr 2, 2011
Messages
11
Motherboard
775,1156,1366.1155
CPU
various intel
Graphics
amd,nvidia,intel
Mac
iMac, MacBook, MacBook Air, MacBook Pro, Mac Pro
Classic Mac
iMac, Power Mac
Mobile Phone
Android, iOS, Other
Success Finally........
Had the same prob booting clover uefi from my hackintosh ssd on a asrock h61m/u3s3 mobo,
could only boot from a usb stick..no ssd or hdd sata boot would ever work.
Ironically if i connected the ssd drive to a usb adapter,then it did boot but as usb only..

Originally this fix was aimed at laptop user,but it worked great for my desktop.
https://www.tonymacx86.com/threads/acer-aspire-5750g-with-mavericks-10-9-clover-install-guide.112684/

See post 1,scroll to step 7 and read last paragraph.
-----------------------------------------------------------------------------------------------
Quote..
Go into EFI/Microsoft/Boot/ and select the file called 'bootmgfw.efi' rename it to 'bootmgfw-orig.efi'. Then you need to take the CLOVERX64.efi file from EFI/CLOVER/ and place it inside of EFI/Microsoft/boot/ and rename it to 'bootmgfw.efi'.
You can delete the folder /EFI/BOOT. It only contains the file BOOTX64.efi which is exactly the same as CLOVERX64.efi. For our system we don't need that folder.
End Quote..
--------------------------------------------------------------------------------------------------
I Followed the above info and uefi boot is now up an working...currently booting mavericks/sierra
Made a new folder inside EFI called ...Microsoft... and inside that created another folder..Boot...
paste the CLOVERX64.efi into Boot and rename to bootmgfw.efi

At Startup
To hide dummy "windows" clover boot option....
Clover bootmanager will show a option to boot windows.
To hide this...go into clover configurator mount your efi partition,
Open clover config.plist in configurator choose Gui section add new entry in Hide Volume.. \EFI\MICROSOFT
Save config.plist next time you boot windows is no longer there..

You may need to change uefi bios boot order, and boot up from the drive with dummy "Windows" selected as the boot os.
For me,no more need to boot from usb stick
 
Last edited:
Joined
Jun 29, 2017
Messages
11
Motherboard
Z77 OC Formula 2nd gen
CPU
i7 2600k 3.4 turbo
Graphics
EVGA 1070 FTW2
Mac
iMac, MacBook Air
Mobile Phone
Android
If somebody can help me with booting my uefi AsRock. i cannot boot either. I'm not sure if i'm doing it right also. I followed the steps and when i get to the part. bcfg boot add N bootx64.efi "Clover"

it gives me a message saying invalid arguments - N

Please Thank you
 
Top