Contribute
Register

Anyone using the Magic Mouse without Issues on a Hackintosh?

Joined
Apr 9, 2013
Messages
1
Mac
Classic Mac
Mobile Phone
I just ran into this problem. I typically shut down my Mackintosh when I'm not using it but had left it up for a few weeks. I restarted and found the magic mouse would jump to the upper left hand corner whenever I lifted it. The gestures and clicking would not work either. I am using the IO Gear BT adapter and it has been working well. I had moved it to be closer to the mouse after the mouse would loose connection periodically. The fix was to unplug the adapter and plug it back in. After that the mouse functionality returned to normal.
 
Joined
Jun 1, 2011
Messages
14
Motherboard
Gigabyte UD2H-B3
CPU
i7 2600K
Graphics
HD 6870
Mac
Classic Mac
Mobile Phone
Just a quick update regarding the Magic Mouse 2. It's scrolling function does not work in OSX Yosemite and lower, which is completely ridiculous for something simple as a mouse. The only way to get full support is to update to El Capitan, which is not the most interesting thing to do for a lot of systems due too USB3 issues.
 
Joined
Sep 20, 2015
Messages
94
Motherboard
Asus P8Z77-V LK
CPU
Intel i7-3770K 3.5Ghz
Graphics
MSI Geforce GTX 970 Gaming 4G/4096 GDDR5 Overclock Edition
Mac
Classic Mac
Mobile Phone
I've got a magic mouse showing up tomorrow, I currently have an IOGEAR GBU521 that so far has not given me any issues and running El Capitan. I hope it works. :)
 
Joined
Sep 20, 2015
Messages
94
Motherboard
Asus P8Z77-V LK
CPU
Intel i7-3770K 3.5Ghz
Graphics
MSI Geforce GTX 970 Gaming 4G/4096 GDDR5 Overclock Edition
Mac
Classic Mac
Mobile Phone
Magic mouse with IOGEAR working with no issues so far. Paired up in seconds. I also tried shutting down and restarting to be sure and it's still paired. It's an awesome mouse.
 
Joined
Sep 20, 2015
Messages
94
Motherboard
Asus P8Z77-V LK
CPU
Intel i7-3770K 3.5Ghz
Graphics
MSI Geforce GTX 970 Gaming 4G/4096 GDDR5 Overclock Edition
Mac
Classic Mac
Mobile Phone
So far the only thing I noticed is once in a great while the mouse will disconnect for like a second or two, and reconnect. It hardly happens. Wondering if perhaps I should get one of those Rockfetfish dongles like others have.
 
Joined
Jul 12, 2015
Messages
1
CPU
i7
Graphics
760gtx
Mac
Classic Mac
Mobile Phone
I just completed my Hackintosh build, and the Magic Mouse I got off eBay is giving me fits. It will not track worth a darn, looses connection, etc, etc. It was supposed to be brand new, and it looks like it is (even came with the new batteries). I am using a Sabrent Micro USB Bluetooth adapter, which is on the approved list as working OOB (and it does). http://www.frys.com/product/6103319

I am trying to determine if the Mouse is defective, or my bluetooth module is the problem.

Can anyone confirm they actually this device w/o issues? The internet is flooded with people reporting that it looses signal frequently. I have tried multiple trouble shooting techniques, mark a favorite, reset EPROM (or whatever it is called), new batteries, reboot etc, etc.

Any ideas?

I was thinking of going to the Apple Store to pick up another one to test and see if works any better.
I found the following points useful:
+install "Continuity-activation-tool-master"
+small distance between magic mouse and bluetooth dongle
+using USB 2.0 instead of 3.0

My magic mouse and my apple keyboard (2016) are now working without any issues under El Capitan.
 
Joined
Mar 27, 2015
Messages
30
Motherboard
Asus X99 Deluxe
CPU
i7-5820K
Graphics
GTX 980
Mac
MacBook Pro, Mac Pro
Mobile Phone
Android
Hello all,

My solution:

In the 1st config I've plugged the BT dongle GBU521 to an USB 2.0 port on the rear IO panel of the motherboard. The distance to the mouse was 20 inches. In this config I'd some problems with the connection.

For the 2nd and successful config I put the BT dongle to the right USB port on the USB attached Apple keyboard. The distance to the Magic Mouse was reduced to 10 inches.

Bye Oli
I just went out of the way to log in to say THANK YOU. I thought of moving it from the back to the front (helped) but now it's on the keyboard and works really well.
 
Joined
Nov 8, 2015
Messages
6
Motherboard
Gigabyte Z97MX-Gaming 5
CPU
Intel Core i7 4790K
Graphics
EVGA GeForce GT740 SC
Mac
MacBook Pro
Mobile Phone
iOS
Hello all,

For those lucky of you whose BT mouse is working correctly, I assume everything is working? I mean scrolling, gestures, etc?
My problem is that my Magic Mouse 2 pairs right away, but it is not recognized as a Magic Mouse. The gestures don't work and I cannot configure it under system preferences.

Can you guys please confirm that your Magic Mouse is seen by El Capitan as a Magic mouse, and if so, state what BT you are using, what version of El Capitan and whether you had to tinkered with the kexts or not? It would be great to get a "summary" from people who've been successful.

Thanks!!
 

tonymacx86

Administrator
Staff member
Joined
Nov 18, 2009
Messages
8,486
Motherboard
GA-Z270X-UD5
CPU
Core i3-7100
Graphics
HD 630
Mac
MacBook Pro, Mac mini
Classic Mac
Apple, PowerBook
Mobile Phone
iOS
Joined
Nov 8, 2015
Messages
6
Motherboard
Gigabyte Z97MX-Gaming 5
CPU
Intel Core i7 4790K
Graphics
EVGA GeForce GT740 SC
Mac
MacBook Pro
Mobile Phone
iOS
The first one is exactly the BT I have!! Are you running 10.11.4?
 
Top