Contribute
Register

Anyone using the Magic Mouse without Issues on a Hackintosh?

Joined
Mar 6, 2011
Messages
12
Motherboard
GA-X58A-UD3R 2.0 FH
CPU
i7 940 @ 3.07ghz
Graphics
GIGABYTE GV-R577UD-1GB Radeon HD 5770
Mac
MacBook Pro, Mac mini
Mobile Phone
iOS
I suspect the issue is with the Sabrent adapter and not the Magic Mouse. I just received my adapter and mouse today - so excited to use them and my excitement was ripped from my soul - thank you Sabrent.

The problem is that the mouse stays connected but it stops making the cursor move and clicking/gestures don't work - might as well be 'off'. This happens randomly but the mouse never works for longer than 30 seconds.

Lesson learned, Rocketfish Adapter ordered.
 
Joined
Nov 23, 2012
Messages
36
Motherboard
GA-Z77-UP5TH
CPU
Core i7-3770K
Graphics
NVIDIA GeForce GTX 780
Mobile Phone
iOS,
Hello all,

My solution:

In the 1st config I've plugged the BT dongle GBU521 to an USB 2.0 port on the rear IO panel of the motherboard. The distance to the mouse was 20 inches. In this config I'd some problems with the connection.

For the 2nd and successful config I put the BT dongle to the right USB port on the USB attached Apple keyboard. The distance to the Magic Mouse was reduced to 10 inches.

Bye Oli
 
Joined
Aug 5, 2012
Messages
12
Motherboard
Gigabyte z390 Aorus Pro
CPU
i9-9900K
Graphics
RX 570
Mac
iMac, MacBook, MacBook Pro, Mac mini
Mobile Phone
iOS
Yep this totally fixed my magic mouse issues. Instantly. Using the IOGear BT adapter that is recommended on this site.

moved it from the back USB on my computer to the front.... got better performance but still glitchy. Moved it from the computer to a powered USB hub on my desk... Perfect.
 
Joined
Feb 17, 2011
Messages
86
Motherboard
ASUS X299 Prime Deluxe
CPU
i7-7820X
Graphics
Vega 64
Mac
MacBook Pro
Mobile Phone
iOS
moved it from the back USB on my computer to the front.... got better performance but still glitchy. Moved it from the computer to a powered USB hub on my desk... Perfect.
This was the solution for my connection problems!
 
Joined
May 31, 2011
Messages
3
Motherboard
Intel S5520HC hackintosh
CPU
Xeon E5620
Graphics
Nvidia 640GT
Mac
MacBook Air
Classic Mac
Mobile Phone
iOS
After reading this thread I moved my kensington bluetooth adapter from the bottom usb ports in front of my case to an extension cable up on my desk. Now all is working (gestures, no random volume increases, no jumpiness). I'm on mavericks btw
 
Joined
Jun 2, 2013
Messages
1
Mac
Classic Mac
Mobile Phone
Hi everybody
I have the iogear BT and the mouse works well, but sometimes (it happend 2 or 3 times) when you stand up the mouse to move it along the screen (sorry for the expression but I don't know how to say in English) it goes to the top-left corner :(
The first time I could solve it, pairing again the mouse (I don't remember the exact steps) but now... it happends again and I can re- pair the mouse. If I go to BT menu, I can activate o deactivate the mouse, and I can see how it shows the message that "Carlos' mouse has been discovered"

Anyone with the same problem?

thanks and regrds
 
Joined
May 29, 2013
Messages
2
Mac
Classic Mac
Mobile Phone
I'm getting the exact same issue. Jumping to the top left corner when i pick up the mouse to scroll.

Gone back to wired mouse but would love to hear a solution quick!

PLEASE SAVE US SOMEBODY!

Thanks in advance
 
Joined
Sep 13, 2012
Messages
1
Motherboard
Gigabyte GA-P55M-UD2
CPU
Core i3-540
Graphics
Asus GTS450
Mac
Classic Mac
Mobile Phone
Same here. My Fix was to disconnect the BT dongle and plug it back in. All of the problems went away immediately. Scroll is working, no more random jumping around.

Hope this helps.
 
Joined
Jun 15, 2013
Messages
56
Motherboard
GA-Z97X-UD7 TH
CPU
Intel 4790
Graphics
NVIDIA GTX 960
Same here. My Fix was to disconnect the BT dongle and plug it back in. All of the problems went away immediately. Scroll is working, no more random jumping around.

Hope this helps.
YES! Thank you... Here I was blaming my changes to AppleHDA.kext :) - "how the hell did I do that?"
 
Joined
Jul 11, 2014
Messages
111
Motherboard
X99-Deluxe II ASUS
CPU
6950X
Graphics
ASUS GTX-960
Mac
iMac, MacBook Pro, Mac Pro
Mobile Phone
Android
My MM from time to time jumps to the upper right hand corner...and my solution is to open the BT preference pane and right click the mouse listing and remove it, then pair again.
On my mackintosh I always have a second (logitech wireless) mouse which works when in the bios and for situations like this when MM fails,
 
Top