Contribute
Register

Anyone got the LG 34" 34WK95U Monitor Working on Hackintosh?

Joined
Jan 17, 2018
Messages
24
Motherboard
Z370 AORUS Gaming 7
CPU
i7-8700K
Graphics
Radeon VII + GTX 1080 Ti
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Quick update: tried Thunderbolt port but got no luck.

I connect the two DP from the GPU to my thunderbolt card and connect the monitor to the Thunderbolt port, and here's what I got: system believes I have TWO monitors connected, LOL


Screen Shot 2019-02-01 at 10.17.06 PM.png
 
Joined
Aug 19, 2010
Messages
526
Motherboard
GA-Z390 Designare
CPU
i7 9900K
Graphics
UHD630 & Radeon VII
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac mini
  4. Mac Pro
Mobile Phone
  1. iOS
Anyone else figure this out? The monitors are working well but i can't get the HiDPI resolutions i want. Basically the only options presented that are at full 5K are 5120x2160 (which is 1:1 and everything is too small on the monitor for practical everyday use) or 2560x1080, which puts the monitors into 5120x2160 full rez mode but doubles the scaling on everything. This looks good, but everything is too large (scaled up) for my taste- i dont want such a small "looks like" resolution.

The sweet spot for these monitors is a HiDPI scaled 3440x1440 resolution, where the image is processed at some 6K+ (i think 6880 x 2880 is the resolution it renders the desktop at) and then downscales to 5120x2160 and scaled as though it was 3440x1440. I dont understand why the full HiDPI modes (and even the typical HiDPI scaled menu in system preferences->Displays) is missing. If i plug my real MacBook pro into the monitor i get the proper resolution options i am after (with the typical HiDPI scaled menu options for "more space" or "larger text". But on my hackintosh i don't get these options. i have tried with a 1080ti in 10.13.6, then a Vega64 in mojave and now using a radeon vii in 10.14.5 and the issue persists regardless of the setup.

Thanks,
g\
 
Last edited:
Joined
Dec 24, 2018
Messages
25
Motherboard
ASUS Z370 ROG MAXIMUS X HERO
CPU
i7-8700K
Graphics
Radeon VII
Looks like after 1/2 year there is no treat yet, It looks like you tried everything
 
Joined
May 21, 2016
Messages
98
Motherboard
Gigabyte Z370 HD3
CPU
I5-8600K
Graphics
RX 570
Mac
  1. iMac
Mobile Phone
  1. iOS
Looks like after 1/2 year there is no treat yet, It looks like you tried everything

the screen issue really makes me switch back to Windows for most of the time... after all the satisfaction gained from getting a full operatable hackintosh....
 
Joined
Jan 17, 2018
Messages
24
Motherboard
Z370 AORUS Gaming 7
CPU
i7-8700K
Graphics
Radeon VII + GTX 1080 Ti
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Well, after sitting at the corner for three months, I finally light up this 5k2k baby successfully.
It is running at 3840x1620@60hz right now. (Perfectly fine with 5120x2160 if you're curious)
405249



I have 1080ti with two DP connected to the Thunderbolt mini-DP (Gigabyte GC-ALPINE RIDGE (rev. 2.0))
and connect to the monitor with the Type-C connector.

Everything is running fine except that only DP 1.2 works (tried switch to DP 1.4 in the monitor settings but it won't light up, will try again later) and the USB upstream only works with USB-B mode which isn't a big deal.
Oh, also macOS is not recognizing the monitor as a sound output device which used to work fine, so I will try to work this out later, but who needs the terrible speakers anyway.

FYI. I'm running:
macOS 10.13.6 17G6030
Web Driver 387.10.10.10.40.127
 
Joined
Aug 19, 2010
Messages
526
Motherboard
GA-Z390 Designare
CPU
i7 9900K
Graphics
UHD630 & Radeon VII
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac mini
  4. Mac Pro
Mobile Phone
  1. iOS
Well, after sitting at the corner for three months, I finally light up this 5k2k baby successfully.
It is running at 3840x1620@60hz right now. (Perfectly fine with 5120x2160 if you're curious)

Are you saying you have HiDPI mode working? What were the steps you took to get that working? can you post your EFI folder? And mention any other graphics related kexts you might have installed?
 
Joined
Jan 17, 2018
Messages
24
Motherboard
Z370 AORUS Gaming 7
CPU
i7-8700K
Graphics
Radeon VII + GTX 1080 Ti
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Are you saying you have HiDPI mode working? What were the steps you took to get that working? can you post your EFI folder? And mention any other graphics related kexts you might have installed?

I don't remember having any special hacks/kexts installed.


I bought the monitor and plug it directly to the DP on 1080Ti it didn't work, then I bought the Thunderbolt card and it's still not running at full resolution until last week.
I saw the new updates for Webdriver and figured maybe Nvidia has fixed it for me so I tried and succeed.

FYI. I haven't updated my EFI stuff for months, things could be pretty outdated.
 

Attachments

  • EFI.zip
    58.3 MB · Views: 141
Joined
Dec 24, 2018
Messages
25
Motherboard
ASUS Z370 ROG MAXIMUS X HERO
CPU
i7-8700K
Graphics
Radeon VII
did anyone else tried this? I am running Mojave on RX580 thru DP 34WK95U best I get 2560x1080 HiDPI, higher resolution unusable
 
Joined
Dec 28, 2018
Messages
24
Motherboard
Gigabyte Z390 Aorus Pro
CPU
i9-9900K
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
I am using LG 34" 34uc99-w connected via display port to Geforce GTX 970 and absolutely no problem (running at High Sierra, because of Nvidia card)
409749
 
Joined
Aug 19, 2010
Messages
526
Motherboard
GA-Z390 Designare
CPU
i7 9900K
Graphics
UHD630 & Radeon VII
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac mini
  4. Mac Pro
Mobile Phone
  1. iOS
I am using LG 34" 34uc99-w connected via display port to Geforce GTX 970 and absolutely no problem (running at High Sierra, because of Nvidia card)
Your reports are not relevant to us. Of course your monitor is working fine, it has a maximum resolution of 3440x1440. monitors of that resolution have always worked correctly. The issue we are trying to solve is with our higher resolution 5Kx2K monitors.

g\
 
Top