Contribute
Register

Any fix to the Garbled/Distorted Headphone issue?

Joined
Feb 9, 2017
Messages
5
Motherboard
Clover, Dell 15r-5537 - model: 0845MX - haswell ULT chipset
CPU
core i5-4200u code Name: Haswell ULT
Graphics
intel HD4400 - 1366x768
Mobile Phone
Android
The HD4400/HD4600 plist file does not have the patches for AppleHDA ALC283. Those patches are in the config.plist provided im my u430 repo.
oh yea i have seen it. So i have to inject those patches from that plist into the HD4400/HD4600 plist (as it is the one currently in my EFI partition)?
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,123
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
oh yea i have seen it. So i have to inject those patches from that plist into the HD4400/HD4600 plist (as it is the one currently in my EFI partition)?
Yes, of course. You use copy/paste with plist editor to copy into your own config.plist.
 
Joined
Feb 9, 2017
Messages
5
Motherboard
Clover, Dell 15r-5537 - model: 0845MX - haswell ULT chipset
CPU
core i5-4200u code Name: Haswell ULT
Graphics
intel HD4400 - 1366x768
Mobile Phone
Android
Yes, of course. You use copy/paste with plist editor to copy into your own config.plist.
thank you, will try it tonight and post any outcomes/updates
 
Joined
Feb 9, 2017
Messages
5
Motherboard
Clover, Dell 15r-5537 - model: 0845MX - haswell ULT chipset
CPU
core i5-4200u code Name: Haswell ULT
Graphics
intel HD4400 - 1366x768
Mobile Phone
Android
Yes, of course. You use copy/paste with plist editor to copy into your own config.plist.
Been moving around past week. So am back trying to fix the sound. I am trying to decompile and check my DSDT for errors before I start applying the sound Patch. It has no errors but has warnings. Do i just ignore the warnings?
 

Attachments

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,123
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Joined
Mar 21, 2016
Messages
2
Mac
Classic Mac
Mobile Phone
Newcomer here, I'm using the CodecCommander just fine but when I unplug and replug in my headphones the audio gets jumbled again. Any fix?
 
Joined
Jul 4, 2017
Messages
18
Motherboard
Dell Inspiron 3558 (CloverUEFI)
CPU
Intel Core i3 5015u
Graphics
Intel HD Graphics 5500 (1366*768)
Mac
MacBook Pro
Mobile Phone
Android
Hi Rehabman,

I tried your command "hda-verb 0x19 SET_PIN_WIDGET_CONTROL 0x25" and it works!! It solves the headphone issue. I modified the codeccommander.kext info.plist exactly as yours. Now everything is working properly. =] Thanks a lot!
Hello
Can you help with the file or something as yours is working now.
I have the same hardware; sound plays good with internal speakers but too bad from headphones.
 
Joined
Jun 1, 2018
Messages
14
CPU
Intel Core i5 8250U
Graphics
Intel UHD Graphics 620
Mobile Phone
Android
On Acer aspire e5 576g-5762 with ALC 887 i fixed this audio issue just doing what rehabman put here and nothing more:

First you need to build and install CodeCommander and hda-verb.

Code:
cd ~
mkdir Projects
cd Projects
git clone https://github.com/RehabMan/EAPD-Codec-Commander.git codec.git
cd codec.git
make
make install
 
Top