Contribute
Register

An iDiot's Guide To iMessage

P1LGRIM

Moderator
Joined
Mar 2, 2012
Messages
18,928
Motherboard
Lenovo ThinkStation p300 ⌘
CPU
i7-4790K
Graphics
Intel HD Graphics 4600
Mac
MacBook Pro, Mac mini
Classic Mac
Power Mac
Mobile Phone
iOS
Thanks
how to have enO Builtin
802.11 is Wireless not Ethernet.
You must have Ethernet as en0 and BuiltIn.

The Guide said:
This is not intended as a help thread, requests for help will be deemed off-topic and removed.
For help with iMessage refer to the comprehensive How to Fix iMessage Guide thread.
 

P1LGRIM

Moderator
Joined
Mar 2, 2012
Messages
18,928
Motherboard
Lenovo ThinkStation p300 ⌘
CPU
i7-4790K
Graphics
Intel HD Graphics 4600
Mac
MacBook Pro, Mac mini
Classic Mac
Power Mac
Mobile Phone
iOS
I've been troubleshooting this exact problem the last four hours without any luck. I have run through this guide several times and the only step I've skipped is the "checkcoverage.apple.com" section where I'm supposed to see the "We're sorry, but this serial number is not valid. Please check your information and try again" prior to continuing. The reason I skipped this step is because the website seems to be down, all I see is "we'll be back soon" every time I load the page from any device. I assumed if I skipped this step, I would be unlucky only one or two times before getting a good match with the serial/uuid. However, that's not the case. It's been a good 7 or 8 combinations and I'm still having the same issue as you mentioned, where I see the recipient in red and I get the "_____ is not registered with iMessage".

One thing I noticed is that when I run iMessageDebug and save the .txt, the UUID inside that file isn't and hasn't been identical to the uuid that's saved in my config.plist. However, everything remains identical when I run iMessageDebug after a restart and compare it to the saved .txt.

Am I extremely unlucky here and have not found a successful serial/uuid combination in the 7 or 8 tries or do we think it may be something else? Also, is "checkcoverage.apple.com" reading "We'll be back soon" message to anyone else or is that just me? Could this verification be what's preventing me from successfully getting iMessage to work? I have gotten iMessage to work (with this guide) on my last install over the weekend, but since I'm running a new SSD, I have to get everything working again. If anyone has an input, I'd really appreciate it.
The Guide said:
This is not intended as a help thread, requests for help will be deemed off-topic and removed.
For help with iMessage refer to the comprehensive How to Fix iMessage Guide thread
 

P1LGRIM

Moderator
Joined
Mar 2, 2012
Messages
18,928
Motherboard
Lenovo ThinkStation p300 ⌘
CPU
i7-4790K
Graphics
Intel HD Graphics 4600
Mac
MacBook Pro, Mac mini
Classic Mac
Power Mac
Mobile Phone
iOS
Many thanks P1LGRIM for this guide
I'm on a Macbook pro8,2 with Sierra 10,12,6
first: I cant find "show library folder" and all those files in caches & preferences
second: I get System-ID: failed on iMessage Debug
little help pls
The Guide said:
This is not intended as a help thread, requests for help will be deemed off-topic and removed.
For help with iMessage refer to the comprehensive How to Fix iMessage Guide thread
 
Joined
Jan 5, 2018
Messages
3
CPU
i7 4700MQ
Graphics
intel HD 4600 + GT 740M
hello P1LGRIM
instead of "com.apple.ids.service", I have "com.apple.ids.subservices"
should I delete this file?
thank you
 

P1LGRIM

Moderator
Joined
Mar 2, 2012
Messages
18,928
Motherboard
Lenovo ThinkStation p300 ⌘
CPU
i7-4790K
Graphics
Intel HD Graphics 4600
Mac
MacBook Pro, Mac mini
Classic Mac
Power Mac
Mobile Phone
iOS
hello P1LGRIM
instead of "com.apple.ids.service", I have "com.apple.ids.subservices"
should I delete this file?
thank you
Your choice - It will be recreated next boot.
 

P1LGRIM

Moderator
Joined
Mar 2, 2012
Messages
18,928
Motherboard
Lenovo ThinkStation p300 ⌘
CPU
i7-4790K
Graphics
Intel HD Graphics 4600
Mac
MacBook Pro, Mac mini
Classic Mac
Power Mac
Mobile Phone
iOS
This works like a charm on my MSI 370A-PRO i8700k system! iMac 18,3! Thanks!
Thanks for the feedback.
It's good to know that it still works, I haven't done a new build in ages.
 

P1LGRIM

Moderator
Joined
Mar 2, 2012
Messages
18,928
Motherboard
Lenovo ThinkStation p300 ⌘
CPU
i7-4790K
Graphics
Intel HD Graphics 4600
Mac
MacBook Pro, Mac mini
Classic Mac
Power Mac
Mobile Phone
iOS
P1LGRIM, Could you help me to check my config.plist? I always get ROM: ffffffffffff with this config.
the Guide said:
This is not intended as a help thread, requests for help will be deemed off-topic and removed.
For help with iMessage refer to the comprehensive How to Fix iMessage Guide thread.
The Guide said:
You must have a working Ethernet connection which is defined as BuiltIn and en0.
An easy way to determine this is with the DPCIManager app.
It is possible to connect with a Wireless adaptor but you must have working Ethernet which is BuiltIn and en0 too.
This is the most basic fundamental and the one that is overlooked most by laptop users although it is equally valid for desktop users too.
 
Top