Contribute
Register

AMD RX 4XX graphics cards in Sierra.

Status
Not open for further replies.
Joined
Sep 4, 2016
Messages
10
Motherboard
Gigabyte Z170MX Gaming 5
CPU
Intel i5 6600K
Graphics
AMD RX 480
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
The update went well. I restarted my desktop and used a DVI cable on the Z-170MX during the update.

The LAN and the sound worked out of the box. I still had to edit the kexts to reflect the device ID of the reference RX 480.

Upon restarting, I paused at the Clover boot menu, removed the DVI and replaced it with the HDMI cable. I hit enter and the desktop booted as normal.

I noticed that Safari is fine. Preview now works, even with large PDFs. All pages load correctly and I am happy. Goodbye, Chrome. :)
 
Joined
Nov 10, 2016
Messages
3
Graphics
RX 480
Hi guys. I just try to get work my first eGPU, and unfortunetlly i have a little issue.
I use Sonet Echo III - D TB2 and Saphire Radeon RX480 Nitro 4g. I just install fresh system (sierra), have plug-in everything, but my system doesn't see the graphic card. In "This mac" ---> system report ---> PCI there is an information "An error occurred retrieving information about the PCI device."
I also try to put on the Sonet PCIe card from MOTU HD Express, and it's work fine.

Does anyone have an idea what may go wrong ? Thanks for the replay !
 
Joined
Mar 20, 2013
Messages
11
Motherboard
GA-Z77X-UP5 TH
CPU
i7-3770
Graphics
MSI GTX 980 Ti Gaming
Mac
  1. Mac Pro
Anyone tested the Powercolor RX 480 8GB Reference Model? Is it compatible?
 
Joined
Mar 20, 2013
Messages
11
Motherboard
GA-Z77X-UP5 TH
CPU
i7-3770
Graphics
MSI GTX 980 Ti Gaming
Mac
  1. Mac Pro
The RED DEVIL works well.

Yeah but I wanted the reference model and seems like not many brands are available now for that.
The reference model blow hot air out the back which is what I wanted, and someone is selling a Powercolor one where I am staying.
 

Gigamaxx

Moderator
Joined
May 15, 2016
Messages
6,558
Motherboard
GIGABYTE X470 Arous Gaming 7 WiFi
CPU
Ryzen R9 3900X
Graphics
RX 480
Mac
  1. iMac
Yeah but I wanted the reference model and seems like not many brands are available now for that.
The reference model blow hot air out the back which is what I wanted, and someone is selling a Powercolor one where I am staying.

The reference model should work, the vbios is the same.
 

Gigamaxx

Moderator
Joined
May 15, 2016
Messages
6,558
Motherboard
GIGABYTE X470 Arous Gaming 7 WiFi
CPU
Ryzen R9 3900X
Graphics
RX 480
Mac
  1. iMac
Yeah but I wanted the reference model and seems like not many brands are available now for that.
The reference model blow hot air out the back which is what I wanted, and someone is selling a Powercolor one where I am staying.

The reference model should work, the vbios is the same.
 
Joined
Jan 6, 2017
Messages
15
Motherboard
GIGABYTE GA-Z170X-UD3
CPU
Intel Core i7 6700k
Graphics
ASUS AMD RADEON RX 480 STRIX
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. Android
  2. iOS
I have Asus RX 480 Strix and Sierra 10.12.beta1 installed - but no acceleration so far. I tried to use FakeId but it is not enough - I can do some checks

I have the same car (just installed a new 10.12.2 machine) I changed the entry in the 4100 kext file, changed ownership of the file too.
Nothing. This is what I see AMD R9.
 

Attachments

  • Screen Shot 2017-01-08 at 21.52.47.png
    Screen Shot 2017-01-08 at 21.52.47.png
    106.2 KB · Views: 132

Gigamaxx

Moderator
Joined
May 15, 2016
Messages
6,558
Motherboard
GIGABYTE X470 Arous Gaming 7 WiFi
CPU
Ryzen R9 3900X
Graphics
RX 480
Mac
  1. iMac
I have the same car (just installed a new 10.12.2 machine) I changed the entry in the 4100 kext file, changed ownership of the file too.
Nothing. This is what I see AMD R9.

The 67EO definition is buggy have you tried the FF or EF definition in 4100kext? The latest clover boot loaders if you inject ATI will give you the proper definition.
 
Status
Not open for further replies.
Top