Contribute
Register

<< Solved >> AMD Radeon RX5700 or 5700XT

Joined
Jun 5, 2015
Messages
13
Motherboard
Asus Prime X299 Deluxe
CPU
i9 9960X OC 4.9Ghz
Graphics
Dual AMD RX5700XT
Mac
  1. Mac Pro
Mobile Phone
  1. Android
Hello everyone!!! This is my first publication after many years of reading and using TonymacX86!

After my update to macOS Catalina Beta 10.15.1 (beta3), I decided to try a pair of GPUs from the AMD Navi series (RX5700 and. 5700XT), getting a good result after a day of problems and some crashes.

It is important to delete WhatevergreenKext to get a complete job, if you do not remove it you will get a black screen or some kernel panics, now I am trying to make a new sssdt to get all the information in the hardware of the pci slots.

Now I only have one problem with the thunderbolt which varies its state of suggestion from SL0 No-Security to SL1 user-authorization, I will try to update the bios.

My system Configuration:

CPU: Intel Core i9 9960X OC 4.9GHz
MTB: Asus X299 Deluxe
GPU: AMD Radeon RX5700
RAM:32GB RAM DDR4 Corsair 3000MHz
Disk: 512GB NVMe Sandisk
Cooling: ArticCooling AIO 280mm WaterCooling
Case: Corsair 175RGB
PSU: PSF Group 1200W Platinum
Wifi: Apple WIFI and NGFF adapter

Thanks to: KGP X299 Guide

Screenshot 2019-10-27 at 11.52.33.png

Screenshot 2019-10-27 at 11.52.51.png

Screenshot 2019-10-27 at 12.00.38.png
 
Joined
Mar 28, 2011
Messages
251
Motherboard
Asus Tuf X299 Mark 1
CPU
i9-7900X
Graphics
RX 5700 XT
Mobile Phone
  1. iOS
Very interesting, I have a system and I used the kgp guide, I was interested in changing my 980 ti for a 5700 xt and thus updating myself to Catalina.

I am interested, I look forward to the results and it is 100% stable.

10.15.1 was released, I hope you have full support.
I use smbios imacpro 1,1

I think WhatevergreenKext v1.3.4 work with navi rdna cards
 
Joined
Jun 5, 2015
Messages
13
Motherboard
Asus Prime X299 Deluxe
CPU
i9 9960X OC 4.9Ghz
Graphics
Dual AMD RX5700XT
Mac
  1. Mac Pro
Mobile Phone
  1. Android
Very interesting, I have a system and I used the kgp guide, I was interested in changing my 980 ti for a 5700 xt and thus updating myself to Catalina.

I am interested, I look forward to the results and it is 100% stable.

10.15.1 was released, I hope you have full support.
I use smbios imacpro 1,1

I think WhatevergreenKext v1.3.4 work with navi rdna cards

Hi, i recently update the lastest OSX Catalina 10.15.1, i try with WEGKext and i have the same result, backscreen or not signal over DisplayPort Or HDMI.

Without WEGKext, everyThink works great!
 
Joined
Mar 28, 2011
Messages
251
Motherboard
Asus Tuf X299 Mark 1
CPU
i9-7900X
Graphics
RX 5700 XT
Mobile Phone
  1. iOS
I buy sapphire nitro + oc 5700xt , update high sierra to catalina 10.15.1 with my old 980ti with bootflag nvsiable.
change graphics card using weg with bootflag agdpmod=pikera , smbios imacpro 1,1.
I use displayport with Lg 34” Uhd
work all flawless no errors.
 
Last edited:
Joined
Apr 19, 2011
Messages
44
Motherboard
Gigabyte Z590 Vision D
CPU
intel i9 10900k
Graphics
intel 630 Desktop
Hello. Do you work in the display port connection?
I can boot catalina 10.5.1 with 5700 XT, but only by HDMI, in display port i only get black screen.
Any suggestion please?
 
Joined
Jun 5, 2015
Messages
13
Motherboard
Asus Prime X299 Deluxe
CPU
i9 9960X OC 4.9Ghz
Graphics
Dual AMD RX5700XT
Mac
  1. Mac Pro
Mobile Phone
  1. Android
Hello. Do you work in the display port connection?
I can boot catalina 10.5.1 with 5700 XT, but only by HDMI, in display port i only get black screen.
Any suggestion please?
hi i use hdmi, over displayport i only get blackscreen, my suggestion its remove Whatevergreen kext and update lilu, recently i update my older rx5700 non xt for one 5700 xt and works well
 
Joined
Jun 5, 2015
Messages
13
Motherboard
Asus Prime X299 Deluxe
CPU
i9 9960X OC 4.9Ghz
Graphics
Dual AMD RX5700XT
Mac
  1. Mac Pro
Mobile Phone
  1. Android
I buy sapphire nitro + oc 5700xt , update high sierra to catalina 10.15.1 with my old 980ti with bootflag nvsiable.
change graphics card using weg with bootflag agdpmod=pikera , smbios imacpro 1,1.

work all flawless no errors.
sweet
 
Joined
Dec 18, 2016
Messages
21
Motherboard
GIGABYTE Z170-D3H-F3-Clover
CPU
i7-6700
Graphics
GTX 970
Heyo luisdanielv!
Sorry for little bit of a off topic. I want to buy myself a GIGABYTE Radeon RX 5700 GAMING OC 8G card, whitch i guess is the same as you own. Is everything ok with it? Is it working properly? :)
The reason why I ask is that I want todo a hackintosh build after years of unsupported nvidia, so I won't buy something that won't be compatible with a new Catalina (whitch btw. works awesome on my MB Pro 2017!)
Have a great day!
 
Joined
Nov 30, 2019
Messages
1
Hi guys,

Same trouble here, graphics card is running smooth and sending out signal over hdmi.
But only darkness over the DisplayPort connectors. Any ideas?
Running OpenCore + WhateverGreen 1.3.5
 
Joined
Apr 27, 2012
Messages
6
Motherboard
Gigabyte Z390 Aorus Elite
CPU
i9-9900K
Graphics
Sapphire 5700 Pulse
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Hi guys,

Same trouble here, graphics card is running smooth and sending out signal over hdmi.
But only darkness over the DisplayPort connectors. Any ideas?
Running OpenCore + WhateverGreen 1.3.5

Not sure what I've done right. I swapped my new Sapphire 5700 pulse with the original rx580, connected to DP and booted with agdpmod=pikera, black screen. I then removed WEG1.3.4, system can boot up thru DP.
 
Top