Contribute
Register

AMD Radeon Performance Enhanced SSDT

Joined
May 11, 2020
Messages
21
Motherboard
Asus TUF z390 PRO Gaming
CPU
i5 9600k
Graphics
Gigabyte Radeon RX 5500 XT OC
Mac
  1. Mac Pro
Hello there,

What booloader are you using?

Yes finish the install with the onboard graphics.

For the AMD GPU you need to add boot args : agdpmod=pikera


Hey mattstonnie, I was trying to finish the install with the onboard graphics but when I "Booted from MacOS" I get this verbose error:
IMG_0368.jpg
I tried removing all the kext files from the kexts>other folder in my EFI and the same thing happened. Any ideas on what this issue is or how I can fix it?
 
Joined
Nov 19, 2011
Messages
159
Motherboard
Gigabyte GA-Z170X Gaming G1-F22j
CPU
i7-6700K
Graphics
HD 530 + Vega 64
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Hey mattstonnie, I was trying to finish the install with the onboard graphics but when I "Booted from MacOS" I get this verbose error:
View attachment 473126
I tried removing all the kext files from the kexts>other folder in my EFI and the same thing happened. Any ideas on what this issue is or how I can fix it?
Did you add Emulate NVRAM support to your bootable USB installer? Or did you decided to use SSDT for NVRAM?
For more info about this you can follow MacMan's build here.
 
Joined
May 11, 2020
Messages
21
Motherboard
Asus TUF z390 PRO Gaming
CPU
i5 9600k
Graphics
Gigabyte Radeon RX 5500 XT OC
Mac
  1. Mac Pro
Did you add Emulate NVRAM support to your bootable USB installer? Or did you decided to use SSDT for NVRAM?
For more info about this you can follow MacMan's build here.

I used Emulated NVRAM and I followed the steps in MrMan's post as we both have the same MoBo. Are there any specific kexts i need before booting (I have none at the moment and was going to add them later with MultBeast)? Or do I have to do something with the config.plist file in the CLOVER folder? Or are there any boot arguments I am missing?
 
Joined
Nov 19, 2011
Messages
159
Motherboard
Gigabyte GA-Z170X Gaming G1-F22j
CPU
i7-6700K
Graphics
HD 530 + Vega 64
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
I used Emulated NVRAM and I followed the steps in MrMan's post as we both have the same MoBo. Are there any specific kexts i need before booting (I have none at the moment and was going to add them later with MultBeast)? Or do I have to do something with the config.plist file in the CLOVER folder? Or are there any boot arguments I am missing?
I think you should read again MacMan's Build post carefully. Sometimes when trying to install macOS is necessary to use the USB 2.0 port (the black ones and avoid the blue ones) because the installer sometimes fails when connecting the USB drive to a USB 3.0 port. If you have your case USB ports wired to the motherboards internal USB 2.0 header, then use those ports for instalation. It is recomended to use only the necessary minimal kexts during installation.The most important one is FakeSMC/VirtualSMC (use only one of these) follow by Lilu, WhatEverGreen and IntelMausiEthernet. The rest can be added after installation but I would add AppleALC also. After reading MacMan's post keep reading the rest of the thread if possible, because that's how you find out about others problems with your same board and their solutions. Cheers, at the begining hackintoshing could be a challege, but once your are done with all the necesarry reading then you will feel very good. Take advantage of the files that MacMan shared at the end of his post, use only the ones that apply to you (remember you choose to build your installer with Emulated NVRAM).
 
Joined
May 11, 2020
Messages
21
Motherboard
Asus TUF z390 PRO Gaming
CPU
i5 9600k
Graphics
Gigabyte Radeon RX 5500 XT OC
Mac
  1. Mac Pro
I think you should read again MacMan's Build post carefully. Sometimes when trying to install macOS is necessary to use the USB 2.0 port (the black ones and avoid the blue ones) because the installer sometimes fails when connecting the USB drive to a USB 3.0 port. If you have your case USB ports wired to the motherboards internal USB 2.0 header, then use those ports for instalation. It is recomended to use only the necessary minimal kexts during installation.The most important one is FakeSMC/VirtualSMC (use only one of these) follow by Lilu, WhatEverGreen and IntelMausiEthernet. The rest can be added after installation but I would add AppleALC also. After reading MacMan's post keep reading the rest of the thread if possible, because that's how you find out about others problems with your same board and their solutions. Cheers, at the begining hackintoshing could be a challege, but once your are done with all the necesarry reading then you will feel very good. Take advantage of the files that MacMan shared at the end of his post, use only the ones that apply to you (remember you choose to build your installer with Emulated NVRAM).


Yeah I have been studying MrMac's thread a lot over these past few days since it addresses my MoBo and it is very detailed. I understand that he said to use a USB2 adapter but if I don't have to i will try to avoid it. So far Hackintosh has certainly been a challenge for me but it has been a fun journey. Thanks for the help!
 
Joined
Nov 19, 2011
Messages
159
Motherboard
Gigabyte GA-Z170X Gaming G1-F22j
CPU
i7-6700K
Graphics
HD 530 + Vega 64
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Yeah I have been studying MrMac's thread a lot over these past few days since it addresses my MoBo and it is very detailed. I understand that he said to use a USB2 adapter but if I don't have to i will try to avoid it. So far Hackintosh has certainly been a challenge for me but it has been a fun journey. Thanks for the help!
I read somewhere that the latest macOS versions have better support with USB 3.0 drives for installation. Also Intel USB ports are better supported over 3rd party USB ports. Your board seems to use only Intel USB ports, so it's possible you won't have problems with that.
 
Joined
May 11, 2020
Messages
21
Motherboard
Asus TUF z390 PRO Gaming
CPU
i5 9600k
Graphics
Gigabyte Radeon RX 5500 XT OC
Mac
  1. Mac Pro
I read somewhere that the latest macOS versions have better support with USB 3.0 drives for installation. Also Intel USB ports are better supported over 3rd party USB ports. Your board seems to use only Intel USB ports, so it's possible you won't have problems with that.

I just redid my USB Bootloader and I am now on my MacOS Catalina Desktop!!! Thanks for your help along the way!
 
Joined
Oct 13, 2013
Messages
29
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
Gigabyte Vega 64 8go
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. iOS
Hi @mattystonnie,
So I upgrade all my system (Z170 Designare to Z390 Designare and i7 to i9 with 64Go Ram). Your solution don't work very well on my Z170. But on the new configuration it is F*ck*ng FREAT !!!
Geekbench score :
Without Metal : 53747. OpenCL : 47608
With Metal : 71082. OpenCL : 61649

At first I put SSDT, Vega64 kext and activate agpmode=pikera.(I have 3 screen, 2 on HDMI on the Vega and 1 on DP). After reboot, just the screen on DP work (Fan are noisy). So I plug one of HDMI (have just 1 adapter) to DP, it work immediatly. After reboot, I have black screen. So I turn of and unplug the second DP screen and boot. First screen work. I remove agpmode=pikera, plug the second DP and reboot. It work great ( I will buy another HDMI to DP adapter to test my last screen)(Fan are noisy).

So I use VGTab to solve noisy Fan
here it is my setting :
Idle Speed : 0
Target Speed : 2600
Min Speed : 400(I don't change it)
Max Speed : 3000
Fan Sensibilyty : 4836(I don't change it)
Target temperature : 55°
TDC(%) : 50(I don't change it)

I generate kext of this setting and reboot. Everything seems to be good. My DP port work good. And the Vega64 Fan are less noisy(I have a Gigabyte Vega64).

I have 3 questions
- Is the a working software to see Vega64 temperature to see if the is no problem? (specially in FCPX or After effect working) ?
-I don't find anywhere a guide with advice value for VGTab and I want to check if my values are good (I find them on a german forum). Is anybody can advice me?
-Is the a way to get the HDMI working ?(as I told you on an old post, I need an HDMI working for a Blackmagic recorder)

Thanks for your great work

Ps : My SMBIOS is iMac Pro. The Core i9 Intel GPU is desactivate in bios as @CaseySJ guide for FCPX user advice it
Ps2 : Sorry for my bad English
 
Joined
Sep 3, 2018
Messages
65
Motherboard
Asrock X570 Taichi
CPU
Ryzen 9 5900X
Graphics
Radeon VII
Mobile Phone
  1. iOS
Hello, any posibility this ssdts for the Radeon VII :)...
 
Joined
Jan 12, 2020
Messages
12
Motherboard
MSI mpg z390 gaming
CPU
i7 9700k
Graphics
5700XT
Great little tweak. Increased performance of my 5700xt by at least 50% on mac.

BUT since it increased the power of the GPU to what it's supposed to be. It also brought coil whine with it. Which I always get on windows and have to underclock.

Other than that, if you need the extra performance then this is worth doing. I'm going to revert back because I can't stand the coil whine I unluckily got with this GPU
 
Last edited:
Top