Contribute
Register

AMD Radeon Performance Enhanced SSDT

Joined
Oct 23, 2010
Messages
970
Motherboard
GA-Z77X-UP5-TH
CPU
i7-3770K
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Hi all
Thank you for this guide.
i've tried the RX 580 SSDT, but i don't notice so much changes. Did i do something wrong?

iMacPro1,1 Mojave 10.14.6 No ssdt
48196
Metal Score

41578
OpenCL Score

ssdt
48501
Metal Score

42057
OpenCL Score

Win 10
43091
OpenCL Score

46867
Vulkan Score
View attachment 467108
That's pretty normal for an RX580.
There's no more that can be squeezed out from that card.

Did you run the benchmark straight after booting or after waking from ?

On my Z77X-UP5 + RX580 Nitro+ running Mojave (10.14.6) I get similar scores to you.
But, on Catalina (10.15.4), if I run the benchmark after booting, I get ~ 40% LESS and only get those "normal" scores AFTER waking from sleep.
 
Last edited:
Joined
Aug 28, 2012
Messages
73
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
Radeon VII
Mac
  1. Mac Pro
Hi everyone , would this work on Vega VII?
 
Joined
Feb 7, 2016
Messages
75
Motherboard
Dell Precision 7730-OpenCore
CPU
i9-8950HK
Graphics
UHD 630
Mac
  1. Mac Pro
Mobile Phone
  1. Android
  2. iOS
That's pretty normal for an RX580.
There's no more that can be squeezed out from that card.

Did you run the benchmark straight after booting or after waking from ?

On my Z77X-UP5 + RX580 Nitro+ running Mojave (10.14.6) I get similar scores to you.
But, on Catalina (10.15.4), if I run the benchmark after booting, I get ~ 40% LESS and only get those "normal" scores AFTER waking from sleep.
I ran it after wake up
 
Joined
May 11, 2011
Messages
1,158
Motherboard
Asrock B365M Phantom Gaming
CPU
i5-9600KF
Graphics
RX 580
Mobile Phone
  1. iOS
Reporting no change in GB scores after implementing your EFI and disabling iGPU in BIOS. Attaching the new ioreg as requested. Hope we can find the culprit...

Edit: Btw., lost Sidecar. I can "connect", but there is a black screen shown on the iPad...

Enable again IGPU in bios for sidecar.
 
Joined
Dec 3, 2014
Messages
93
Motherboard
Intel DX58SO
CPU
W3680
Graphics
Vega 56
Mac
  1. MacBook
  2. MacBook Pro
@mattystonnie

I am on a intel Dx58so with w3680..harware very close to a macpro5,1 and upgraded to a vega from 660 to go from ElCap to Mojave.

after some tweeks and experimentation I found that I get close to everything I want by instead of using a straight macpro5,1 SMBIOS.. I now use a split personality like the real macpro guys are doing with opencore and putting in a imacpro1,1 board-id in the SMBIOS.. not injecting it with WEG.. still using pikera and shikigva=80.. I get BOTH HARDWARE encode AND decode of BOTH 264 and HEVC... and at least DRM for prime.. have not tested others .. on 10.14.6 2020-002

I am currently using a kext called radeonvegaaircoolingfanfix.kext (not my work).. for my MSI VEGA 56 Airboot and it works fantastic .. fans trottle properly, nothing gets stuck.. it doestn STOP the fan like apples power mangement so it stays cooler...

I would like to see if adding some of your SMU injection in it might take it up another notch

right now I get GB4 opencl or 144770 and a luxball3.1 of 28083
 

Attachments

  • RadeonVega56AirCoolingFansFix.kext.zip
    4 KB · Views: 46
Joined
Sep 21, 2013
Messages
1,026
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900KS
Graphics
RX 580
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
  4. Mac mini
  5. Mac Pro
Classic Mac
  1. Classic
  2. iBook
  3. Power Mac
  4. PowerBook
  5. Quadra
  6. SE/30
Mobile Phone
  1. iOS
Yes it is safe. Why is on compute?

I'm using it for FCPX, Compressor, Avid, etc. I'm not a gamer. The machine is in a one-room project studio, so it has to be silent. FWIW, GB5 Open CL = 44407; Metal = 50988.
 
Joined
Jun 16, 2010
Messages
304
Motherboard
Gigabyte GA-Z270X-Gaming-K7
CPU
i5-7600K
Graphics
RX 5500 XT
Hi @mattystonnie.

I've been keeping up with your post since the beginning and followed the directions (Clover) for my 5500XT. I even added the flag for AddDTGP in Clover Configurator. Thanks to your guide, everything is noticeably faster than before but I thought I'd follow your suggestion to add the PCIe Display Device Path in the List of PCI Devices in my config.plist before removing the SSDT. I first right-clicked and copied the path I have shown in the attached picture from Hackintool and then went to paste it into CC at the bottom left in the Devices tab. First, I added a device and even though I pasted the path, I can't get it to stick and generate the properties in the bottom right pane (I previously was able to add my IGPU as a headless device and that stuck). I've also attached my IOReg in case I have other issues that might be interfering with the procedure. If you have a chance to look into it, I'd appreciate it. Thanks in advance for your help.

Screen Shot 2020-05-04 at 10.46.55 PM.png
 

Attachments

  • Superbogey IOReg 5-4-2020.ioreg
    9 MB · Views: 35
Joined
Dec 24, 2018
Messages
54
Motherboard
Intel NUC8i7BEH
CPU
i7-8559U
Graphics
RX 5700 XT
Mobile Phone
  1. Android
With Geekbench 5 my 5700XT went from 38k to 65k in Metal and 38k to 60k in OpenCL.
This is not affecting the Luxmark results and I think because its an old benchmark tool anyway, nor Engine Heaven but all good.

Thanks for sharing
I have a 5700XT and my max GeekBench 5 is 40K Metal after this mod, Can you share your efi folder to compare?
 
Top