Contribute
Register

AMD Radeon Navi GPU

Joined
Mar 15, 2017
Messages
123
Motherboard
Acrock Z390 Phantom Gaming-ITX/ac
CPU
i9 9900k
Graphics
RX Vega 64
Mac
  1. iMac
  2. MacBook Pro
  3. Mac Pro
Mobile Phone
  1. iOS
How can you see it is detected if you have black screen? Could you please provide more details? Thanks.
maybe the monitor is driven by igpu or he/she has more than one dgpu i guess
 
Joined
Jan 4, 2013
Messages
129
Motherboard
Gigabyte Z370 AORUS Ultra Gaming
CPU
i7-8700K
Graphics
MSI Radeon RX 5700XT Evoke + UHD 630
Mac
  1. iMac
  2. MacBook Air
Mobile Phone
  1. Android
  2. iOS
How can you see it is detected if you have black screen? Could you please provide more details? Thanks.

I boot with monitor connected to UHD630 , see the 2 graphics cards, and the status of kexts loaded.
In last betas, 5700 was only VESA support, no metal and no kext
 
Joined
Oct 23, 2012
Messages
85
Motherboard
MSI B360m Mortar Titanium
CPU
i7-8700
Graphics
RX 560
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Hmm, i've tried to do the same with my reference RX 5700 XT but it still appears as generic VGA (VESA) card without any kext loaded...
 
Joined
Oct 23, 2012
Messages
85
Motherboard
MSI B360m Mortar Titanium
CPU
i7-8700
Graphics
RX 560
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
I boot with monitor connected to UHD630 , see the 2 graphics cards, and the status of kexts loaded.
In last betas, 5700 was only VESA support, no metal and no kext

Could you please provide a screenshot?
 

Gigamaxx

Moderator
Joined
May 15, 2016
Messages
6,050
Motherboard
GIGABYTE X470 Arous Gaming 7 WiFi
CPU
Ryzen R9 3900X
Graphics
RX 480
Mac
  1. iMac
It is described in system properties as AMD Radeon 5700, details show Metal support, and a related kext is loaded. Maybe some kext related configuration changes needed, but i am optimistic to get it working soon.

Take some screenshots and post them.
 

Gigamaxx

Moderator
Joined
May 15, 2016
Messages
6,050
Motherboard
GIGABYTE X470 Arous Gaming 7 WiFi
CPU
Ryzen R9 3900X
Graphics
RX 480
Mac
  1. iMac
I’ll test this one MSI Evoke.

Powercolor Red Dragon doesn’t work in beta 8 with and without plist edits. Same with the MSI.

466B887B-0B8D-4461-854F-DC501F26BEDB.jpeg
Screen Shot 2019-09-17 at 9.11.59 PM.png

The latest clover 5070 has the card labeled as 5700XT but using inject gives you 5700.

Screen Shot 2019-09-17 at 9.25.35 PM.png
 
Last edited:
Joined
Jul 23, 2011
Messages
63
Motherboard
Gigabyte Z370P D3
CPU
i5-8600K
Graphics
RX 580 / RX 5700 XT
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
Mobile Phone
  1. iOS
Beta 8 recognized my Navi 5700 XT Custom Model, so final will probably do so, too.

Only problem is, i can't make it displaying anything with my iMacPro1,1 System definition and WhatEvergreen 1.3.2 kext.
I tried Display Ports and HDMI. No Luck. Black Screen.

I'll be watching this thread with interest! I (stupidly) purchased only a 4gig RX580 when I built my Hackintosh and even for 1080p gaming it's really not enough - an upgrade to the 5700XT and 8gig seems like a good option for me right now :)
 
Joined
Jul 23, 2011
Messages
63
Motherboard
Gigabyte Z370P D3
CPU
i5-8600K
Graphics
RX 580 / RX 5700 XT
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
Mobile Phone
  1. iOS
XFX Radeon RX 5700 XT arrives today (thanks Amazon), so I'll have a go at updating to Catalina later and see how I get on :)

I'll be mostly using it in Windows for gaming, but I'm pretty confident this will be supported in Catalina...
 
Joined
Jul 23, 2011
Messages
63
Motherboard
Gigabyte Z370P D3
CPU
i5-8600K
Graphics
RX 580 / RX 5700 XT
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
Mobile Phone
  1. iOS
Well this isn't a bad start, certainly better than expected... the card is at least giving me video output in Catalina, even though it's not loading a kext for it and isn't accelerated.

Have literally only just installed it and haven't played around yet, but I at least have usable video without having to swap the cards around :)
1569265881875.png
 

Attachments

  • 1569265789371.png
    1569265789371.png
    294.6 KB · Views: 35
Joined
Apr 9, 2019
Messages
48
Motherboard
X79T 1.02
CPU
E5-1650v2
Graphics
RX 5700XT
Well this isn't a bad start, certainly better than expected... the card is at least giving me video output in Catalina, even though it's not loading a kext for it and isn't accelerated.

Have literally only just installed it and haven't played around yet, but I at least have usable video without having to swap the cards around :)
View attachment 427148
What version of beta?
 
Top