Contribute
Register

AMD Radeon Navi GPU

Joined
Jan 26, 2020
Messages
6
Motherboard
MSI H110M PRO-D
CPU
i5-6400
Graphics
Sapphire RX5600XT Pulse
I can’t select IGPU. There are no other options for integrated graphics in BIOS. I think IGPU is disabled. But I do not know how to check.

Are you sure the problem is in IGPU? This used to work with Sierra and Nvidia.
 
Joined
Jan 26, 2020
Messages
6
Motherboard
MSI H110M PRO-D
CPU
i5-6400
Graphics
Sapphire RX5600XT Pulse
Sapphire RX 5600 XT Pulse is working!

My problem was in config.plist -> ACPI -> DSDT -> Fixes -> AddHDMI.
 
Joined
Jul 16, 2017
Messages
40
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900KS
Graphics
RX 5700 XT
Mac
iMac
Mobile Phone
iOS
I use VirtualSMC instead of FakeSMC and it's working well.
Could you share your EFI folder? which software that you are using to check core clock temps and other infos? istat menus? Mine here is out of information

1580160534248.png


For temps I'm using Slice Fakesmc along with modified RadeonMonitor.kexts for Navi (I can provide if you need them), however all I can see is temps in real time with iStatMenus app with clock/processor bars, no numbers tho.

View attachment 436071View attachment 436072

About the errors I have no idea, my Sapphire reference 5700XT runs flawlessly on anything I'm testing it with, not even a fan problem as it was with my Vega 64.
You might need a fresh install or maybe new version release to have even more stability I think.
Could you share your EFI folder? thx in advanced
 
Joined
Apr 1, 2014
Messages
169
Motherboard
Gigabyte GA-H170-D3H
CPU
i7-6700
Graphics
RX 5700 XT
I am planing to buy the MSI rx 5700 xt gaming because I am looking for silence.
Please if anyone has something to say, anything in particular I should be aware of, so please do.
is it safer and wiser to go with the nitro instead ? long term support and so on..
Am I going to use the imac 17,1 as always or need to change it?
this is still related to the cpu and not gpu right ?
 
Last edited:
Joined
Jul 16, 2017
Messages
40
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900KS
Graphics
RX 5700 XT
Mac
iMac
Mobile Phone
iOS
I am planing to buy the MSI rx 5700 xt gaming because I am looking for silence.
Please if anyone has something to say, anything in particular I should be aware of, so please do.
is it safer and wiser to go with the nitro instead ? long term support and so on..
Am I going to use the imac 17,1 as always or need to change it?
this is still related to the cpu and not gpu right ?
EDIT

If you are looking for SILENCE, you must build a water custom loop.
Even at absolutelly full load I almost forgot that I have something runing around me (absolutelly silent)
This AIB cards (not reference from AMD versions) has less vram amd vrm quality components and they are more expensive than reference version (around 100US or 800 brazilian reais for me, that is almost triple the price of a GPU water block, I looked for asus strix 3fan version and sapphire nitro+ 3fan version).

If I were you I would go with reference card and with the money saved I would start building the loop.
My temps at full load (heaven test 10min longer) with water loop on GPU and CPU (i9 9900ks):
CPU 50~60c (at load)
GPU 44~49c (at load)
GPU HOTSPOT 57~67c (at load)
GPU VRM 65~70 (at load)
GPU CLOCK 1950 without Thermal throttling

My card is Power Color Radeon rx 5700 xt Reference Edition (single blower cooler version)


Temps at full load (running heaven on windows for 10minutes) with AIR cooler (high noise, fan curve not even at max rpm, can reach 4800rpm, absolutelly noisely)

below I will attach the GPU-Z Sensor Log of heaven at water cooler running benchmark test
(you can see at log that the gpu clock is running smooth over 1900mhz)

1580237080601.png


Temps runing Heaven for 10min longer at water cooler

1580243919039.png


Water blocked with Bykski reference block (thermal pads side)

1580236862761.png


Block installed (this block can handle the original backplace whitout any issue)

1580236782860.png


Old pic before change GPU water block

1580236829599.png
 

Attachments

Last edited:
Joined
Dec 31, 2013
Messages
633
Motherboard
Huawei Matebook D
CPU
i5-8250U
Graphics
UHD 620
Mobile Phone
iOS
I'm running this Radeon RX 5700XT 8GB from Powercolor:

The system is a X299.
It works great BUT one thing.
Out of 4 ports (3 DP and 1 HDMI) only 2 work (1DP 1 HDMI), the other 2 (2 DP) show a black screen.
Is there a patching available to fix this issue?

Thanks a lot.
 

dez

Joined
Feb 2, 2014
Messages
123
Motherboard
Asus X299 Deluxe II
CPU
i9-9940X
Graphics
RX 5700XT
Mac
MacBook Pro, Mac Pro
Mobile Phone
Android, iOS
I'm running this Radeon RX 5700XT 8GB from Powercolor:

The system is a X299.
It works great BUT one thing.
Out of 4 ports (3 DP and 1 HDMI) only 2 work (1DP 1 HDMI), the other 2 (2 DP) show a black screen.
Is there a patching available to fix this issue?

Thanks a lot.
Same issue with my reference 5700XT. Using WEG kext along with the agpmod=pikera and proper GFX0 naming using SSDT resolved it for me.
 
Joined
Dec 31, 2013
Messages
633
Motherboard
Huawei Matebook D
CPU
i5-8250U
Graphics
UHD 620
Mobile Phone
iOS
Same issue with my reference 5700XT. Using WEG kext along with the agpmod=pikera and proper GFX0 naming using SSDT resolved it for me.
Thanks for your reply!
If I use the latest WEG I get a black screen altogether. I can retry.
Is agpmod=pikera a boot flag?
I've done a SSDT where the card shows GFX0, can you share yours?

Update Solved!!
- WEG + agpmod=pikera + SSDT and it works great...
 
Last edited:
  • Like
Reactions: dez
Joined
Jan 26, 2020
Messages
6
Motherboard
MSI H110M PRO-D
CPU
i5-6400
Graphics
Sapphire RX5600XT Pulse
Hello !

I will buy this card, can you confirm it's working flawlessly ? Which patch did you apply ? Only AddHDMI in ACPI -> Fixes ? or some more ?

Thanks !

Hello!

I confirm, RX5600XT is still good working (include HEVC and H264 coding) by using standart settings for Navi cards (Disabled IGP, Lilu, WEG, agdpmod=pikera, SMBIOS ProductName=iMacPro1,1).

I had to patch AddHDMI because I try used my old config file.
 
Top