Contribute
Register

AMD Radeon Navi GPU

Joined
Mar 28, 2011
Messages
265
Motherboard
Asus Tuf X299 Mark 1
CPU
i9-7900X
Graphics
RX 5700 XT
Mobile Phone
  1. iOS
If update to 10.15.2 beta 4 i keep weg and lilu , Does it work or do modifications have to be made?
 
Last edited:
Joined
Apr 9, 2019
Messages
48
Motherboard
X79T 1.02
CPU
E5-1650v2
Graphics
RX 5700XT
At 10.15.2, there remained artifacts with dynamic wallpapers and a screen frequency in 2K resolution. Any ideas?
UPD: I did as written here: https://gist.github.com/ejdyksen/8302862
Dynamic wallpapers are now without artifacts. But I can not change the frequency of the screen.
Booted under the windows to watch the dump on the monitor EDID and saw that there wasn’t 75Hz.
How do I force 75Hz into the Catalina configuration?
UPD2: This worked under only one user. Under others, I observe artifacts on dynamic wallpapers. In addition, other users also lost the ability to change the frequency
 
Last edited:

Gigamaxx

Moderator
Joined
May 15, 2016
Messages
6,570
Motherboard
GIGABYTE X470 Arous Gaming 7 WiFi
CPU
Ryzen R9 3900X
Graphics
RX 480
Mac
  1. iMac
Navi 14 works!

MSI RX 5500XT Gaming 8gb.Apple added Navi 14 support to the 10.15.2 release.

Screen Shot 2019-12-12 at 9.42.46 AM.pngScreen Shot 2019-12-12 at 9.37.57 AM.pngScreen Shot 2019-12-12 at 9.32.25 AM.pngScreen Shot 2019-12-12 at 9.29.24 AM.pngScreen Shot 2019-12-12 at 9.47.53 AM.png
 
Last edited:
Joined
Jan 9, 2012
Messages
26
Motherboard
Z87X-UD5
CPU
i7-4770K
Graphics
GTX 950, GTX 760
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
Another Round :

Hardware and Software
All the tests use DaVinci Resolve Studio 16.1.1
The Project is a Simple Timeline with 3 BRAW (4.6K) heavily graded
The results are in “fps” (frame per second)

  • Imac 2019 – Core i9 8 cores 3.6 Ghz – RAM 64 GB – Pro Vega 48 8GB
  • Hack X299 – Core i9 12 cores 2.9 Ghz – RAM 32 GB – RX 5700XT 8GB
  • Hack X299 – Core i9 12 cores 2.9 Ghz – RAM 32 GB – RX 5700XT 8GB & GT 710 2GB
  • Hack X299 – Core i9 12 cores 2.9 Ghz – RAM 32 GB – GTX 1080 Ti 11GB
  • Hack X299 – Core i9 12 cores 2.9 Ghz – RAM 32 GB – GTX 1080 Ti 11GB & GT 710 2GB
With the Dual GPUs, only one is used for compute with Resolve and the other is only for GUI

The Test Results
View attachment 436749What I learned
  • The Old and Expensive (more than 800€ a year and half ago) GTX 1080 Ti is the best with FHD timeline
  • The Very expensive (RX 580X + 540€) Vega Pro 48 is almost as powerful as the RX 5700 XT
  • The RX 5700 XT (450€) is the best for UHD timeline
  • For AMD GPU, the GUI has a small impact on performances
  • There is something definitely wrong the NVIDIA web driver ➧ You need a dedicated GPU for the GUI
Hope this helps

Are you able to keep your Nvidia card installed while using AMD for graphics?

This would be extremely interesting to me. I would like to have an Nvidia card exclusively for its CUDA and tensor cores, for computing power. I do not need the card to display anything nor accelerate video (which I know it can't, after High Sierra). I was under the impression that people who had a dual OS system had to physically disable Nvidia cards when booting into Mac OS to avoid errors.
 
Joined
Nov 29, 2019
Messages
4
Motherboard
Z170x-UD5 TH
CPU
i7-6700K 4.00Ghz
Graphics
RX 5700 XT
Hi,

I installed my new 5700 xt. Updated to Catalina seemed to go well beside from some black screens,

Just before the update I did the mistake of removing the Whatevergreen kext from the kexts->Other folder on EFI partition. Now I get black screen at the end of the Apple logo loading screen.

Is it possible to add the Whatevergreen.kext to EFI partition whiteout being able to get into/see OSX?
I did update the lilu before update.

I have tried the boot arg agdpmod=pikera and also switching between displayports and HDM
 

Attachments

  • BlackScreen.png
    BlackScreen.png
    1.8 MB · Views: 134
Last edited:
Joined
Jul 20, 2014
Messages
962
Motherboard
AsRock X299 Creator-1.50
CPU
i9-10900X
Graphics
RX 6800 XT
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Are you able to keep your Nvidia card installed while using AMD for graphics?

This would be extremely interesting to me. I would like to have an Nvidia card exclusively for its CUDA and tensor cores, for computing power. I do not need the card to display anything nor accelerate video (which I know it can't, after High Sierra). I was under the impression that people who had a dual OS system had to physically disable Nvidia cards when booting into Mac OS to avoid errors.
During all tests, may be once, I have had the situation with 1080 ti (no display connected). It's not a problem to start the MacOS under Catalina.
You use the RTX with Windows I presume ?
 
Last edited:

pastrychef

Moderator
Joined
May 29, 2013
Messages
18,559
Motherboard
Asus Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
RX 6600 XT
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
Hi,

I installed my new 5700 xt. Updated to Catalina seemed to go well beside from some black screens,

Just before the update I did the mistake of removing the Whatevergreen kext from the kexts->Other folder on EFI partition. Now I get black screen at the end of the Apple logo loading screen.

Is it possible to add the Whatevergreen.kext to EFI partition whiteout being able to get into/see OSX?
I did update the lilu before update.

I have tried the boot arg agdpmod=pikera and also switching between displayports and HDM

Boot from USB flash drive.
 
Joined
Nov 29, 2019
Messages
4
Motherboard
Z170x-UD5 TH
CPU
i7-6700K 4.00Ghz
Graphics
RX 5700 XT
Boot from USB flash drive.
Thanks. Got me one step further.
So now I'm booted from Catalina Install USB. But my screen gets odd resolution and glitched out where I can't really see what I'm doing or actually get to launch EFI mounter. Tried HDMI and Display port and 3 different monitors with no luck. Any suggestion where to go from here?
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
18,559
Motherboard
Asus Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
RX 6600 XT
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
Thanks. Got me one step further.
So now im booted from Catalina Install USB but my screen gets odd resolution and glitched out where I can't really see what im doing or actually get to launch EFI mounter. Tried HDMI and Display port and 3 different monitors with no luck. Any suggestion where to go from here?

You need a working EFI folder on your USB flash drive. Then, once you are booted in to macOS, you can replace the non-working EFI folder on your startup drive with the good one.

I'm still not quite sure on what the "magic recipe" is for RX 5700 (XT)s. Different users seem to require different settings.
 
Top