Contribute
Register

AMD Radeon Navi GPU

Gigamaxx

Moderator
Joined
May 15, 2016
Messages
6,539
Motherboard
GIGABYTE X470 Arous Gaming 7 WiFi
CPU
Ryzen R9 3900X
Graphics
RX 480
Mac
  1. iMac
(On 18,1 running i5 8400 and 5700XT reference board) Completed the glitchy install process by using tab and space bar but unable to get through the final setup step after restart. I keep reaching this phase (attached), the mouse moves but nothing after. Any ideas?

Edit: It’s a Samsung 4K TV but had Mojave running on an RX580 previously. I wiped the ssd and clean installed 10.15.1. Tried a 1080p monitor too thinking the 4K res was the issue, still no luck.

Did you try disabling Whatevergreenkext?

Also need to disable the IGPU in bios.


To install disable weg after it’s installed you can use weg with boot arg agdpmod=pikera

In clover boot screen hit space bar once and select block injected Kexts. Select WEG.
 
Joined
Aug 9, 2011
Messages
27
Motherboard
Gigabyte Z370n
CPU
8700k
Graphics
5700 XT
SOLVED! Just had to have the latest Clover Bootloader installed with all the updated EFI files. I never updated it previously since I initially installed High-Sierra 10.13 and that was the issue for all the glitchy installation screens.

Thanks everyone, 5700XT on a 4k TV is looking fantastic! :)

Did you try disabling Whatevergreenkext?

Also need to disable the IGPU in bios.

To install disable weg after it’s installed you can use weg with boot arg agdpmod=pikera

In clover boot screen hit space bar once and select block injected Kexts. Select WEG.
 
Last edited:
Joined
Jul 16, 2015
Messages
20
Motherboard
MSI Z370 Gaming M5
CPU
i9-9900K
Graphics
RX 5700 XT
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
SOLVED! Just had to have the latest Clover Bootloader installed. I never updated it since I initially installed 10.13 and that was the issue for all the glitchy installation screens.

Thanks everyone, 5700XT on a 4k TV is looking fantastic! :)

clover 5098 fixed your glitched install?
This is currently a common issue I’ll have to try it
 
Joined
Aug 9, 2011
Messages
27
Motherboard
Gigabyte Z370n
CPU
8700k
Graphics
5700 XT
clover 5098 fixed your glitched install?
This is currently a common issue I’ll have to try it

Yah - I had a dual boot install, so through Windows using Explorer++ app I was able to copy and replace the boot.efi, cloverx64.efi and other driver files from the latest Clover Bootloader build over the existing EFI folder of mine. Just keeping config.plist the same. Boom success.
 
Last edited:
Joined
Mar 6, 2019
Messages
24
Motherboard
Asus ROG Strix Z390-E
CPU
9900k
Graphics
5700 XT Anniversary
Yah - I had a dual boot install, so through Windows using Explorer++ app I was able to copy and replace the boot.efi, cloverx64.efi and other driver files over the existing EFI folder of mine. Just keeping config.plist the same. Boom success.

Hmm, It appears that the Clover 5098 is not fixing my glitched install...
 
Joined
May 22, 2014
Messages
14
Motherboard
Gigabyte GA-Z97X-UD3H
CPU
i7-4790K
Graphics
RX 5700
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
Classic Mac
  1. iBook
Mobile Phone
  1. iOS
Does buy an RX 5700 or RX 5700 XT makes any difference?

Sapphire Pulse 5700 (non-XT) here, same issue with dynamic wallpaper as described by others, otherwise no issues (with WEG, bootflag, Clover 5098). Updating to non-beta 10.15.1 on 2k screen, the apple logo and progress bar appeared only in the top left quarter of the screen for a while, but otherwise again no issues.
 
Joined
Aug 9, 2011
Messages
27
Motherboard
Gigabyte Z370n
CPU
8700k
Graphics
5700 XT
How far through the installation process are you able to reach? You can use Tab and Spacebar and also guess where the next "(->)" button is using the mouse to start the installation. I was only having the stuck issue on the final restart stage where it asks you to select the country/keyboard etc. I would get that attached image screen - and it got fixed once i updated Clover.

I tested it again with 5098 and the problem still persists.
 
Last edited:
Joined
Oct 21, 2010
Messages
19
Motherboard
Gigabyte GA-Z170X-UD3
CPU
i7-7700
Graphics
RX 5700 XT + HD 530
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
Classic Mac
  1. PowerBook
Mobile Phone
  1. Android
Got my gigabyte RX 5700XT working, here was my steps:
I first backed up my EFI files.
Got the latest clover off of github, unzipped the 'CloverISO-5097.tar.lzma' archive and deleted my old EFI files and copied over the new EFI files.
I then copied over my old config.plist and only put in whatevergreen and lilu kext into kext/other for now.
This allowed my to use the integrated HD 530 to finish the install of Catalina. (I was upgrading from High Sierra.)
I disabled the integrated graphics after this-not sure if necessary?
After install had finished, i used '-v agdpmod=pikera' without using agdpmod=pikera i dont think it worked.
I'm using the display port furthest away from the card pluggin into the board, i guess you would say the top of the card?
  • I noticed thin 'line glitches' appearing when I had my monitor set to 60Hz, after switching it 100Hz in display settings, the glitches are no longer appearing :D
  • My screen does not wake up after a long sleep though :|
 
Last edited:
Joined
Jul 20, 2014
Messages
816
Motherboard
Asus ProArt B550 Creator
CPU
Ryzen 9 5900X
Graphics
RX 6800 XT
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Some Information.
I plugged both a Radeon VII and an RX 5700 XT on the motherboard: System info show both use x16 PCIe
I made several quick tests with DAVINCI and the "candle project"
Display is 3440x1440 via DP
resolve_VII_5700XT_comparaison.png

What I learn :
1 - RX 5700 XT in a little less powerful than Radeon VII ➧ RX 5700 XT has better price/performance ratio
2 - OpenCl is dead .... slow
3 - Pluging the display on computing GPU has a minor impact on performances (It's not true with RED RAW GPU debayering for example)
4 - I can't figure how Final Cut Pro 10.4.7 select the GPU despite the new preference menu
5 - RX 5700 XT (Gigabyte Gaming OC) is less noisy than the Radeon VII when fully loaded
6 - RX 5700 XT (Gigabyte Gaming OC) is a little wider than 2 PCI slot ➧ multiple GPU difficulties

After I Superscale (very GPU intensive) the media to 8K and make the project to 8K, to find a if the RADEON VII's 16G is an advantage. 2 TNR Test give the same result with each computing GPU

Hope this helps
 
Last edited:
Top