Contribute
Register

AMD Radeon Navi GPU

Joined
May 22, 2014
Messages
14
Motherboard
Gigabyte GA-Z97X-UD3H
CPU
i7-4790K
Graphics
RX 5700
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
Classic Mac
  1. iBook
Mobile Phone
  1. iOS
Updating to beta worked, added boot parameter, disabled IGPU and put in the 5700. Flawless boot, and with the SMBIOS changed from 14,2 to iMacPro HEVC works too.

Thanks again for the help! Benchmark below (this is the Sapphire Pulse RX 5700 (not the XT version).

Edit: Unlike my NVIDIA 1060, the 5700 is now also recognized by Adobe software (in this case Lightroom Classic), see screen shot below!

Screenshot of Lightroom Classic (2019-10-27 11-09-08).png

Screenshot of LuxMark (2019-10-27 9-51-32).png
Screenshot_2019-10-27 iMacPro1,1 - Geekbench Browser.png
 
Last edited:
Joined
Jan 3, 2017
Messages
12
Motherboard
Gigabyte GA-Z97X Gaming 5
CPU
Intel i7 4790k 4.0Ghz
Graphics
HD 4600
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Anyone has a Gigabyte version of 5700 XT? Will all the brands work fine? I remember there was an issue with Sapphire card before so I’m asking because I might buy a 5700 XT next week.
 
Joined
Oct 22, 2019
Messages
8
Motherboard
Gigabyte GA-Z170X-Gaming 7
CPU
i5-6600K
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
Anyone has a Gigabyte version of 5700 XT? Will all the brands work fine? I remember there was an issue with Sapphire card before so I’m asking because I might buy a 5700 XT next week.
In my opinion it shouldn't make a difference. The chip is the same on all cards. Maybe some vendor-freaky thinks won't work like RGB-LED or if they put some non-standard outputs on it.

Did anyone tried and managed to get Audio working out of the HDMI?
Every time I select it in my audio settings the whole system freeze until I pull out the HDMI cable. DP Audio works fine.
 

Gigamaxx

Moderator
Joined
May 15, 2016
Messages
6,580
Motherboard
GIGABYTE X470 Arous Gaming 7 WiFi
CPU
Ryzen R9 3900X
Graphics
RX 480
Mac
  1. iMac
Anyone has a Gigabyte version of 5700 XT? Will all the brands work fine? I remember there was an issue with Sapphire card before so I’m asking because I might buy a 5700 XT next week.

Yes a Gigabyte Gaming 5700XT.
The only brand I haven’t heard confirmation on is the Asrock. Anyone have one running?
 
Joined
Mar 21, 2011
Messages
25
Motherboard
P8P67 Pro
CPU
i7-2600K
Graphics
R9 280X
Does anyone know if you have to change the SMBIOS from iMac 14,2? I have a Sandy Bridge system (Asus P8P67 Pro). so I'm disinclined to change it unless I have to. (I think the last time I changed it to MacPro, it disabled speed states.)
 

Gigamaxx

Moderator
Joined
May 15, 2016
Messages
6,580
Motherboard
GIGABYTE X470 Arous Gaming 7 WiFi
CPU
Ryzen R9 3900X
Graphics
RX 480
Mac
  1. iMac
Does anyone know if you have to change the SMBIOS from iMac 14,2? I have a Sandy Bridge system (Asus P8P67 Pro). so I'm disinclined to change it unless I have to. (I think the last time I changed it to MacPro, it disabled speed states.)

Give it a go. The main reason is to allow H264, H265 encoding/decoding but if you’re not rendering video it may be fine.

Update: I just tested with MacPro 6.1 and iMac 14.2 all works OK.


Screen Shot 2019-10-27 at 10.38.15 AM.png
 
Last edited:
Joined
May 31, 2013
Messages
383
Motherboard
ASUS ROG Strix Z390-I Gaming
CPU
i9-9900K
Graphics
5700 XT
I plan to buy a video card Sapphire AMD RX 5700 XT Pulse the other day. Was there any problem with it work on macOS?
 
Joined
Feb 25, 2011
Messages
1
Motherboard
Gigabyte z97x Gaming 5
CPU
i7-4790K
Graphics
RX 5700 XT
Mac
  1. iMac
Mobile Phone
  1. iOS
ASUS TUF 3-RX5700XT-O8G-GAMING

Works good on Catalina beta 15.1 version 3.
IGPU off, WEG (version: 1.3.4), LILU (version 1.3.9) boot arguments "agdpmod=pikera", Display Port 144 Hz.
 
Top