Contribute
Register

AMD Radeon HD 7xxx Graphics Support in OS X 10.8.3

Status
Not open for further replies.
Joined
Aug 31, 2012
Messages
2
Motherboard
pc
CPU
1
Graphics
ASUS ATI
Mac
Classic Mac
Mobile Phone
Article: AMD Radeon HD 7xxx Graphics Support in OS X 10.8.3

Finally got it to me ....

machine:

1 - CPU: Inte Ivybridge i7-3370 3.5 (OK)

2 - MB: Asus P8Z77-V Pro Thunderbolt

3 - RAM: Corsair 16GB (4 * 4GB) DDR3-2133

4 - PCIx16_1: Asus ATI HD 7950 3GB GDDR5

5 - PCIx8_1: BlackMagic Pro

6 - PCIx8_2: Wireless TP-Link ....

I used the technique of double video card, I start the system with the card HD4000 integrated into the processor (leave attached the cable hdmi output of the HD4000), to boot necessarily have to prepend "GraphicsEnabler = No", as the system comes into operation, I remove the hdmi cable and the hdmi insert in the output of the ATI HD7950, stop.

The system seems a bit slow, maybe there is more to do for this ATI card, but I'm glad there is support.

Thank you all, I could not do anything without your help.

Greetings from Italy (Rome)
VL
:headbang: :headbang:
 
Joined
Jun 17, 2012
Messages
18
Motherboard
Gigabyte B550I Aorus Pro AX
CPU
Ryzen 9 5900X
Graphics
RX 5500 XT
Mac
  1. iMac
  2. MacBook
Mobile Phone
  1. iOS
Article: AMD Radeon HD 7xxx Graphics Support in OS X 10.8.3

Hi, this doesn't seem to work for me .. If using internal HD4000 and HD7950 with the following settings

Init Display First: IGFX
Internal Graphics: Disabled (OS X will recognize fully)

it's the same result als Booting auto/auto or Auto/Enabled - nothing works - OSX boot stops immediately.

All is working fine, if I eject the PCI-E HD7950. I love the OSX Mountain Lion, but I can't get it running with both GFX solutions.

Any other Idea ? I'm using a GA-Z77N-Wifi, it has the same bios as showed in the first thread.
 
Joined
Nov 30, 2011
Messages
42
Motherboard
Gigabyte Z77P-D3
CPU
i7-2600K
Graphics
HD 7850
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Joined
Jun 17, 2012
Messages
18
Motherboard
Gigabyte B550I Aorus Pro AX
CPU
Ryzen 9 5900X
Graphics
RX 5500 XT
Mac
  1. iMac
  2. MacBook
Mobile Phone
  1. iOS
Article: AMD Radeon HD 7xxx Graphics Support in OS X 10.8.3

can anyone upload the drivers of this card (os x) to test it with other cards
excellent idea, hope for someone who owns this card
 
Joined
Nov 22, 2012
Messages
12
Motherboard
z68ma-d2h-b3 (rev1)
CPU
core i3770
Graphics
gigabyte gtx 650 ti OC 2g
Mac
  1. iMac
Classic Mac
  1. iMac
Mobile Phone
  1. iOS
hey guys and girls i unfortunately own a gigabyte 7850 2g and tried every thing i even updated to the latest bios that says that it supports uefi bios (f31) the only way i get graphic acceleration is if i boot with clover when you look at the desktop you would think i got graphic acceleration but when you try to play video files with vlc you only get audio and a message saying you dont have graphic acceleration i tried putting device id into ati7000.kext 0x68191002 i tried altering the dsdt nothing works did any one have any luck with this card yet any help plzzz thank
 
Joined
Sep 16, 2012
Messages
1
Motherboard
Gigabyte
CPU
Intel 3570k
Graphics
GTX 260
Mac
Classic Mac
Mobile Phone
Article: AMD Radeon HD 7xxx Graphics Support in OS X 10.8.3

The 7xxx support happened at a great time - I just put together my system the day before this posted, and had a 7770 I was going to just be using in Windows. I haven't even had a chance to put together a post in the "completed builds" section yet, but I wanted to report on my success. I've got a 3570K, GA-Z77-DS3H, and a Galaxy 7770 "Ghz Edition". Running 10.8.3 with chameleon 1.11.1394 (I think - the version that comes in the latest MultiBeast). It took a bit of fiddling and a few tries, but the process described in the article worked for me: set IGFX to primary, set integrated to disabled, booted with the GraphicsEnabler=No flag, and doing the sleep trick. Hardware acceleration is definitely working, was getting >120fps at 1080p in CS:GO with settings maxed out. I haven't ran a hackintosh since 2009, so if I can get it running, should mean good things for everyone!
This worked perfectly for me, but i didn't have to do a sleep trick. Thank you! I am using intel HD4000 and an MSI 7870 :D
 
Joined
Jan 6, 2013
Messages
59
Motherboard
Gigabyte Z77p-d3
CPU
Intel i5 3570K 3.8Ghz
Graphics
Sapphire Radeon HD 6870
Mac
  1. iMac
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Power Mac
Mobile Phone
  1. Android
  2. iOS
  3. Other
how about HD 6870 for 10.8.3? does it support natively? at the moment for me, it shows Radeon HD 6xxx with GraphicsEnabler=No
 
Joined
Feb 18, 2013
Messages
8
Motherboard
Win7/OS X
CPU
3570k @4.4GHz
Graphics
2x Sapphire HD7970 3GB OC
Mac
  1. MacBook Pro
Classic Mac
Mobile Phone
  1. Android
Article: AMD Radeon HD 7xxx Graphics Support in OS X 10.8.3

--------------------------------------------------

Do you get a 'boot 0' error?
Yes, I get the following error:

Boot0: GPT
Boot0: Test
Boot0: Test
Boot0: Done Followed by 4 lines of garbled text and symbols.
 
Joined
Dec 10, 2012
Messages
129
Motherboard
GA-Z77X-UD5H F14 Bios
CPU
i73770K
Graphics
MSI Radeon 7950 3GB
Mac
  1. Mac Pro
Classic Mac
Mobile Phone
Article: AMD Radeon HD 7xxx Graphics Support in OS X 10.8.3

Yes, I get the following error:

Boot0: GPT
Boot0: Test
Boot0: Test
Boot0: Done Followed by 4 lines of garbled text and symbols.

------------------------------------------------------


Using MultiBeast, restore the boot sector to the HD where you installed OS x.

Chimera+Multibeast+install.png
 
Status
Not open for further replies.
Top