Contribute
Register

AMD Fury X public beta 3

Joined
Jan 28, 2013
Messages
226
Motherboard
Asrock Z370 Taichi
CPU
8700K
Graphics
AMD Fury X/Intel UHD 630
Mac
iMac, MacBook Pro
Mobile Phone
iOS
I have been successfully running 10.12.2 public beta with my AMD Fury X. I add 0x73001002 to AMDRadeonX4100.kext and AMD9000Controller.kext.

The latest public beta 3 changed the AMDRadeonX4100.kext and broke my system. My system boots and I get all the way to a full progress bar. The system dims like it does before loading and then goes back to display the progress bar. I reinstalled the 4100.kext from beta 2 and the Fury X works again.

Anyone else have issues with their Fury X?
 
Joined
Jan 28, 2013
Messages
226
Motherboard
Asrock Z370 Taichi
CPU
8700K
Graphics
AMD Fury X/Intel UHD 630
Mac
iMac, MacBook Pro
Mobile Phone
iOS
It appears that my only solution right now is to boot with onboard graphics connected. If I switch to the Fury X after booting, it works. If I boot with the Fury X connected, the screen still stops with the progress bar at 100%
 
Joined
Jan 28, 2013
Messages
226
Motherboard
Asrock Z370 Taichi
CPU
8700K
Graphics
AMD Fury X/Intel UHD 630
Mac
iMac, MacBook Pro
Mobile Phone
iOS
Fixed: I removed inject intel from my config.plist
 
Joined
Oct 22, 2016
Messages
16
Motherboard
Gigabyte x99 Designare-EX
CPU
Intel Core i7-5960X Haswell-E
Graphics
Radeon 7970, R9 Fury X
Had the same questions!
 
Joined
Jan 28, 2013
Messages
226
Motherboard
Asrock Z370 Taichi
CPU
8700K
Graphics
AMD Fury X/Intel UHD 630
Mac
iMac, MacBook Pro
Mobile Phone
iOS
Here are the modifications to AMD9000Controller.kext and AMDRadeonX4100.kext.

I enable the IGPU as primary.

I set Clover to inject ATI, but not to inject Intel.

I have clover set to automatically boot my OS X drive. Black screen until the OS X driver loads, then I get the OS X logon screen.

Takes longer than usual to boot since updating to beta 3
AMD9000Controller.jpg
AMDRadeonX4100.jpg
AMD9000Controller.jpg
AMDRadeonX4100.jpg
AMD9000Controller.jpg AMDRadeonX4100.jpg AMD9000Controller.jpg AMDRadeonX4100.jpg

Good LuckView attachment 222487View attachment 222488
 
Joined
Aug 8, 2016
Messages
16
Here are the modifications to AMD9000Controller.kext and AMDRadeonX4100.kext.

I enable the IGPU as primary.

I set Clover to inject ATI, but not to inject Intel.

I have clover set to automatically boot my OS X drive. Black screen until the OS X driver loads, then I get the OS X logon screen.

Takes longer than usual to boot since updating to beta 3
View attachment 222489 View attachment 222490 View attachment 222489 View attachment 222490 View attachment 222489 View attachment 222490 View attachment 222489 View attachment 222490

Good LuckView attachment 222487View attachment 222488

I feel silly, but I am trying to find half of these controllers and other things needed to make the fury card work but i cannot find anything.

MY setup right now:
6700k Intel
Gigabyte z170 Gaming 5 motherboard
AMD Pro Duo
64gb Ram
boot ssd

So far the card actually works right now as I'm typing but it has artifacts everywhere and will not play videos smoothly let alone play video games at all. I would like some help to see if I could get the card to run smoothly and if you could explain in more depth so I can see where I am going wrong.

All I did was take out my AMD hd 7870 card and put in the Pro Duo and it got me this far. Please help.
 
Joined
Jan 28, 2013
Messages
226
Motherboard
Asrock Z370 Taichi
CPU
8700K
Graphics
AMD Fury X/Intel UHD 630
Mac
iMac, MacBook Pro
Mobile Phone
iOS
Update: I did a clean install of Sierra and updated to Public Beta 3. Fury X is working properly with both inject ATI and inject Intel selected.
 
Joined
Jan 28, 2013
Messages
226
Motherboard
Asrock Z370 Taichi
CPU
8700K
Graphics
AMD Fury X/Intel UHD 630
Mac
iMac, MacBook Pro
Mobile Phone
iOS
Download Xcode from the App Store and download Kext Utility from this website.

The Kexts are located in System/Library/Extensions. Right click on the kext and select Show Package Contents. Open the contents folder and drag the info.plist file to the desktop. I use Xcode to edit the file, there are other editors available that work also. Open info.plist with Xcode and add 0x73001002 as shown above. Save and drag the info.plist file back into the contents folder. You will be asked to authenticate, do so and select replace. Do this for the AMDRadeonX4100.kext and the AMD9000Controller.kext

Run Kext Utility in order to rebuild the kext cache.

Reboot with the Fury X connected. You should get acceleration now and eliminate the artifacts.
 
Joined
Aug 8, 2016
Messages
16
Download Xcode from the App Store and download Kext Utility from this website.

The Kexts are located in System/Library/Extensions. Right click on the kext and select Show Package Contents. Open the contents folder and drag the info.plist file to the desktop. I use Xcode to edit the file, there are other editors available that work also. Open info.plist with Xcode and add 0x73001002 as shown above. Save and drag the info.plist file back into the contents folder. You will be asked to authenticate, do so and select replace. Do this for the AMDRadeonX4100.kext and the AMD9000Controller.kext

Run Kext Utility in order to rebuild the kext cache.

Reboot with the Fury X connected. You should get acceleration now and eliminate the artifacts.

I tried that (only after unlocking hidden files thanks to my brother) but I when i tried to use the kext utility to rebuild the cache, it didn't work and my computer will not boot now. I'm trying recover the mac but what should I try next?
 
Top