Contribute
Register

AMD/ATI 7xxx and "Rxxx" with Mavericks ?

Status
Not open for further replies.
Joined
Sep 5, 2013
Messages
104
Motherboard
GA-H87N-WIFI
CPU
4770
Graphics
RX570
Mac
  1. MacBook Air
  2. MacBook Pro
Classic Mac
  1. PowerBook
I've tried to look in the forum without real success. Does Mavericks support the 7xxx and the new Rxxx out of the box like the Nvidia?
I'm looking for a decent single slot video card and the only one i found is a ATI 7750...

Thanks!
 
Joined
Oct 17, 2011
Messages
15
Motherboard
Z68X-UD3H-B3 (EUFI)
CPU
Intel 2500K
Graphics
XFX 6870
Mac
  1. MacBook Air
Classic Mac
Mobile Phone
  1. iOS
It supports my SAPPHIRE HD 7950 3GB with the same Mountain Lion hoops here

http://www.tonymacx86.com/318-amd-radeon-hd-7xxx-graphics-support-os-x-10-8-3.html

I have mine booting with the IGP HD 3000 as initial boot so my screen is black from power on to login, but then switches over to fully working 7950. I never could figure out the screen rotation trick with my triple monitors. Had to use HD 3000 for install as well as booting off the 7950 had white screens (no way to do the rotation trick)

One improvement in mavericks is that I'm able to use the fakeSMC sensor plugins again, in ML the graphics plugins KP'd the system. (though it could be that they updated FakeSMC to fix that issue, not sure).
 
Joined
Dec 8, 2012
Messages
1
Motherboard
10.8
CPU
i5
Graphics
650
Mac
Classic Mac
Mobile Phone
My HD7750 in Mavericks works natively without any additional actions.
 
Joined
Oct 22, 2013
Messages
4
Motherboard
Asus
CPU
8400
Graphics
1080Ti
Just did a clean install with Maverick with my HIS 7950 plugged in (no use of integrated graphics) and so far, it works pretty good :)
 
Joined
Sep 8, 2013
Messages
5
Motherboard
windows
CPU
intel 3770k
Graphics
7850
Mac
Classic Mac
Mobile Phone
anyone with luck using a hd 7850? really would be great to know :)
 
Joined
May 19, 2011
Messages
29
Motherboard
GA-z68x-ud3h-b3
CPU
i7 2600k
Graphics
AMD HD7850 2GB
Mac
  1. iMac
Classic Mac
Mobile Phone
i got my 7850 to work.. some what.. it gets detected by MAC and it shows as follows..

now, the reason i say somewhat is because, the pc seems to be laggy (animations)...

when i open launchpad, it is very laggy and slow.. also when i open safari it takes forever to load images.. and when i scroll pages it seems laggy.. also when the top sites (when opening a new tab) section loads slow as if my pc sucks...

my build

i7 sandy
16GB RAM
AMD 7850 Ghost (single fan) 2GB

i modified the kexts to include my device id in order to get it recognized by mac.. i was going to try to edit AMDradeonaccelerator.kext but it was nowhere to be found in my extension folder.. and so i tried downloading one from another forum post and edit it to include my device id but the accelerator kext didn't make any difference..

anyone has any idea on how to fix this laggy animation or graphics stuff.??
 

Attachments

  • Untitled.jpg
    Untitled.jpg
    34 KB · Views: 795
Status
Not open for further replies.
Top