Contribute
Register

Almost successful build with i7 8700k, Asus hero maximus x, Intel UHD 630

Joined
Jun 21, 2018
Messages
4
Motherboard
Asus ROG Maximus x hero
CPU
i7 8700K
Graphics
Intel UHD630
Mac
MacBook Pro, Mac Pro
Mobile Phone
iOS
Hi guys!

First of all, I'm incredibly thankful for this forum and all of the resources. I haven't built computers since I was like 16, and back then it was almost exclusively PC, so I could never have figured any of this stuff out on my own.

Yesterday I thought I had a perfectly working build, but today it acts weird. I do two screens, and I thought I solved it all with the the right smbios settings (17.1), the adgpfix and some tweaking in clover to make it recognize my internal graphics model.

So today I start the computer up, and it seems to have rolled back a few hours. I notice this because I had a desktop background for a short amount of time, then changed it. Today that background is back. One screen is flickering, and the other one is black. If I disconnect the black screen, the main screen turn normal. Also had some problems with the keyboard not responding (?).

I thought that maybe there's been some updates installed without me noticing, so that I'd have to do the adgpfix again. I restart and go in to clover settings. Notice that the sip settings have been restored, and seems to do so on every restart. So that's one question mark I have. I boot with sip disabled and try to run agdpfix again, but it says it already seems to be patched.

So.. Any suggestions on what might have happened?

Except for the dual monitor setup everything works fine. I'll list my monitor setup here aswell, if that could matter. But as I said, I got it working perfectly once.
Main monitor: Asus, pretty modern. Connected with Displayport out to hdmi in.
Side monitor: Reeeally old Samtron monitor, connected with hdmi out to vga in. I've read that vga might be troublesome, but as I mentioned, it worked fine yesterday.

Would be very happy for any theories!
 
Top