Contribute
Register

Alienware installation help required

Status
Not open for further replies.
Joined
Jul 17, 2017
Messages
21
Motherboard
Alienware / Intel Z270
CPU
Intel i7-7700K
Graphics
GeForce GTX 1080, HD630, 1440p
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. Android
  2. iOS
Working:
  1. Nvidia GTX 1080 (Nvidia Web driver)
  2. Audio (ALC 898, LayoutID: 1)
  3. Bluetooth(Currently working. Have to see what happens when I replace the WiFi chip)
  4. Ethernet (AtherosE2200Ethernet.kext)
Not working:
  1. WiFi (Killer 1535 isn't supported. Ordered a AzureWave Broadcom BCM94352HMB which is in transit, the AzureWave Broadcom BCM94352HMB was a mistake. It is a Mini PCI-E card. Aurora R6 has a M.2 2230 slot)
  2. No HDMI audio on Pascal cards
  3. USB 3.1 type-A port on the rear IO. Works as USB 3.
Not tested:
  1. USB 3.1 Type C port
  2. Installing to stock NVMe SSD. (System shipped with SK hynix NVMe which gave issues. It was replaced by Dell with a Toshiba NVMe drive). Toshiba still works as a data drive. I bought a SATA SSD for the Boot drive.
  3. Mic input ports, rear input ports.

Use the EFI from EFI-InstallerUSB.zip for your Sierra 10.12.6 installation USB. The graphics will be slow, but it'll work.

Use the EFI from EFI-BootDrive.zip for your boot drive after installation. Make sure to install Nvidia Web Driver.

---------
Model: Alienware Aurora R6
CPU: Intel i7-7700K
GPU: Nvidia GTX 1080
NVMe: THNSN5256GPUK NVMe TOSHIBA 256GB (Shipped with PC300 NVMe SK hynix 256GB, later replaced by Dell)
SATA SSD: Samsung SSD 850 EVO 250GB (Aftermarket)
Wireless Chip: Killer 1535 (will be replaced)
 

Attachments

  • EFI-BootDrive.zip
    2.9 MB · Views: 56
  • EFI-InstallerUSB.zip
    3.9 MB · Views: 60
Last edited:
Joined
Jan 7, 2017
Messages
5
CPU
I7-6700
Graphics
GTX 970
Mobile Phone
  1. Android
Working:
  1. Nvidia GTX 1080
  2. Audio
  3. Bluetooth(Currently working. Have to see what happens when I replace the WiFi chip)
  4. Ethernet
Not working:
  1. WiFi (Killer 1535 isn't supported. Ordered a AzureWave Broadcom BCM94352HMB which is in transit)
  2. No HDMI audio on Pascal cards
  3. USB 3.1 type-A port on the rear IO. Works as USB 3 with a pen drive, as USB 2.0 with a USB 3.0 hub connected
Not tested:
  1. USB 3.1 Type C port
  2. Installing to stock NVMe SSD. (System shipped with SK hynix NVMe which gave issues. It was replaced by Dell with a Toshiba NVMe drive). Toshiba still works as a data drive. I bought a SATA SSD for the Boot drive.
  3. Mic input ports, rear input ports.

Use the EFI from EFI-InstallerUSB.zip for your Sierra 10.12.6 installation USB. The graphics will be slow, but it'll work.

Use the EFI from EFI-BootDrive.zip for your boot drive after installation. Make sure to install Nvidia Web Driver.

---------
Model: Alienware Aurora R6
CPU: Intel i7-7700K
GPU: Nvidia GTX 1080
NVMe: THNSN5256GPUK NVMe TOSHIBA 256GB (Shipped with PC300 NVMe SK hynix 256GB, later replaced by Dell)
SATA SSD: Samsung SSD 850 EVO 250GB (Aftermarket)
Wireless Chip: Killer 1535 (will be replaced)


im still having probloms bootong, would you mind asending me your install process?
 
Joined
Sep 20, 2017
Messages
12
Motherboard
Alienware Aurora R6
CPU
i7 7700k
Graphics
Intel HD 630/Nvidia GTX 1080
im still having probloms bootong, would you mind asending me your install process?
I'm having problems with this too. I can install without too much trouble but I can't get the Nvidia drivers to work. Unfortunately the bios doesn't allow for disabling the onboard graphics.

Any help would be much appreciated.
 

BreBo

Moderator
Joined
Oct 17, 2011
Messages
9,449
Motherboard
Gigabyte GA-Z87X-OC
CPU
i7-4770K
Graphics
HD 4600 / RX 580
@legsak1mbo, please update your profile (personal details) with your Motherboard or Make/Model, CPU and Graphics Card.
The Rules said:
Profiles need to contain at least your primary system to assist others with helping you.
 
Joined
Jul 17, 2017
Messages
21
Motherboard
Alienware / Intel Z270
CPU
Intel i7-7700K
Graphics
GeForce GTX 1080, HD630, 1440p
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. Android
  2. iOS
I'm having problems with this too. I can install without too much trouble but I can't get the Nvidia drivers to work. Unfortunately the bios doesn't allow for disabling the onboard graphics.

Any help would be much appreciated.
Did you install the Nvidia Web drivers?

If you have, then take a look at my config.plist in the EFI-BootDrive.zip that I uploaded in post #11. While booting connect your HDMI/DP cable to the Nvidia card.
 
Joined
Sep 20, 2017
Messages
12
Motherboard
Alienware Aurora R6
CPU
i7 7700k
Graphics
Intel HD 630/Nvidia GTX 1080
Did you install the Nvidia Web drivers?

If you have, then take a look at my config.plist in the EFI-BootDrive.zip that I uploaded in post #11. While booting connect your HDMI/DP cable to the Nvidia card.

I had yes but was still getting Intel-related kernel panics.

I've used the config.plist and a few other tweaks from here https://www.tonymacx86.com/threads/success-alienware-aurora-r6-with-10-12-6.229567 and it's all working swimmingly now. The only thing that I need to figure out is getting the Dell to boot from the SATA SSD into Clover by default - the bios is somewhat limited.
 
Joined
Jul 17, 2017
Messages
21
Motherboard
Alienware / Intel Z270
CPU
Intel i7-7700K
Graphics
GeForce GTX 1080, HD630, 1440p
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. Android
  2. iOS
I had yes but was still getting Intel-related kernel panics.

I've used the config.plist and a few other tweaks from here https://www.tonymacx86.com/threads/success-alienware-aurora-r6-with-10-12-6.229567 and it's all working swimmingly now. The only thing that I need to figure out is getting the Dell to boot from the SATA SSD into Clover by default - the bios is somewhat limited.

You can change the boot order in BIOS. Use the File Browser Add Boot Option option to add Clover entry(any custom name). Then you can change the Boot priority between Option #1 and #2.


View attachment 279757
 

Attachments

  • IMG_20170921_154332.jpg
    IMG_20170921_154332.jpg
    1.5 MB · Views: 93
Last edited:
Status
Not open for further replies.
Top