Contribute
Register

Alienware Area51m R2 near fully working - Problems with Display and Sound

Joined
May 31, 2010
Messages
14
Motherboard
Sabertooth X79
CPU
3930
Graphics
gtx680
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Hi,
I get the new Alienware Area51M R2 with an RX5700m! as eGPU. I get the AMD GPU because the possibility to get OSX working.
This was good choice - the rx5700m working out of the box! I get for now in Big Sur near everything to work :

eGPU,WLAN,BT,LAN,Keyboard,Touchpad,USB,TB, DP/HDMI out etc....

Only 3 Devices make problems:

1.) Display is an 144HZ 1920x1080 FHD and - under Windows - the only resolution is 1920x1080 with 144HZ! (?????!!!!)
I create individual Resolutions with SwitchResx - only 1920x1080 (without HDPI)with 144 HZ works. I got it with this
app to change the resolution after login. With HDPI I get an 960x540 too... but no luck to get it at login screen. With an fake Monitor Kext I get login screen - but only with an 4K Profile and I can't see login field...... EDID Insert not work.... All WEG boot args are not working. I'm searching for an Possibility to get login screen working and Desktop without this app.

2.) Audio - the codec is an ALC215 - with Layout 18 i get the Audio device up and can change volume. But no sound from internal speakers.....

3.) TouchPad - working with ApplePS2smart....kext. But not good. Any ideas for this Alienware Touchpad ?


Thanks for Help.
 
Joined
May 31, 2010
Messages
14
Motherboard
Sabertooth X79
CPU
3930
Graphics
gtx680
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
It is an embedded internal rx5700m not external eGPU. The Intel IGPU is disabled.
 
Joined
Mar 21, 2016
Messages
15
Motherboard
hm170
CPU
i3-8100
Graphics
uhd630+GT950M
Mac
  1. MacBook Pro
Classic Mac
  1. iMac
Mobile Phone
  1. Android
what about now ?
 
Joined
Aug 15, 2020
Messages
10
Motherboard
Alienware A51m R2 (Opencore)
CPU
i9-10900K/Z490
Graphics
RX 5700m,1920x1080
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. Android
  2. iOS
  3. Other
Hi, I have exactly the same hardware as you. a51m r2 with 5700m GPU.
Display works for me except the brightness adjustment, tried many fix and all failed. Now I need iMac20,2 original ioreg and DSDT to overcome this issue.
Audio also works, but it will go default to headphones on every boot.
The touchpad works by using voodooi2c, but no guesture.
By the way, I wrote a mac program that can control alienfx under mac.
Also this device has other issues, the performance of 5700m under mac os is less than half performance than windows 10, I don't know if you are the same too.
 
Joined
May 31, 2010
Messages
14
Motherboard
Sabertooth X79
CPU
3930
Graphics
gtx680
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Hi. I get now little Time to continue. I get first Video working without any "Patches" : MacPro2019 (Mac7.1) and
11.5.2. With iMac (imac20.2) I don't get login at 1080P - only at 4K. gogowin113 -> DSDT? Can I have it?
Audio internal shows working with ID=18 but only at headphones. No internal speakers...
I use now OpenCore 7.2 and don't test everything . btw -> Opencore only works in text mode.. no graphics.
And Touchpad is ... only working but ... very worse....
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
23,692
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
Hi. I get now little Time to continue. I get first Video working without any "Patches" : MacPro2019 (Mac7.1) and
11.5.2. With iMac (imac20.2) I don't get login at 1080P - only at 4K. gogowin113 -> DSDT? Can I have it?
Audio internal shows working with ID=18 but only at headphones. No internal speakers...
I use now OpenCore 7.2 and don't test everything . btw -> Opencore only works in text mode.. no graphics.
And Touchpad is ... only working but ... very worse....
use a laptop smbios

no DSDT required with OpenCore

please update your hardware profile to allow others to help you easier

read the faq for proper hardware profile setup:
 
Joined
Aug 15, 2020
Messages
10
Motherboard
Alienware A51m R2 (Opencore)
CPU
i9-10900K/Z490
Graphics
RX 5700m,1920x1080
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. Android
  2. iOS
  3. Other
iMac20,2 SMBios is OK. And it's better to use platform-id 07009B3E. This combo is perfect for this machine. And by the way, I'm running 11.5.2 which is the newest Big Sur. Maybe we are using a different system.
 
Last edited:

Feartech

Moderator
Joined
Aug 3, 2013
Messages
23,692
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
iMac20,2 SMBios is OK. And it's better to use platform-id 07009B3E. This combo is perfect for my machine. And by the way, I'm running 11.5.2 which is the newest Big Sur. Maybe we are using a different system.
wrong to use a desktop smbios on a laptop system
 
Joined
Aug 15, 2020
Messages
10
Motherboard
Alienware A51m R2 (Opencore)
CPU
i9-10900K/Z490
Graphics
RX 5700m,1920x1080
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. Android
  2. iOS
  3. Other
wrong to use a desktop smbios on a laptop system
I'm sorry, but this is a laptop using a desktop cpu... and most important, iMac20,2 with rx5700 has exactly the same hardware specs as this computer...
 
Joined
Aug 15, 2020
Messages
10
Motherboard
Alienware A51m R2 (Opencore)
CPU
i9-10900K/Z490
Graphics
RX 5700m,1920x1080
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. Android
  2. iOS
  3. Other
By the way, I have fixed the brightness adjustment problem, this machine is perfect.
 
Top