Contribute
Register

ALC889 Sound Assertion Errors

Status
Not open for further replies.
Joined
Jul 27, 2011
Messages
32
Motherboard
Hackintosh
CPU
Core i7 2600K
Graphics
Sapphire HD 6850
Mac
Classic Mac
Mobile Phone
Hmmm right, using MacPro 3,1 fixes this issue.
 
Joined
Aug 12, 2011
Messages
354
Motherboard
Probook 4440:4540
CPU
i3-3110M
Graphics
HD4000
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
Mobile Phone
The popping is not caused by energy management. It is much simpler; if the codec doesn't have an audio signal for ~60 seconds, it quiets (reduces power to) the amp. This eliminates the static you hear, especially when an input is connected to a output in one of these systems. You hear this when you use an iPod as the input, headphones for the output, mute the iPod and 60m seconds later, the static is stops; that is quieting. The only system definition which doesn't enable quieting is macpro3,1. In the experiment, the static does not stop and there is not pop when an audio signal restarts. The pops are one problem and (I believe) the sound assertions, in particular the timeout, is a different problem.

Thanks toleda, I updated to Mac 3,1 from iMac 12,2 - no more console messages or sound delays. BTW old AppleHDARollback option did not report any messages and worked for me fine on UD5, but it is time to move forward. My GA-Z68X-UD3H-B3 had many audio issues with AppleHDARollback and your solution + MAcPro 3,1 fixed it nicely.

Thanks again!
 
Status
Not open for further replies.
Top