Contribute
Register

ALC255 Distorted Headphone Audio

Joined
Oct 25, 2017
Messages
24
Motherboard
Dell Optiplex 7050
CPU
i5-7500t
Graphics
Intel HD 630
Mobile Phone
Android, iOS
Issue & Scenario:
-Distorted audio on headphone port

-Run kextstat, no CodecCommander.kext found
-Load CodecCommander.kext from S/L/E using kextload after I'm booted up....everything works perfect, no other changes needed.
-Reboot
-Run kextstat, no CodecCommander.kext found
-Copy CodecCommander.kext to EFI/EFI/Clover/Kexts/Other
-Delete CodecCommander.kext from S/L/E
-Reboot
-Login & run kextstat, CodecCommander.kext is now found
-Still have distorted audio
-ensure hda-verb from another post to /usr/bin
-execute the following commands in terminal: "hda-verb 0x19 SET_PIN_WIDGET_CONTROL 0x25" and "hda-verb 0x21 SET_UNSOLICITED_ENABLE 0x83"
-headphone audio sounds good until restart

What could I be missing? Mainly posting here in case someone has a quick fix.

I know, pr files. Working on it.

Mod note: I responded with most of the same stuff to a laptop support post (first one that came up when searching forums for "ALC255 headphone"...it'll probably get trashed since it's in a laptop forum and I'm on a desktop.
 

Attachments

Joined
Jul 6, 2019
Messages
5
Motherboard
acer swift5 514-51
CPU
i5-7200U
Graphics
HD 620
Thx! you helped me a lot! I just followed ur way and it worked on my alc255 as well!!!



for me, the key is to copy 'hda-verb' file to '/usr/bin'(on wallpaper push cmd+shift+g and paste /usr/bin, then you can reach it).

and copied codeccommender.kext to /EFI/Clover/Kexts/Other

and reboot then worked well! Thx!!
 
Joined
Jul 23, 2015
Messages
64
Motherboard
Acer Swift 5 SF514-53t
CPU
i5-8265U
Graphics
UHD 620
Mac
MacBook Pro
Mobile Phone
iOS
Issue & Scenario:
-Distorted audio on headphone port

-Run kextstat, no CodecCommander.kext found
-Load CodecCommander.kext from S/L/E using kextload after I'm booted up....everything works perfect, no other changes needed.
-Reboot
-Run kextstat, no CodecCommander.kext found
-Copy CodecCommander.kext to EFI/EFI/Clover/Kexts/Other
-Delete CodecCommander.kext from S/L/E
-Reboot
-Login & run kextstat, CodecCommander.kext is now found
-Still have distorted audio
-ensure hda-verb from another post to /usr/bin
-execute the following commands in terminal: "hda-verb 0x19 SET_PIN_WIDGET_CONTROL 0x25" and "hda-verb 0x21 SET_UNSOLICITED_ENABLE 0x83"
-headphone audio sounds good until restart

What could I be missing? Mainly posting here in case someone has a quick fix.

I know, pr files. Working on it.

Mod note: I responded with most of the same stuff to a laptop support post (first one that came up when searching forums for "ALC255 headphone"...it'll probably get trashed since it's in a laptop forum and I'm on a desktop.
I had similar problem before.
Noise sound over earphone after wakeup from sleep. I modified the info.plist of CodecCommander as below the noise sound gone after wake up form sleep.

In info.plist of CodecCommander.kext under Root\IOKitPersonalities\CodecCommander\Codec Profile\Default\Custom Commands\Perform Reset on EAPD Fail\ . . <NO> change to ----><YES>
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
15,612
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
iMac
Mobile Phone
iOS
I had similar problem before.
Noise sound over earphone after wakeup from sleep. I modified the info.plist of CodecCommander as below the noise sound gone after wake up form sleep.

In info.plist of CodecCommander.kext under Root\IOKitPersonalities\CodecCommander\Codec Profile\Default\Custom Commands\Perform Reset on EAPD Fail\ . . <NO> change to ----><YES>
that's brilliant! seems to have worked for me :)
 
Top