Contribute
Register

Airplay Mirroring with HD4000 / GTX680 on 10.8.4

Joined
Sep 20, 2012
Messages
39
Motherboard
Gigabyte GA-Z77X-UP5 TH
CPU
E3-1245v2
Graphics
RX Vega 56
Mac
iMac, MacBook Air
Mobile Phone
iOS
Hi, the following hackintosh works great with the exception of Airplay mirroring:

Xeon E3-1245v2 with HD4000 integrated graphics
Gigabyte GA-Z77X-UP5 TH (F11)
Gigabyte GeForce GTX680
Mac OSX 10.8.4


In UEFI, the HD4000 is initialised first as is required for Airplay Mirroring.
My Display is connected to the GTX680 with a displayport cable (2560 x 1440 @ 60 Hz).

I patched my DSDT.aml with the following repository (http://www.tonymacx86.com/dsdt/99822-gigabyte-dsdt-patch-repository-maciasl.html)

Hardware Identifier is (in german):
Modellname: iMac
Modell-Identifizierung: iMac13,2
Prozessortyp: Intel Core i7
Prozessorgeschwindigkeit: 3,40 GHz
Anzahl der Prozessoren: 1
Gesamtanzahl der Kerne: 4
L2-Cache (pro Kern): 256 KB
L3-Cache: 8 MB
Speicher: 32 GB
Boot-ROM-Version: IM131.010A.B05
SMC-Version (System): 1.30f3

Graphics Identifier is (in german):

Intel HD Graphics 4000:


Chipsatz-Modell: Intel HD Graphics 4000
Typ: GPU
Bus: Integriert
Steckplatz: Built In
VRAM (gesamt): 768 MB
Hersteller: Intel (0x8086)
Geräte-ID: 0x0166
Versions-ID: 0x0009

NVIDIA GeForce GTX 680:


Chipsatz-Modell: NVIDIA GeForce GTX 680
Typ: GPU
Bus: PCIe
PCIe-Lane-Breite: x16
VRAM (gesamt): 2048 MB
Hersteller: NVIDIA (0x10de)
Geräte-ID: 0x1180
Versions-ID: 0x00a2
ROM-Version: preset 1.0.0


Any hints on how to enable AirPlay Mirroring (which works from my MacBook Air) is highly appreciated.
Sending audio or video from iTunes to my AppleTV via Airplay works flawlessly.
 

toleda

Moderator
Joined
May 20, 2010
Messages
24,452
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
iMac, MacBook Pro, Mac mini
Classic Mac
512K, LC, Power Mac
Mobile Phone
iOS
Joined
Sep 20, 2012
Messages
39
Motherboard
Gigabyte GA-Z77X-UP5 TH
CPU
E3-1245v2
Graphics
RX Vega 56
Mac
iMac, MacBook Air
Mobile Phone
iOS
Hi Toleda,

thank you for your reply. That thread was the first I found when using google and I already read it.

GraphicsEnabler = No
is already set in boot.plist.
Furthermore I did not only patch the SSDT for my Motherboard, but also applied the graphics patch from http://pjalm.info/repos/graphics/ which is based on your work (and gives credit to it :thumbup: )
My EFI settings (as already stated) are as you described in your thread.
After applying the SSDT Graphics patch, my HD4000 was recognized and HDMI Audio appeared, too.

But nevertheless, Airplay mirroring never worked and did not show in Preferences or the menu bar. (while iTunes airplay works flawlessly).

Any troubleshooting options?
 
Joined
Sep 20, 2012
Messages
39
Motherboard
Gigabyte GA-Z77X-UP5 TH
CPU
E3-1245v2
Graphics
RX Vega 56
Mac
iMac, MacBook Air
Mobile Phone
iOS
S/L/E/Enabler1.kext should be removed. Why didn't you use the discrete graphics patch?
Hi Toleda, I do not know what S/L/E/Enabler1.kext is and I never installed it. I have "HDAEnabler1.kext" and "ApplePlatformEnabler.kext" in /System/Library/Extensions. Those are the only .kext which have "enabler" in it.

And what exactly is the "discrete graphics patch".
 

toleda

Moderator
Joined
May 20, 2010
Messages
24,452
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
iMac, MacBook Pro, Mac mini
Classic Mac
512K, LC, Power Mac
Mobile Phone
iOS
I have "HDAEnabler1.kext" and "ApplePlatformEnabler.kext" in /System/Library/Extensions.

And what exactly is the "discrete graphics patch".
My mistake, remove S/L/E/HDAEnabler1.kext. Leave ApplePlatformEnabler.kext. See PJALM's DSDT Patches.
 
Joined
Sep 20, 2012
Messages
39
Motherboard
Gigabyte GA-Z77X-UP5 TH
CPU
E3-1245v2
Graphics
RX Vega 56
Mac
iMac, MacBook Air
Mobile Phone
iOS
Hi Toleda,

I deleted HDAEnabler1.kext from /System/Library/Extension.
After that, I deleted the DSDT.aml from /Extra, rebooted and patched the System DSDT with the Motherboard Patch, then the discrete patch and finally the HD4000 patch.
After a reboot, sound is working again, even without HDAEnabler1.kext.
But I still cannot use Airplay Mirroring.

See attached my new IOReg. I hope I do not bore you but it seems no one else knows as much about this as you.
Your help is really appreciated.

View attachment IOReg-new.ioreg
 
Joined
Sep 20, 2012
Messages
39
Motherboard
Gigabyte GA-Z77X-UP5 TH
CPU
E3-1245v2
Graphics
RX Vega 56
Mac
iMac, MacBook Air
Mobile Phone
iOS
Seems no one is able to solve this. I will revert to GTX680 as first display device since blind multi-booting does result in some frustation.

If anyone has an idea how to enable airplay-mirroring on my machine, please post to this thread.
Thank you!
 
Top