Contribute
Register

Aiport Problem After Wake (BRCM4352)

Joined
Jul 2, 2015
Messages
20
Mac
Classic Mac
Mobile Phone
Hi everyone,
I am relatively new to Hackintosh and does not have much experience. Currently, I am experiencing difficulty with my laptop. I followed: http://www.tonymacx86.com/threads/guide-booting-the-os-x-installer-on-laptops-with-clover.148093/ for installation, and this: http://www.tonymacx86.com/threads/guide-patching-laptop-dsdt-ssdts.152573/ for ACPI patching.

I have a Dell xps 13 9343, i5-5200U, Intel HD5500, Brcm4352, 3200x1800 touch screen.

What works:
battery status, backlight control, Intel HD graphics, Sleep and Wake.

What does not work:
Camera (having had the time to dig into this topic)

What is troubling:
Wifi and Bluetooth works fine when I boot into OS X. However, after wake, airport fails and cannot be turned on (sudo ifconfig en0 up command does not work). Other features of wake seems to be fine. I need to restart the computer in order to get airport working again. Interestingly, I have noticed in the console that airport seems to be "activated" by a BRCM4360 kext on boot, while BRCM4352 kext is disabled. After wake, the console shows no message associated with BRCM4360 kext, and only shows messages related to BRCM4352 kext. The attached file is the console output before and after sleep.

Is this an issue related to power management? How can I remove BRCM4360 kext? Any input will be greatly appreciated!
 

Attachments

  • airport_error.txt
    1.9 KB · Views: 260

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,467
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hi everyone,
I am relatively new to Hackintosh and does not have much experience. Currently, I am experiencing difficulty with my laptop. I followed: http://www.tonymacx86.com/threads/guide-booting-the-os-x-installer-on-laptops-with-clover.148093/ for installation, and this: http://www.tonymacx86.com/threads/guide-patching-laptop-dsdt-ssdts.152573/ for ACPI patching.

I have a Dell xps 13 9343, i5-5200U, Intel HD5500, Brcm4352, 3200x1800 touch screen.

What works:
battery status, backlight control, Intel HD graphics, Sleep and Wake.

What does not work:
Camera (having had the time to dig into this topic)

What is troubling:
Wifi and Bluetooth works fine when I boot into OS X. However, after wake, airport fails and cannot be turned on (sudo ifconfig en0 up command does not work). Other features of wake seems to be fine. I need to restart the computer in order to get airport working again. Interestingly, I have noticed in the console that airport seems to be "activated" by a BRCM4360 kext on boot, while BRCM4352 kext is disabled. After wake, the console shows no message associated with BRCM4360 kext, and only shows messages related to BRCM4352 kext. The attached file is the console output before and after sleep.

Is this an issue related to power management? How can I remove BRCM4360 kext? Any input will be greatly appreciated!

Camera is likely a USB problem: http://www.tonymacx86.com/threads/guide-10-11-usb-changes-and-solutions.173616/

Make sure you disable "Wake for network access". And make sure you patched ACPI correctly:

http://www.tonymacx86.com/threads/guide-patching-laptop-dsdt-ssdts.152573/
 
Top