Contribute
Register

After update to 10.12.1 BCM94352 WiFi not working

Joined
Nov 14, 2014
Messages
37
Motherboard
GA-Z170N-WIFI
CPU
Core i5-7600K
Graphics
Intel® HD Graphics 630
Mac
MacBook Pro
Mobile Phone
Android, iOS
Hey,
After updating macOS Sierra to 10.12.1 version I've lost my wifi working. To get it working I was following a guide on this site
https://www.tonymacx86.com/threads/guide-airport-pcie-half-mini-v2.104850/
And it was working, but without 5GHz on El Capitan. In macOS Sierra I had to use this patch:

<dict>
<key>Comment</key>
<string>AirPortBrcm4360 - fcvo</string>
<key>Disabled</key>
<false/>
<key>Find</key>
<data>gflSqgAAdSk=</data>
<key>Name</key>
<string>AirPortBrcm4360</string>
<key>Replace</key>
<data>gflSqgAAZpA=</data>
</dict>
But now only BT works, any suggestions?
 

neilhart

Moderator
Joined
May 25, 2010
Messages
2,719
Motherboard
ASRock Fatal1ty Z270 Gaming - ITX/ac
CPU
Intel i7-7700T (TDP: 35W)
Graphics
Gigabyte GTX960 2GB, ITX
Mac
MacBook, MacBook Pro
Mobile Phone
iOS
Hey,
After updating macOS Sierra to 10.12.1 version I've lost my wifi working. To get it working I was following a guide on this site
https://www.tonymacx86.com/threads/guide-airport-pcie-half-mini-v2.104850/
And it was working, but without 5GHz on El Capitan. In macOS Sierra I had to use this patch:

<dict>
<key>Comment</key>
<string>AirPortBrcm4360 - fcvo</string>
<key>Disabled</key>
<false/>
<key>Find</key>
<data>gflSqgAAdSk=</data>
<key>Name</key>
<string>AirPortBrcm4360</string>
<key>Replace</key>
<data>gflSqgAAZpA=</data>
</dict>
But now only BT works, any suggestions?
Yes I have the same issue: BCM94352Z WiFi & BT working in 10.12 but does not load WiFi after update to 10.12.1. This is on my ASUS Z170I Pro Gaming with same patch shown above. Looking for a fix.

Good modding,
neil
 

neilhart

Moderator
Joined
May 25, 2010
Messages
2,719
Motherboard
ASRock Fatal1ty Z270 Gaming - ITX/ac
CPU
Intel i7-7700T (TDP: 35W)
Graphics
Gigabyte GTX960 2GB, ITX
Mac
MacBook, MacBook Pro
Mobile Phone
iOS
Yes I have the same issue: BCM94352Z WiFi & BT working in 10.12 but does not load WiFi after update to 10.12.1. This is on my ASUS Z170I Pro Gaming with same patch shown above. Looking for a fix.

Good modding,
neil
Found a fix for this one.

Go to Insanleymac and search for this thread: [FIX] macOS Sierra DP1 BCM94532Z WiFi

And look in post # 106 for an additional three patches. Add them to your kexts to patch section as in the attached config.plist.

If you had your BCM94352Z working correctly in 10.12 both WiFi and BT then with this set of patches the 10.12.1 update should now have WiFi and BT working correctly.
 

Attachments

toleda

Moderator
Joined
May 20, 2010
Messages
24,379
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
iMac, MacBook Pro, Mac mini
Classic Mac
512K, LC, Power Mac
Mobile Phone
iOS
Last edited:

neilhart

Moderator
Joined
May 25, 2010
Messages
2,719
Motherboard
ASRock Fatal1ty Z270 Gaming - ITX/ac
CPU
Intel i7-7700T (TDP: 35W)
Graphics
Gigabyte GTX960 2GB, ITX
Mac
MacBook, MacBook Pro
Mobile Phone
iOS
Fixed the wrong problem. What broke is is clover/FixAirport_4000
There is no 4352 PCI problem, it is a device-id injection problem.
See [Guide] Airport - PCIe Half Mini v2/Post #1/Airport/WiFi Injection Methods
toleda thank you. I did not see anything in your thread concerning BCM94352Z not working from 10.12 to 10.12.1.

neil
 

toleda

Moderator
Joined
May 20, 2010
Messages
24,379
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
iMac, MacBook Pro, Mac mini
Classic Mac
512K, LC, Power Mac
Mobile Phone
iOS
did not see anything in your thread concerning BCM94352Z not working from 10.12 to 10.12.1.
See Airport/WiFi Injection Methods/
5. Clover/config.plist/ (10.12+, not working)
 

neilhart

Moderator
Joined
May 25, 2010
Messages
2,719
Motherboard
ASRock Fatal1ty Z270 Gaming - ITX/ac
CPU
Intel i7-7700T (TDP: 35W)
Graphics
Gigabyte GTX960 2GB, ITX
Mac
MacBook, MacBook Pro
Mobile Phone
iOS
See Airport/WiFi Injection Methods/
5. Clover/config.plist/ (10.12+, not working)
Yes I see, a tree hidden in a forest.

neil
 

neilhart

Moderator
Joined
May 25, 2010
Messages
2,719
Motherboard
ASRock Fatal1ty Z270 Gaming - ITX/ac
CPU
Intel i7-7700T (TDP: 35W)
Graphics
Gigabyte GTX960 2GB, ITX
Mac
MacBook, MacBook Pro
Mobile Phone
iOS
For me doesn't work, after selecting Fix AirDrop i have KP
Please examine the config.plist that I attached in post # 3. I did not use any Clover "Fixes" under Root > ACPI > DSDT > Fixes.

Also note that this system uses Clover ver 3766 installed with MultiBeast 9.0.1.









Good modding,
neil
 
Last edited:
Joined
Apr 29, 2012
Messages
1
Motherboard
Mountain Lion
CPU
i7 2600k
Graphics
HD6750
Mac
MacBook Pro, Mac Pro
Classic Mac
Mobile Phone
Android, iOS
use both patch for 10.12 and the attachment shows.
It works well for me with the 2 patches.
 

Attachments

Top