Contribute
Register

Advanced Ethernet NIC technical question - "is not serializable"

Status
Not open for further replies.
Joined
Sep 3, 2015
Messages
169
Motherboard
MSI X99A GODlike Gaming LGA 2011-v3 Intel X99
CPU
i7-5820K Haswell-E 6-Core 3.3 GHz LGA 2011-v3 140W
Graphics
MSI GeForce GTX 980Ti 6GD5T OC 6GB 384-Bit GDDR5
Mac
  1. MacBook Pro
Classic Mac
Mobile Phone
  1. iOS
looking for help with getting my ethernet device to show up on my ElCap install. I just freshly reinstalled Unibeast and Multibeast (reformatted all hard drives, m-Flashed bios, cleared CMOs and started completely from square zero)_

there is a specific entry in my IODevice Tree called RP03@1C,2 and also another entry called RP08@1C,7 (see attached screen shots for each).

Both devices are built in Ethernet NIC cards on my Mobo. At the top of the screen there is a AAPL, slot-name as "Ethernet" -- but then it says that the api-device "is not serializable".

If anyone else has had to manually change their acpi table to add this device so that it is serializable (-i assume that means that it is readable by OS X?).

i have a kext that has been modified for E2400 (which is what i have) - but i cannot inject this kext or get the system to use it if it can't find the device to begin with.

thanks for any help anyone can offer.
Screen Shot 2015-11-18 at 8.55.20 PM.pngScreen Shot 2015-11-18 at 8.51.18 PM.png
Screen Shot 2015-11-18 at 8.50.50 PM.pngScreen Shot 2015-11-18 at 8.50.38 PM.png
 
Joined
Sep 3, 2015
Messages
169
Motherboard
MSI X99A GODlike Gaming LGA 2011-v3 Intel X99
CPU
i7-5820K Haswell-E 6-Core 3.3 GHz LGA 2011-v3 140W
Graphics
MSI GeForce GTX 980Ti 6GD5T OC 6GB 384-Bit GDDR5
Mac
  1. MacBook Pro
Classic Mac
Mobile Phone
  1. iOS

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,691
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
View attachment 163041

latest ioreg file after full reformat/reinstall/multibeast

From ioreg, you haven't installed the Ethernet drivers required for your device.

Without the drivers installed, no expectation of it in SysPrefs->Network->[+]
 
Joined
Sep 3, 2015
Messages
169
Motherboard
MSI X99A GODlike Gaming LGA 2011-v3 Intel X99
CPU
i7-5820K Haswell-E 6-Core 3.3 GHz LGA 2011-v3 140W
Graphics
MSI GeForce GTX 980Ti 6GD5T OC 6GB 384-Bit GDDR5
Mac
  1. MacBook Pro
Classic Mac
Mobile Phone
  1. iOS
From ioreg, you haven't installed the Ethernet drivers required for your device.

Without the drivers installed, no expectation of it in SysPrefs->Network->[+]

ok I have installed this kext using kext wizard (http://www.tonymacx86.com/attachmen...-ethernet-e2400-atherose2200ethernet.kext.zip.) then rebuilt permissions. do i need to do something else? it doesn't seem to be connecting to my NIC for some reason? Not sure if I need to use some of the ids from the IOReg to add to the kext somewhere so that it know what device it is supposed to be driving?

i know in NullEthernet.kext i'm supposed to enter in the mac address for the NIC and couldn't find the location in the E2400 kext to add that information. could I just copy from nullethernet.kext/info.plist (mac address section) over to the info.plist for the ethernet driver?

i just don't understand why it is not showing up after i install the kext?
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,691
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
ok I have installed this kext using kext wizard (http://www.tonymacx86.com/attachmen...-ethernet-e2400-atherose2200ethernet.kext.zip.) then rebuilt permissions. do i need to do something else? it doesn't seem to be connecting to my NIC for some reason? Not sure if I need to use some of the ids from the IOReg to add to the kext somewhere so that it know what device it is supposed to be driving?

i know in NullEthernet.kext i'm supposed to enter in the mac address for the NIC and couldn't find the location in the E2400 kext to add that information. could I just copy from nullethernet.kext/info.plist (mac address section) over to the info.plist for the ethernet driver?

i just don't understand why it is not showing up after i install the kext?

I prefer to get my kexts from the direct source (the author): http://www.insanelymac.com/forum/to...lcomm-atheros-ar816x-ar817x-and-killer-e220x/

You probably don't need to customize the Mac address for NullEthernet, but you can do so from the SSDT if you wish.
 
Joined
Sep 3, 2015
Messages
169
Motherboard
MSI X99A GODlike Gaming LGA 2011-v3 Intel X99
CPU
i7-5820K Haswell-E 6-Core 3.3 GHz LGA 2011-v3 140W
Graphics
MSI GeForce GTX 980Ti 6GD5T OC 6GB 384-Bit GDDR5
Mac
  1. MacBook Pro
Classic Mac
Mobile Phone
  1. iOS
I prefer to get my kexts from the direct source (the author): http://www.insanelymac.com/forum/to...lcomm-atheros-ar816x-ar817x-and-killer-e220x/

You probably don't need to customize the Mac address for NullEthernet, but you can do so from the SSDT if you wish.


this kext will not be installed for some reason and i keep getting the following errors in my system log:

Nov 25 14:38:18 NZXTs-iMac sharingd[265]: 14:38:18.355 : Tethering: Identifier needs fixing
Nov 25 14:58:18 NZXTs-iMac com.apple.kextd[43]: kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext "/Library/Extensions/AtherosE2200Ethernet.kext"
Nov 25 14:58:18 NZXTs-iMac kernel[0]: Ethernet [AtherosE2200]: Unknown chip. Aborting.
Nov 25 14:58:19 NZXTs-iMac com.apple.kextcache[579]: kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext AtherosE2200Ethernet.kext
Nov 25 15:01:51 localhost kernel[0]: Ethernet [AtherosE2200]: Unknown chip. Aborting.
Nov 25 15:02:05 NZXTs-iMac sharingd[248]: 15:02:05.336 : Tethering: Identifier needs fixing
Nov 25 15:09:09 localhost kernel[0]: Refusing new kext com.insanelymac.AtherosE2200Ethernet, v1.0.2: already have prelinked v2.0.1.
Nov 25 15:09:09 localhost kernel[0]: Ethernet [AtherosE2200]: Unknown chip. Aborting.
Nov 25 15:09:22 iMac sharingd[251]: 15:09:22.966 : Tethering: Identifier needs fixing
Nov 25 16:01:22 localhost kernel[0]: Refusing new kext com.insanelymac.AtherosE2200Ethernet, v1.0.2: already have prelinked v2.0.1.
Nov 25 16:01:22 localhost kernel[0]: Ethernet [AtherosE2200]: Unknown chip. Aborting.
Nov 25 16:01:35 iMac sharingd[257]: 16:01:35.033 : Tethering: Identifier needs fixing
Nov 25 16:07:47 localhost kernel[0]: Refusing new kext com.insanelymac.AtherosE2200Ethernet, v1.0.2: already have prelinked v2.0.1.
Nov 25 16:07:47 localhost kernel[0]: Ethernet [AtherosE2200]: Unknown chip. Aborting.
Nov 25 16:07:59 iMac sharingd[251]: 16:07:59.434 : Tethering: Identifier needs fixing



how do i get this fixed?
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,691
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
this kext will not be installed for some reason and i keep getting the following errors in my system log:

Nov 25 14:38:18 NZXTs-iMac sharingd[265]: 14:38:18.355 : Tethering: Identifier needs fixing
Nov 25 14:58:18 NZXTs-iMac com.apple.kextd[43]: kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext "/Library/Extensions/AtherosE2200Ethernet.kext"
Nov 25 14:58:18 NZXTs-iMac kernel[0]: Ethernet [AtherosE2200]: Unknown chip. Aborting.
Nov 25 14:58:19 NZXTs-iMac com.apple.kextcache[579]: kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext AtherosE2200Ethernet.kext
Nov 25 15:01:51 localhost kernel[0]: Ethernet [AtherosE2200]: Unknown chip. Aborting.
Nov 25 15:02:05 NZXTs-iMac sharingd[248]: 15:02:05.336 : Tethering: Identifier needs fixing
Nov 25 15:09:09 localhost kernel[0]: Refusing new kext com.insanelymac.AtherosE2200Ethernet, v1.0.2: already have prelinked v2.0.1.
Nov 25 15:09:09 localhost kernel[0]: Ethernet [AtherosE2200]: Unknown chip. Aborting.
Nov 25 15:09:22 iMac sharingd[251]: 15:09:22.966 : Tethering: Identifier needs fixing
Nov 25 16:01:22 localhost kernel[0]: Refusing new kext com.insanelymac.AtherosE2200Ethernet, v1.0.2: already have prelinked v2.0.1.
Nov 25 16:01:22 localhost kernel[0]: Ethernet [AtherosE2200]: Unknown chip. Aborting.
Nov 25 16:01:35 iMac sharingd[257]: 16:01:35.033 : Tethering: Identifier needs fixing
Nov 25 16:07:47 localhost kernel[0]: Refusing new kext com.insanelymac.AtherosE2200Ethernet, v1.0.2: already have prelinked v2.0.1.
Nov 25 16:07:47 localhost kernel[0]: Ethernet [AtherosE2200]: Unknown chip. Aborting.
Nov 25 16:07:59 iMac sharingd[251]: 16:07:59.434 : Tethering: Identifier needs fixing



how do i get this fixed?

Clearly you have two different versions of the kext installed.
 
Joined
Sep 3, 2015
Messages
169
Motherboard
MSI X99A GODlike Gaming LGA 2011-v3 Intel X99
CPU
i7-5820K Haswell-E 6-Core 3.3 GHz LGA 2011-v3 140W
Graphics
MSI GeForce GTX 980Ti 6GD5T OC 6GB 384-Bit GDDR5
Mac
  1. MacBook Pro
Classic Mac
Mobile Phone
  1. iOS
Clearly you have two different versions of the kext installed.


clearly how?

is there a way to uninstall any duplicative versions that shouldn't be there? i have 290 kexts in the SLE folder and not sure which ones that should be removed?

I am only using the USB Apple Ethernet dongle right now for internet. do i need uninstall that kext?

one of the "troubleshooting guides" that i could find that you referred me to states that6 I should not use the "NPCI=0x2000" boot flag (which could be part of the problem???_)

however when i alter my config.plist to take out the npci=0x2000 boot flag i just get an automatic reboot and can't get into el capitan.

can you help me please to get this fixed once and for all? i know this is probably something you could resolve in 2 seconds - but i have been struggling for 3 weeks and still can't get access to mas.

thanks in advance to you giving me full guidance on how to get this resolved.
 
Joined
Sep 3, 2015
Messages
169
Motherboard
MSI X99A GODlike Gaming LGA 2011-v3 Intel X99
CPU
i7-5820K Haswell-E 6-Core 3.3 GHz LGA 2011-v3 140W
Graphics
MSI GeForce GTX 980Ti 6GD5T OC 6GB 384-Bit GDDR5
Mac
  1. MacBook Pro
Classic Mac
Mobile Phone
  1. iOS
View attachment List of kext files from SLE.txt

there is only one instance in my /S/L/E/ folder - so i am not sure what other kext i need to remove?

i have completely reinstalled El Capitan and reformatted and started everything from scratch and still can/t see my ethernet driver.

first it was "it isn't showing up in IOREG because the driver is not installed" and now it is "there are duplicative instances of the driver installed".

not sure if it is just pure user error but i have enlisted help from 2 other people that have been building hackintoshes for the last 5 years and they also can't figure out how to get this fixed.

thanks for your help. please give me guidance on how to get this resolved.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,691
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
clearly how?

Code:
Nov 25 16:07:47 localhost kernel[0]: [B]Refusing[/B] new kext com.insanelymac.AtherosE2200Ethernet, [B]v1.0.2[/B]: [B]already have prelinked v2.0.1.[/B][/quote]
 
Status
Not open for further replies.
Top