Contribute
Register

Adding audio codec AppleALC

Joined
Jul 30, 2019
Messages
6
Motherboard
ASUS TUF Z390M-Pro
CPU
i5 9600k
Graphics
Intel UHD 630
Thanks for not just replying with RTFM. I have zipped the required files and posted on the linked thread above.
 
Joined
Apr 5, 2020
Messages
21
Motherboard
ASUS TUF Z390M-Pro Gaming WIFI
CPU
i7-9700K
Graphics
RX 580
Mac
MacBook Pro
Mobile Phone
Android
Hi all. I'm intending to build a new system based on "ASUS TUF Z390M-PRO GAMING (Wi-Fi)".
I was looking to install Catalina, are there any reports of audio working correctly in Catalina?
 
Joined
Jul 21, 2011
Messages
11
Motherboard
MBP
CPU
i7
Graphics
RTX
Mac
MacBook Pro, Mac mini
Hi I have an unsupported codec I need help to add to ALC.

It's from a HP Zbook 17 G5. It shows as Conexant Unknown, The device Hex is 14F120D0 = Dec 351346896 = CX8400, but tried ID-12 and the speaker output stops working after about a minute, you have to select headphones, then back to speakers, and it works for about a minute then again silence. There are digital glitches sometimes, and no HDMI audio (with hda-gfx patch enabled, also there's no switch from internal to headphones and the external (headphone+mic) input is just noise. Same after waking from sleep.

I'm using Mojave 10.14.6

Attached are my voodoo and linux dumps.

Thank you

Edit

Managed to build my custom AppleALC with my codec and layout info and everything works as long as I don't patch the battery info, so it must be a bug with the EC patches for battery.
Audio side is ok though.
 

Attachments

Last edited:
Joined
Jun 8, 2020
Messages
3
Motherboard
TUF Z390-PLUS GAMING (WI-FI)
CPU
i9-9900K
Graphics
RX 590
Mac
iMac
Mobile Phone
Android
Hi all. I'm intending to build a new system based on "ASUS TUF Z390M-PRO GAMING (Wi-Fi)".
I was looking to install Catalina, are there any reports of audio working correctly in Catalina?
I'm using 10.15.6, audio is normal, OC boot, the audio output port is 2
 
Top