Contribute
Register

ADD WINDOWS 10 BOOT EFI AFTER INSTALLED OS X & CLOVER UEFI Simple

Joined
Jan 27, 2011
Messages
46
Motherboard
GA-Z87MX-D3H
CPU
Intel i7-4770
Graphics
GTX 660
Mac
Classic Mac
Mobile Phone
Hello!

My system has two SSD (one for each OS) and one storage HDD.
My MacOS installation is a pain in the *** as I need to remove my graphics board (Geforce 660) to install it.

So I've installed High Siera, and after that, I've removed this drive.
I've installed Windows 10 on the second SSD (UEFI).

All working good if I select from BIOS from what SSD drive to boot, but it does not work from clover.

Clover sees Windows UEFI, but when I try to load Windows it crashes.



I've added the MS EFI files from this post, but no success.

This is my EFI MacOS Partition

 
Joined
Mar 31, 2013
Messages
3
It's very easy. Delete BOOTX64-win.efi from EFI/BOOT and restore your Microsoft(EFI/Microsoft) folder to Original state.

On Microsoft/boot folder, change the name of 'bootmgfw.efi' to 'bootmgfw-orig.efi'.

Go to your CLOVER(EFI/CLOVER) folder and copy XCLOVER64.efi to Microsoft(EFI/Microsoft/boot) ... Do not rename XCLOVER64.efi.

Reboot and enjoy.
 
Joined
Dec 15, 2017
Messages
21
Motherboard
asrock z370 extreme 4
CPU
i7 8700k
Graphics
quadro k4000
issue: clover boot loader does not see HFS or APFS mac os partition after windows 10 installation.

I am sorry if I post this question again. I could not find the answer anywhere though.
here is what happened.
I have high sierra installed on z370 asRock ext 4 MB with 2 NVME drives on MB. one is loaded with High Sierra. I tried to install UEFI windows 10 on another SSD. it went through fine. after I reboot into clover, it only shows windows file system partition. I could not find any mac os or recovery. of Course, at that point, I can only boot to Windows 10 which is fine and running ok.
Then I used usb clover with high sierra on it to boot and when it complete loading all drivers, I see mac os installation , disk utility etc. so I clicked disk utility to see what happened with my mac os. they are grey out and said not mounted. I was unable to mount those.
anyone has any thought for my problem. any input is appreciated.
Tom
 
Last edited:
Joined
Mar 31, 2013
Messages
3
[QUOTE = "atun, post: 1675915, membro: 1969128"] problema: o carregador de inicialização do trevo não vê a partição Mac OS do HFS ou APFS após a instalação do Windows 10.
[/ QUOTE]

Your problem is not related to the purpose of the topic.
 
Joined
Dec 5, 2017
Messages
68
Motherboard
Asus TUF Z270 Mark 2 ATX
CPU
Intel Core i7-7700K 4.2 GHz
Graphics
EVGA GeForce GTX 1080 SC2 iCX
Mac
iMac, Mac Pro
Classic Mac
Plus
Mobile Phone
iOS
Right Steps :
  1. Boot windows 10/8.1/8 [ In Legacy Mode ].
  2. Open Command Prompt [CMD] as administrator
  3. Insert Command :
    Code:
    bcdboot C:\Windows /s C: /f uefi
  4. Now Go to C drive and then open EFI folder .
  5. Copy all the contents into a usb drive [ mainly there are two folder : "Boot" & "Microsoft" ]
  6. Restart PC/Notebook , set Boot Mode to UEFI.
  7. Boot OSX/MacOS & Mount EFI Partition using Clover configurator or Using Finder-Preference.
  8. Open USB drive and go to Boot folder & Rename "bootx64.efi" to "BOOTX64-win.efi"
  9. Now open the EFI Partition , Then Open EFI folder & Copy "BOOTX64-win.efi" to BOOT Folder.
  10. Go to USB drive again & Copy Microsoft folder to EFI Folder of EFI Partition you mounted. Now you will have 4 folders inside EFI i.e. "Apple", "Boot", "Clover" & "Microsoft".
  11. Restart your MAC & choose Windows option from clover bootmenu.

FIX For Only Windows Loading :
After these steps is quite possible that your Notebook/PC is only Booting Windows Partition or drive , to fix it follow theses steps:

  1. Go to Bios Setting.
  2. Found option like "Add NEW Boot Entry" [ option only available after setting boot mode to UFEI ]
  3. Add Name (Your Choice) & Path = " EFI\CLOVER\CLOVERX64.efi "
  4. Save setting and reboot again into BIOS.
  5. Move Your this new Boot Entry in Top of Your Boot Mode or Boot Priority .
  6. Save BIOS Setting and Restart Normally.
Hi, I followed your instructions and am now able to boot into Windows 10 using Clover bootloader. Two questions/observations, though: 1. Can I now delete the EFI folder that was created at the root level of my Windows C: drive in your #3 step? 2. When I do boot into Windows using Clover, it apparently sets the Boot Priority in my UEFI and puts Windows at the top position, so that subsequent restarts always boot into Windows. I think that may be what you're referring to in the second half of your instructions, but my motherboard UEFI (Asus TUF Mark 2) doesn't offer any ability to add a new Boot Entry like you suggest. It does offer up to 15 Boot Options but the best I can do is disable the ones I don't need or want; I can't create my own entries.
 
Joined
Dec 24, 2017
Messages
3
Motherboard
Asus ROG STRIX Z370-E
CPU
i7 8700K
Graphics
EVGA GEFORCE GTX 1080Ti
This worked for me:

Motherboard: Asus ROG STRIX Z370-E
CPU: i7 8700K
Graphics: EVGA GEFORCE GTX 1080 Ti

I have 2 SSDs installed:
SSD1: macOS High Sierra with Clover 4458 via MultiBeast, installed while SSD2 was disconnected
SSD2: Windows 10, installed while SSD1 was disconnected

When I connected both SSDs and booted from SSD1, Clover showed some boot options for Windows, but when I started them, they just showed a cursor blinking on the screen. Windows 10 didn't start.

Then I booted Windows 10 directly from SSD2, and entered this line (as given by the OP) on the command line with Administator rights: > bcdboot C:\Windows /s C: /f uefi

After restarting and booting from SSD1, Clover showed some additional boot options for Windows: "Boot Microsoft EFI Boot from EFI" and "Boot Microsoft EFI Boot from HD(4,GPT,<UUID>,...)". Selecting either of these successfully boots Windows 10 on my machine.
 
Joined
Oct 26, 2011
Messages
1
Mac
Classic Mac
Mobile Phone
I find I enjoy helping other OS X self builder's and enthusiasts with their systems after I've been helped many times myself by this very community. This is a "straight to the point" guide, not "how I did it guide".


HERE WE GO

This guide has no guarantee it will work for you as it did for me. Use this information at your own risk.

This all inclusive guide is targeted for helping others using UEFI booting of Windows 10 alongside their OS X using the Clover boot loader 'UEFI' option installed on the OS X partition through latest EL Captain Multi-beast version 8xx. If you're using Clover legacy boot settings this guide won't be for you . . . .

so again --->'Not For Legacy Booting' nor older motherboards that don't have ability for UEFI booting.

It is most important that your bios settings are all properly set for UEFI booting. tonymacx86 has plenty of members in this community that have already posted guides to explain how to properly set up your Bios for UEFI boot so I won't be spending any time explaining this.


THE PROBLEM:

You post installed CLOVER UEFI boot loader to your OS X partition, achieved booting OS X UEFI but Windows 10 you can't.


THE DESIRE:

You want the holy grail. The same ability to boot your Windows 10 from the Clover boot loader just like OS X.



HERE'S HOW:

Attached bottom of this post is a zip file containing the proper configured Windows 10 UEFI contents for adding to your Clover boot installation within your permanent OS X partition. Download the zip file and open it. Once zip file is opened reveals the main folder. Inside you'll discover 2 objects. #1 A folder labled 'Microsoft' and #2 a Windows BOOTX64-win.efi file. I'll explain later in steps #9 and #10 for exactly where to place these items. Once completed you should have no problem booting Windows 10 from your Clover boot loader UEFI installation equally without hiccup just like booting OS X from that same Clover UEFI installation.

This guide designed for simplicity of how to rather an explanation as to why.

1. Boot into Windows 10 directly by using keyboard hot key such as F8 or F12 (you likely require the bios boot settings being switched back to the legacy boot options 1st in order to do this.)

2. Once booted back into Windows 10. Open command window 'run as administrator'

3. enter command: bcdboot C:\Windows /s C: /f uefi

4. You should then see a following message "Boot files successfully created". 1st step success!

5. Restart computer, enter bios & reset the bios legacy boot settings back to UEFI boot settings if need be.

6. Clover boot options should now be back. Now boot into OS X El Captain or your whatever OS X installation.

7. You now should see a Windows 10 drive and possibly a reserve drive mounted on the OS X desktop. Leave them there.

8. Using an EFI mounter like 'Clover configurator' mount OS X 'EFI' partition. Follow next 2 steps as specified.

9. Open the mounted 'EFI' drive/folder on the OS X desktop then simply drag the attached entire 'Microsoft' folder inside that 'EFI' folder. Don't mess with any contents within 'Microsoft' folder. It is configured to boot Windows 10 UEFI. Just drag the folder as specified.

For those who are still newbies learning your way around OS X and have attempted to mount your EFI drive/folder but do not see it mounted on your desktop try this:

A. Open Finder (smiley face square icon bottom of your desktop)
B. Now left click the actual word 'Finder' located at top left corner of your desktop for revealing a list of selactable options.
C. Select Preferences
D. Under 'show these items under desktop' make sure 'Hard Disks' is checked (EFI drive should now be seen mounted on desktop)


10. Now take BOOTX64-win.efi and drag that file into the 'BOOT' folder sitting inside underneath same 'EFI' folder. You now are completely done.

11. Other Points Need Mentioned to avoid mistakes. Underneath 'EFI' folder make sure you put nothing in the Apple or Clover folders. Leave them alone. The Microsoft folder should now be seen listed or being grouped among APPLE, BOOT & CLOVER folders under 'EFI' after you dragged it there. The only file you'll put within another folder is placing BOOTX64-win.efi inside that 'BOOT' folder sitting inside the "EFI' folder.

12. You can unmount Windows 10 or any mounted partitioner for that matter on the OS X desktop simply by right clicking then selecting 'eject' from the list.

13. Hopefully now a restart back into the Clover provide you booting options either OS X or Windows without problem.

I hope this simple explanation for multiboot of OS X and Windows works for you. God Bless.

Thks a lot man, this worked fine for me.
 
Joined
Oct 15, 2013
Messages
2
Mac
Classic Mac
Mobile Phone
hi,

try everything listed in this thread but did not work.
2x SSD 1 with High Sierra and SSD2 with Win 10. install both clean.

- pressing F12 does not seem to boot win10, and i need to go to BIOS to remove/disable SSD1 (High Sierra) to boot to win 10.

- i got both the options to boot windows via "Boot Microsoft EFI Boot from EFI" and "Boot Microsoft EFI Boot from HD(4,GPT,<UUID>,...)"

- "Boot Microsoft EFI Boot from EFI" here i got this error.



- choosing "Boot Microsoft EFI Boot from EFI" and "Boot Microsoft EFI Boot from HD(4,GPT,<UUID>,...)"i got a black screen with a mouse cursor.

- the only way for me to boot to windows10 is to disable all my High Sierra SSD1. and than it will boot to windows10. for me to go to OSX i need to enable and choose the boot sequence to choose SSD1 (high sierra)

i ran out of ideas :( any tips?
 
Joined
Sep 22, 2017
Messages
26
Motherboard
Gigabyte Brix Pro 4570R
CPU
i5
Graphics
Intel Iris 5200
Mobile Phone
Android
this looks like your booting the wrong disk.
you need to boot the MacOs disk and have Clover as the bootloader.
Then you need to select the correct disk to boot MacOs or Windows, if you get this message then you've selected the wrong one.
 
Top