Contribute
Register

Add Support for XFX 6850 ZCFC

Joined
Jul 29, 2012
Messages
47
Motherboard
Dell inspiron 7737. (Clover)
CPU
Intel Core I7-4510U (Haswell)
Graphics
Intel® HD Graphics 4400 (1920X1080p) + nVidia GeForce GT 750M
Mac
MacBook Pro, Mac mini
Mobile Phone
iOS
Go to techpowerup, download bios for XFX 6870 ZHFC

http://www.techpowerup.com/vgabios/106421/XFX.HD6870.1024.110804.html

And then use ATI bios flash tool like
http://www.techpowerup.com/downloads/Utilities/BIOS_Flashing/ATI/

To flash 6850 ZCFC to 6870 ZHFC.

6870 ZHFC is supported by mac OS X 10.8 right away. ZCFC and ZHFC use the same card design, connectors etc.

Make sure you read some online tutorial on how to properly flash a video card bios.

There is tools: http://www.techpowerup.com/rbe/
Did you tune the 6870 clock to 775Mhz (from 900Mhz) before you flash xfx 6850 zcfc?

thanks,
-Jack
 
Joined
Jul 29, 2012
Messages
47
Motherboard
Dell inspiron 7737. (Clover)
CPU
Intel Core I7-4510U (Haswell)
Graphics
Intel® HD Graphics 4400 (1920X1080p) + nVidia GeForce GT 750M
Mac
MacBook Pro, Mac mini
Mobile Phone
iOS
Wow, it is working now in ML 10.8.2 :thumbup:

Flash XFX 6850 ZCFC bios with XFX 6870 ZHFC. These are my steps
1. Download XFX 6870 ZHFC bios (George_Xu 's link)
2. Create bootable USB Drive (I use Patriot 8GB orange thumb drive, instruction is easy to Google and get)
3. Verify MD5: 61c81ea08a029fed394ebaea60b3badf (this value is on the download page) with my download file using WinMD5Free.exe
4. Use RBE from http://www.techpowerup.com/rbe/ to get CheckSum value of my download rom file.
5. Boot from USB drive, under DOS C:> command line:
6. ATIFlash -cf my6870.rom -- verify CheckSum value with value from RBE tools, (0x6400 as I remembered)
6. ATIFlash -s 0 my6850.rom -- save my original bios from XFX 6850 ZCFC, just in case if I want restore it back.
7. ATIFlash -f -p 0 my6870.rom -- write 6870 bios into XFX 6850 ZCFC, after it is done, it asks me to restart my machine.

Restart my machine into ML 10.8.2, 6850 ZCFC works, GraphicsEnabler=Yes|No both are good.

Cinebench 11.5 gives OpenGL benchmark: 39.28
Boot into Windows 7:
Cinebench 11.5 gives OpenGL benchmark: 67.19

I tried a few AtiConfig values: Duckweed,Bulrushes,Gibba, Pithecia, Muskgrass, Lotus.
it turns out: none of them can raise benchmark value dramatically.:banghead: Lotus makes slightly better: 40.26

So I keep this setting so far as now:
<key>GraphicsEnabler</key>
<string>Yes</string>
<key>AtiConfig</key>
<string>Lotus</string>
<key>AtiPorts</key>
<string>4</string>

2 monitors are connected and working under ML 10.8.2

If anyone has better configuration to increase Cinebench OpenGL value, I will really appreciate your post in this forum.

-Jack
 
Joined
Nov 11, 2012
Messages
1
Motherboard
iMac
CPU
QUAD 2.4 Ghz
Graphics
AMD 6850
Mac
Classic Mac
Mobile Phone
Wow, it is working now in ML 10.8.2 :thumbup:

Flash XFX 6850 ZCFC bios with XFX 6870 ZHFC. These are my steps
1. Download XFX 6870 ZHFC bios (George_Xu 's link)
2. Create bootable USB Drive (I use Patriot 8GB orange thumb drive, instruction is easy to Google and get)
3. Verify MD5: 61c81ea08a029fed394ebaea60b3badf (this value is on the download page) with my download file using WinMD5Free.exe
4. Use RBE from http://www.techpowerup.com/rbe/ to get CheckSum value of my download rom file.
5. Boot from USB drive, under DOS C:> command line:
6. ATIFlash -cf my6870.rom -- verify CheckSum value with value from RBE tools, (0x6400 as I remembered)
6. ATIFlash -s 0 my6850.rom -- save my original bios from XFX 6850 ZCFC, just in case if I want restore it back.
7. ATIFlash -f -p 0 my6870.rom -- write 6870 bios into XFX 6850 ZCFC, after it is done, it asks me to restart my machine.

Restart my machine into ML 10.8.2, 6850 ZCFC works, GraphicsEnabler=Yes|No both are good.

Cinebench 11.5 gives OpenGL benchmark: 39.28
Boot into Windows 7:
Cinebench 11.5 gives OpenGL benchmark: 67.19

I tried a few AtiConfig values: Duckweed,Bulrushes,Gibba, Pithecia, Muskgrass, Lotus.
it turns out: none of them can raise benchmark value dramatically.:banghead: Lotus makes slightly better: 40.26

So I keep this setting so far as now:
<key>GraphicsEnabler</key>
<string>Yes</string>
<key>AtiConfig</key>
<string>Lotus</string>
<key>AtiPorts</key>
<string>4</string>

2 monitors are connected and working under ML 10.8.2

If anyone has better configuration to increase Cinebench OpenGL value, I will really appreciate your post in this forum.

-Jack
Thank you thank you thank you. Not enough thanks.

So I got dual monitors working by flashing the graphics card. I didn't downclock it like jzhang19 suggestions. I can only get dual monitors to work with the Lotus AtiConfig, Duckweed and Bulrushes disables my dual monitors and puts my screen to sleep. What else I noticed is that when using Lotus I get Graphics System Profile says I'm running AMD Radeon HD 6xxx 1024MB card, but when running Bulrushes I end up getting 6850 instead of 6xxx.

Also this might be OT, but Cinebench keeps crashing when I run it. Not sure if I'm doing something wrong or not (first time ever ran Cinebench before).

So if other people are having a hard time getting dual monitors to work with your new try the Lotus ATIConfig. I left all my other settings the same as jzhang19.
 
Joined
Dec 18, 2011
Messages
33
Motherboard
MSI B85-G43 Gaming
CPU
i5-4690
Graphics
MSI GTX 760
Mac
Mac mini, Mac Pro
Mobile Phone
Android
I have the same card and i could not run with it SL or Lion.
I read your guide about flashing bioss but i am considering if something goes wrong when i am flashing bios.
Isnt that a little bit risky ?
is it worth for this ?
 
Joined
Jul 29, 2012
Messages
47
Motherboard
Dell inspiron 7737. (Clover)
CPU
Intel Core I7-4510U (Haswell)
Graphics
Intel® HD Graphics 4400 (1920X1080p) + nVidia GeForce GT 750M
Mac
MacBook Pro, Mac mini
Mobile Phone
iOS
I have the same card and i could not run with it SL or Lion.
I read your guide about flashing bioss but i am considering if something goes wrong when i am flashing bios.
Isnt that a little bit risky ?
is it worth for this ?
The same feeling and consideration as yours at beginning. But what could I do with this XFX 6850 ZCFC? It seems no other solution so far. Anyway I will throw it away if I cannot make it working in my hackintosh. (replaced with Nvidia GT 640 2GB). That's why I decided to give a try. and it works:p

Make a backup of your original bios in case if anything goes worng. (most of the chance even if it goes wrong, you can still boot it in character mode. and refresh back your old bios. Rarely it gives a completely black screen)

I did some checksum comparision before refreshing. make sure you downloaded the good-bit bios file.

It is a risky job, needs a lot of attention on each step. I agree!

One more thing - I can only make the refreshed XFX 6850 ZCFC working under ML. not Lion nor SL. if you can make it working with Lion or SL. please let me know.
 
Joined
Oct 31, 2011
Messages
1
Motherboard
OS X Mavericks 10.9.5
CPU
Intel Core 2 Quad Q8200
Graphics
XFX HD 6850 ZCFC flashed bios to HD 6870 ZHFC
Mac
Classic Mac
Mobile Phone
George_Xu, just wanted to say thank you! It worked flawlessly on Mavericks 10.9.5!
 
Top