Contribute
Register

Acer Swift 3 2018 Catalina with OpenCore guide

Joined
Jun 15, 2015
Messages
40
Motherboard
Xiaomi Mi Notebook Pro
CPU
i7-8550U
Graphics
UHD 620/GTX MX150
Mobile Phone
Android
macOS 10.15 Catalina on Acer Swift 3 SF315-51-518S (could work on others too)

TL;DR If you want an easy way to install macOS and not make all the OpenCore EFI yourself, there's an already-built version in my repository.
Last guide edit: Dec. 27, 2019

Specs
  • CPU : Intel Core i5-8250U (Kabylake-R)
  • Graphics : Intel UHD 620
  • RAM : 8 GB DDR4 2133 MHz (non-replaceable)
  • SSD : 256 GB Intel 600p series (SSDPEKKW256G7) (M.2 2280 NVMe, replaceable. PCIe x2 speeds (1500MBs\540MBs) )
  • Screen : 15-inch 1920 x 1080 glossy IPS
  • Ports : 1xUSB 3.1 Gen-1 Type-C, 2xUSB 3.0, 1xUSB 2.0, 1xHDMI (full-size), 1xAudio jack
  • Wifi/Bluetooth : Intel AC-7265, (M.2 NGFF)
  • Audio : ALC255 (ven id:10ec, dev id:0255)
  • SD Card Reader : Realtek USB2.0-CRW (ven id:0bda, dev id:0129)
  • Back-lit keyboard
  • I2C Trackpad + PS2 keyboard

What is working
  • Graphics
    Intel UHD Graphics 620 1536 МB
    • QE\CI, Final Cut X works just fine
  • Audio
    • Speakers, headphones and internal mic
  • Keyboard
    • Backlight is ACPI-managed so it works just fine too
  • Trackpad
    • VoodooI2C makes it buttery-smooth, supports all the macOS gestures
  • USB
    • Some injections has to be done and it may vary from model to model, more details below
  • Webcam
    • PhotoBooth works fine :D
  • Sleep/Wake
    • Lid also working
    • To my knowledge, no weird things after sleep/wake
      • If you disable the wifi with Acer's keyboard shortcut (Fn+F3) and go to sleep, wifi won't be able to be enable. You'll have to reboot the laptop.
  • At least 6 hours battery life
    • Tested with 10.13.4 (max brightness, 720p on safari, USB wifi dongle)

What is NOT working
  • Built-in Wifi
    • Must be replaced
  • Built-in SD card reader
  • Fingerprint
    • It's detected but it is useless (can't authenticate on lockscreen or in password manager), so I decided to disable that port (I got shitloads of BiometricKit errors)
  • SSD. I had kernel panics with Intel 660p, I don't know if it works now, but 10.13.4 and lower certainly had problems with it.
    • Replaced with Samsung EVO970 250GB

What was not tested
  • HDMI

What must be done
  • Replace Wi-Fi module
    • I've installed DW1560 which is based on Broadcom BCM94352Z, all is working great
  • Replace SSD (stock one may or may not work fine, you should note that it can cause kernel panics)
    • Replaced with EVO970 250GB
  • Follow my guide


Updating BIOS to the latest version and BIOS configuration

Install latest BIOS with fixes for your laptop, it can be found in "Support" tab on official Acer website (I have 1.05 at the moment)

Once the update is done, go in your BIOS setup. For my model, I must presse F2 at boot. Press F9 to reset default settings. Enable "F12 Boot Menu" in Main tab. Set Supervisor Password in Security tab (needed to deactivate Secure Boot). Disable "Secure Boot" in Boot tab. Save changes.


Create bootable USB

You'll need to make a bootable USB drive with macOS installer. There are plenty of methods, the one of popular ones is UniBeast, but it required internet connection on install, and it was a no-go for me. I decided to prepare Installer with "createinstallmedia" method. You may check it here, but in short, you need to format your flash drive to GUID partition table and JHFS+ filesystem, download latest installer from Mac App Store and rewrite your flash drive by that command
Code (Text):
sudo /Applications/Install\ macOS\ Mojave.app/Contents/Resources/createinstallmedia --volume /Volumes/*YOUR FLASH DRIVE NAME* --applicationpath /Applications/Install\ macOS\ Mojave.app

Then, you'll have to instal OpenCore bootloader on your flash drive. This is not a subject of this guide, you can either do this by copying the latest release of my repository to the EFI partition of the USB drive or installing everything manually.

After this, we will have to put some important kexts in the flash drive's EFI partition in folder EFI/OC/Kexts. Don't forget to put them in the config.plist too, or download mine.

Add the following kexts:


Installation
  • You must press F12 for this Acer laptop at boot to select USB flash drive. I plugged the flash drive in the USB3 port.
  • When the installation is over and the laptop reboots, it will probably give you an error at boot (Default Boot Device Missing or Boot Failed). Select OK and, again, boot on your USB flash drive. In OpenCore bootloader, choose to boot on your newly installed macOS drive. This step is normal because there is no bootloader yet on your SSD. Keep in mind this step because if you will have problems booting from your SSD in the future, this could be handy.

Allow apps downloaded from Anywhere and other useful configurations
  • In Terminal, type the following :
    Code (Text):
    sudo spctl --master-disable
  • In Finder>Preferences>General>Select to show hard disks on the desktop
  • In System Preferences>User and groups
    • Click on the lock and type your password
    • Click on Login Options and select your user in Automatic login
It just speeds up the configuration. You can put it back as it was after this guide.


OpenCore EFI bootloader installation

  • The easy way is to download it from my repository and copy the files to the EFI partition of the SSD (you can find the exact steps on the GitHub page, but you're welcome to do it yourself. I wouldn't describe how to do it here though, because there are many guides for it, for example this one

DSDT Patching
Reboot the laptop. At Clover boot screen press F4. This will dump files in EFI/Clover/ACPI/origin.
  • Boot into macOS
  • Mount your EFI drive in Clover Configurator
  • Copy DSDT.aml and all SSDT*.aml from EFI/Clover/ACPI/origin to a new folder named DSDT on your desktop.
  • Copy MaciASL from your USB flash drive to Applications

The guide talks about duplicate SSDTs and comparing their size. I have two SSDTs with the same size but not the same content so there will be no problems later on.

  • In Terminal:
    • Code:
      git clone https://github.com/RehabMan/Intel-iasl.git iasl.git
      • It should ask you to install git. Install git.
    • Code:
      git clone https://github.com/RehabMan/Intel-iasl.git iasl.git
      • Yes, you must do it again.
    • Code:
      cd iasl.git
    • Code:
      make
    • Code:
      sudo make install
    • Code:
      sudo cp /usr/bin/iasl /Applications/MaciASL.app/Contents/MacOS/iasl61
    • Code:
      cd *drag and drop your DSDT folder*
      • This will put you back to DSDT folder
    • Code:
      iasl -da -dl *.aml

You should have pretty much the same files as me if you have the same laptop.
  • For DSDT.dsl, wait for the file to load completely
    • Search and Replace all "GFX0" for "IGPU"
    • Search and Replace all "HDAS" for "HDEF"
    • Apply Brightness fix patch
    • Apply VoodooI2C GPIO Patch and Windows 10 Patch
    • Find your touchpad device (mine was TPL1), scroll to _INI section and replace
      Code:
      If (LEqual (SDM1, Zero))
      {
      SHPO (GPLI, One)
      }
      to
      Code:
      SHPO (GPLI, One)
      I.e delete If condition so it would load in any case
    • Additionally I had to add
      Code:
      \_SB.PCI0.I2C1.TPL1._INI ()
      to _WAK method to make touchpad work after sleep
    • Compile and if no errors, save the file as AML file (replace if needed).
    • I also applied some generic patches like "HPET patch" they can't harm but I don't sure is it needed, so I applied it and it's just working fine, it's up to you.
  • For every other .dsl
    • Search and Replace all "GFX0" for "IGPU"
    • Compile and if no errors, save the file as AML file (replace if needed)
  • Copy ONLY EDITED (don't copy if you didn't replace anything) files from DSDT folder to EFI/CLOVER/ACPI/patched

I wrote a simple SSDT patch which replaces TPL1 (trackpad) device definition with the code which works well with VoodooI2C, so DSDT patching is unnecessary now.



In System Preferences > Display, you should now see the Brightness slider. You may remap brightness change to F10-F11 as did I, anyway you can't use stock brightness shortcut without Karabiner.


Fn Keyboard Shortcuts (same as on Windows)
  • F3 : Disconnect from your wireless network. Pressing it again won't connect you back. You'll have to manually reselect your wireless network.
  • F4 : Put laptop to sleep
  • F5 : Switch between displays (when you have another monitor)
  • F6 : Disable/Enable main display
  • F7 (and also PrtSc) : Disable/Enable trackpad
  • F9 : Disable/Enable keyboard's backlight
  • Up/Down: Volume
Messages and FaceTime fix:
The simplest guide I found was the one here : https://www.tonymacx86.com/threads/simple-imessage-guide-for-yosemite-and-el-capitan.186276/ , but I didn't have any problems from start.


P.S
I can be wrong! Maybe I forgot something writing the guide, maybe something is not right at all, please correct me if you found an error. Liked my work? Donate, I will be very happy if you'll buy me some coffee :)

Credits:
Apple for macOS
Acer for laptop
RehabMan for great guides and useful files
Steeeeeeve (also known as stevezhengshiqi) for awesome EFI examples and many explanations.
alex.daoud for VoodooI2C kext and hints for making it work with the trackpad.
ioreknanou for making guide for older model, this one is edit of this
acidanthera for awesome kexts and first-class support for hackintosh enthusiasts


Other Useful Links

https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
http://www.insanelymac.com/forum/topic/312759-fix-macos-sierra-dp1-bcm94532z-wifi/
https://www.tonymacx86.com/threads/guide-patching-dsdt-ssdt-for-laptop-backlight-control.152659/
 
Joined
Dec 27, 2019
Messages
2
Motherboard
H370
CPU
i5-8200
Graphics
nVidia GTX1050
Hi, I have just installed Mojave on my Acer Swift 3 (i5-7200u)

After patching DSDT/SSDT and some kexts I can say that it is mostly working like a MacBook. (except wifi, I therefore ordered a compatible wifi chip. Should come by in early January)

This guide was largely helpful, and the files provided were of great use (even though I ended up using clover)

One problem though: my laptop battery drains like crazy. It lasts 3 hours at best under very moderate use. It easily lasted 7 hours with windows installed. I tried all the power management tricks, including adding a SSDT file, modifying config.plist, but still my battery drain has not improved much.

I was wondering if you have any advice regarding power management?
 
Joined
Oct 19, 2019
Messages
1
@PavelIT:
Thanks for your tutorial.
My laptop is Acer Swift 3 SF315 52G 58TE i5 8250U/8GB/256GB/2GB MX150/.
I think it seems like your laptop
I have an issue, can you help me, plz?
I make a USB bootloader with OpenCore by using your EFI, but when it booting to bios, not open core. I try to test another pc, it works okay.
Do I need to config the bios of my laptop Acer? Thank?
 
Last edited:
Joined
Jan 19, 2020
Messages
2
Motherboard
SF315-52G-56FR
CPU
i5 8250U
Graphics
UHD 620 + MX150
Hi, are you going to update to 0.5.4? Also, your EFI works perfectly fine when I just change the layout id except the internal mic and touchpad itself. I have checked the ACPI name of the touchpad and it's exactly the same as yours but it doesn't work no matter what I do... Do you have any suggestions for that?
 
Joined
Feb 8, 2020
Messages
1
Motherboard
intel
CPU
intel
Graphics
intel 620
FAILURE

macOS 10.15.3 Catalina on Acer Swift 3 SF313-51-57EQ vs SF315-51-518S

I've been using this guide for my Swift 3 SF313-51-57EQ, below in red is what differs between my system and OP's (which isn't much). The process has failed, but I'm not sure why. I know it's not OP's fault in any capacity. Thank you @PavelIT for getting me as close as I am, unfortunately I'm messing up somewhere.

Specs
  • CPU : Intel Core i5-8250U (Kabylake-R)
  • Graphics : Intel UHD 620
  • RAM : 8 GB DDR4 2400 MHz
  • SSD : 256 GB KINGSTON RBUSNS8154P3256GJ1 (M.2 M.2 2280 NVMe SSD - REPLACEABLE
  • Screen : 13.3 inch 16:9, 1920 x 1080 pixel 166 PPI NON-Glossy IPS LCD
  • Ports : 1xUSB 3.1 Gen-1 Type-C DisplayPortCompatible, 1xUSB 3.0, 1xUSB 2.0, 1xHDMI (full-size), 1xAudio jack
  • Wifi/Bluetooth : Intel AC-7265, (M.2 NGFF)
  • Audio : ALC255 (ven id:10ec, dev id:0255)
  • Back-lit keyboard
  • I2C Trackpad(?) + PS2 keyboard(?)
    • All i can find online is Acer FineTip keyboard,multi-gesture touch pad, precision touchpad
BIOS
  • Version: 1.11
  • Fast Boot [Disabled]
  • Network Boot [Disabled]
  • F12 [Enabled]
  • SATA Mode [AHCI]
  • VTX [Disabled]
  • VTD [Disabled]
  • TPM [Disabled]
  • Boot Mode [UEFI] (Can't change I believe)
  • Secure Boot [Disabled]
macOS Catalina [10.15.3]

I've been attempting this install for over a week now and I cannot for the life of me figure out what I'm doing incorrectly.

Process:
  • Using USB 2.0, 32 GB
    • Switching View to All
    • Format: macOS Extended Journaled, GUID
  • Using terminal command to push install onto USB
  • Using CLOVER to simply mount, open EFI partition
  • Dragging entire EFI folder supplied by OP to EFI partition, which supports his SF315-51
  • OpenCore opens, allowing disk selection
    • Choose macOS Install USB
Irregularities:
  • When plugging USB stick into USB 2.0 port: Apple logo followed by PROHIBITED SIGN(circle w/slash)
  • When plugging USB stick into USB 3.0 port: Apple logo, midway through initialization, the keyboard flashes and screen completely dims to where text is barely legible.. however at that point, midway through loading, the install page opens-- to either repair, install, disk utility.. However... MORE issues
    • Complete dimmed screen
    • Trackpad does not interact w/cursor
    • Keyboard DOES WORK
  • At this point above.. I used the keyboard to attempt to install.. The install page/computer freezes at the screen where you are to choose which disk to download macOS to.
And..now I'm here. I've attempted to research as much as possible to what could be causing the issues, but I'm fairly new.. and I continue to question my own process because this build seems to be working for OP, but not myself, even though we have very, almost exact, specs.

Possibilities? :
  • I am installing to a partitioned disk with half of it allocated to Windows 10 already, even though I've resized the main EFI on the SSD to 200MB. May need a clean drive?
  • The SSD (Kingston) is incompatible, requring a replacement.. (EVO 970/950..etc)
  • I'm doing EFI mount incorrectly, even though I'm able to load OpenCore..
  • Kext's aren't loading/need updates?
  • I'm incapable
If anyone's got ANY sort of tip/opinion, I'd appreciate it. :)
 
Joined
Aug 6, 2015
Messages
140
Motherboard
HP EliteBook 850 G5
CPU
i5-8350U
Graphics
UHD 620
Mac
MacBook Pro
Mobile Phone
iOS
I tried use your EFI folder to get it work with HP EliteBook 850 G5. I have almost success but some things doesn't work. So I tried to remove your SSDT and place mine from Clover, but it wont boot.
Do you have some "migration" guide?
 
Joined
Oct 19, 2010
Messages
43
Motherboard
Acer Swift 3 SF314-51
CPU
i5-8250U
Graphics
UHD 620
Please, Delete this post !
 
Last edited:
Top