Contribute
Register

Acer Aspire V5-171 Notebook?

Joined
Feb 2, 2011
Messages
22
Motherboard
inspiron e1405
CPU
c2d
Graphics
gma950
Mac
Classic Mac
Mobile Phone
You did spot my mention of the MANY HOURS I spent reading and trying to downgrade BIOS? ;-) My son and I concluded that the only remaining POSSIBILITY to downgrade would be to deliberately flash a corrupt BIOS to then allow the Recovery Flash to put a new one on and then use an older version. I am not the kind of person to give up but believe me I tried everything I could to downgrade... If you can manage it then you ARE a better man than me!!!!



Thanks for the Plist.. yes thats the one I wanted... :)

There is also another USB EHCI type flag if memory serves. Might work? I'll try myself shortly... assuming I get the resolution etc working with the Plist!!
For the USB, tried each one individually, and all together...still no work...
USB Bus Fix
EHCI Acquire Fix
UHCI Reset Fix
USB Legacy Off

Perplexing, but we are living in an imperfect world...
 
Joined
Mar 25, 2010
Messages
217
Motherboard
HP 8300
CPU
i7-3770
Graphics
HD4000
Mac
iMac
Mobile Phone
Android
I wonder if Crabhunter has USB working but since he doesnt want to contribute I doubt we will find out :(

I have now got up and running (with my xMove method but I have some ideas how to get Unibeast working again!) and booting OSX, Win8 and Ubuntu nicely. No joy on USB yet. DSDT & Audio I sourced doesn't work as Yamete confirmed :( Will go back and look again at that.

On LAN, you cannot just copy the kext into position. Looks like you need to insert into IONetworkingFamily.kext and then install that so will try that shortly.

Four issues remaining for me - two major and two minor:

1) USB (as above)

2) Sound (as above) - I am determined to get DSDT etc working as that will probably also solve sleep and CPU throttling issues (and mean no NullCPUPowerManagement needed)

3) I seem to need to ignore boot caches to get it to boot (-f).. Any ideas how to stop that?

4) Yamete has his showing as MacBook Air (can you post the smbios.plist you use for that?) and I *want*!!!
 
Joined
Feb 2, 2011
Messages
22
Motherboard
inspiron e1405
CPU
c2d
Graphics
gma950
Mac
Classic Mac
Mobile Phone
I wonder if Crabhunter has USB working but since he doesnt want to contribute I doubt we will find out :(

blah, blah, blah...

4) Yamete has his showing as MacBook Air (can you post the smbios.plist you use for that?) and I *want*!!!
Here is my smbios.plist with the MacBook Air 5,2 definition...
Perhaps using SleepEnabler.kext might help for sleep if we can't we a working DSDT...what we would be missing would be the i5/i7 cpu speed-step thingy...that would be nice, but not a show stopper...but since sleep is not a biggy for me, I'll let other people try the kext...(if anyone out there is reading these posts)...

I am still optimistic the hackintosh community will come up with a workaround or fix for the USB 2.0 ports not recognizing pen drives...! :)
 

Attachments

Joined
Mar 8, 2011
Messages
6
Motherboard
Gigabyte B75M-D3H
CPU
Intel i5 3570K (Ivy Bridge)
Graphics
NVidia GTX 650 Ti
Mac
MacBook Air
Classic Mac
Mobile Phone
iOS
Methanoid, yamete, and others --

I've got it !!! Finally. At least for myself, and a huge one for you guys I'm about to divulge.

First, let me say I've spent days obsessively trying to get this working. Dealing with various panics, getting past them, seeing other issues, etc. I've even taken the hard drive in and out several times for various reasons.

Anyway, let me just say that despite getting it to a great state with only a few minor non-perfections, I am actually going to rebuild this A5-171 as a Windows 8 laptop tonight. I know, I know. But the build was for my own challenge, and was for my wife, but she just told me she wants Windows on it and not osx.

Now, for the good stuff. Here is me regurgitating some of the key gotchas I came across and also some secret sauce for the A5-171 osx build. In no specific order:

A) BIOS. It's really important. Spent over an hour trying to downgrade my 2.15 to a lesser version. Why? Because there is an issue with 2.15 not allowing you to boot from USB in Legacy mode. There seem to be other issues also, like kernel panic's related to BIOS not being able to be communicated with. I circumvented my BIOS 2.15 issue with method described below in C.

B) Internal hard drive. I have the WD5000LPVT, found out it's 'Advanced Format' and I experienced the 'boot0' error. Used Tonymac's boot0 guide solution #2, and it worked. Yes, I had to take out the hard drive and attach it via usb sata cable to another mac.

C) My golden install method: attach hard drive to another mac using a usb sata cable. created 2 GUID partitions. one 8GB, remaining about 490GB. use 'carbon copy cloner' to copy your tonymac unibeast install usb stick to your newly created 8GB partition. once done, put hd back in V5-171 and reboot with unibeast stick, select the 8GB partition and use boot flags -x -v. Got me to the installer. Installed ML on 490GB partition. once back on desktop again, used an smbios I created from 'Champlist' for MBA, and the org.chameleon.Boot.plist from yamete. used multi beast and ticked what is shown in attachment.

D) Drumroll please ... all my USB ports were working 100%. Even the USB 3.0 was working super fast (I could tell). I too had the usb issues from other attempts like plugged in mouse working fine, but thumb drive not, etc. Here is the solution that worked for me .. tick the box in Multibeast 'Legacy USB Support'. That was the answer.

Good luck to all of you. I may change my mind in the future and attempt another build on this one though. We shall see.
 

Attachments

Joined
Mar 25, 2010
Messages
217
Motherboard
HP 8300
CPU
i7-3770
Graphics
HD4000
Mac
iMac
Mobile Phone
Android
Methanoid, yamete, and others --

I've got it !!! Finally. At least for myself, and a huge one for you guys I'm about to divulge.

SNIP SNIP

D) Drumroll please ... all my USB ports were working 100%. Even the USB 3.0 was working super fast (I could tell). I too had the usb issues from other attempts like plugged in mouse working fine, but thumb drive not, etc. Here is the solution that worked for me .. tick the box in Multibeast 'Legacy USB Support'. That was the answer.

Good luck to all of you. I may change my mind in the future and attempt another build on this one though. We shall see.
So basically what you did is what I did.. xMove does just what you did!!! :D What is damned helpful though is the Multibeast settings that work.

I just found Crabhunter has posted the LAN kext altogether and he also helped with USB kext fix - http://goo.gl/HNsrY

I'll tweak the guide I have compiled from all the posts and get it finished. I think we might finally be there!
 
Joined
Jul 1, 2012
Messages
5
Motherboard
z68xp-UD3
CPU
i7 2600k @ 3,8
Graphics
PNY GTX560ti
Mac
Mac Pro
Classic Mac
Mobile Phone
Android
Hey guys,

congrats! I am reading since some weeks. I also tried to install OSX on my v5 171, but it didn'r work. I'm glad that you have power of endurance that I don't have.
If you are building a guide, I will also try it again, but I'm not that much involved in hackintosh.
By the way: I have the v5 171 with the i3 processor. Will it be different from your steps?

Sorry for my English, it's a while since my last trip ;)
 
Joined
Mar 25, 2010
Messages
217
Motherboard
HP 8300
CPU
i7-3770
Graphics
HD4000
Mac
iMac
Mobile Phone
Android
mhbalough123

Looked at your Mutlibeast settings and it seems obvious now that USB is needed

But...

3rdPartySATA - why? We only have Intel SATA - surely that is redundant kext?
IOAHCIBlockStorageInjector - why?
PS2 KB & Mice Kexts - ISTR that Yamete reported they conflict with other PS2 kexts - do they give you working trackpad with no other kexts?

No FakeSMC (which Multibeast says is the one ESSENTIAL kext yet doesnt autoselect?!?!?)
No NullCPUPowerManagement (which normally is needed unless BIOS is patched)

Just querying some of the selections ;-)
 
Joined
Mar 25, 2010
Messages
217
Motherboard
HP 8300
CPU
i7-3770
Graphics
HD4000
Mac
iMac
Mobile Phone
Android
A DRAFT GUIDE:

Guide written based on information from Yamete888, Methanoid, crabhunter & mhbalough123. This guide is written for and tested on BIOS v2.14. The videoRam setting is fixed at 128Mb and the BIOS is set to Legacy BIOS (won’t work with UEFI). If you want working WiFi just get a new WiFi card ($5-10) that is compatible e.g AR9280. It’s easy to open this machine with a single screw to undo only!

1) Prepare Unibeast USB (see other guide) but ensure you select Legacy USB Support (Laptop support doesn’t do anything for us AFAIK). Make sure your Unibeast USB disk includes Multibeast, KextBeast, Chimera 2.01 installer and any kexts needed. If Multibooting Windows and other OS I recommend MBR patching your OSX USB installer (that is another topic)

2) Boot Unibeast with –v –x and run installer. Format your HDD as needed using Disk Utility (multibooters may do differently or need MBR). Install OSX on drive.

3) Reboot system but using Unibeast USB’s Chimera – select the new OSX partition and boot with –v –x PCIRootUID=1 to allow you to boot. Allow OSX to finish Apple's initial install and go to System Preferences, Security & Privacy and allow apps from Anywhere to run (so Chimera etc can run).

4) Open MultiBeast and select as below:

UserDSDT
FakeSMC
NullCPUPowerManagement
PS2 KB/Mice
Legacy USB Support
Chimera Bootloader

5) You probably ought to update Chimera to the latest v2.0.1 from your Unibeast USB stick. Then copy the org.chameleon.Boot.plist and smbios.plist files attached into /Extra overwriting any existing files.

6) Open KextBeast and install the kexts as needed (see attachment)

PS2 kexts for Trackpad & Keyboard
LAN kexts for Wired LAN
Battery kext
Audio kexts (VoodooHDA until a proper DSDT patch is completed)

7) To be able to adjust brightness, use "Brightness Slider" – a free app from App Store

8) To dos:
Untested: VGA output (though haven't tried it on mine)
Untested: Sleep, Power Management probably doesnt work (ie not speed stepping)
To fix: DSDT to allow power management, sleep and audio to work properly without Voodoo HDA
 

Attachments

Joined
Feb 2, 2011
Messages
22
Motherboard
inspiron e1405
CPU
c2d
Graphics
gma950
Mac
Classic Mac
Mobile Phone
Strange behaviour from Multibeast 5.2.1....did a new install...and selected the options from Multibeast (see pix), then I get an install error? hmmm...the only new thingy was choosing the "Legacy USB" thingy...
The Multibeast PS2 stuffs never worked for me, I don't have them installed...they crashed my system after install...that's why I went for the PS2 kexts in osx86.net...
 

Attachments

Joined
Mar 25, 2010
Messages
217
Motherboard
HP 8300
CPU
i7-3770
Graphics
HD4000
Mac
iMac
Mobile Phone
Android
Strange behaviour from Multibeast 5.2.1....did a new install...and selected the options from Multibeast (see pix), then I get an install error? hmmm...the only new thingy was choosing the "Legacy USB" thingy...
The Multibeast PS2 stuffs never worked for me, I don't have them installed...they crashed my system after install...that's why I went for the PS2 kexts in osx86.net...
I dont think the Multibeast PS2 kexts do anything - they don't crash my machine but they certainly dont activate the trackpad. I'll check again. I did a fresh install today (with Unibeast working!) and tested the guide. I also got that failed install message but it seems to work fine so I am not worry too much.

Would be useful if we can confirm that without the Multibeast PS2 kexts and with the OSX86.net kexts Trackpad & KB work. If so we can remove the Multibeast PS2 kexts from the draft guide.

I got a strange new effect of the Apple logo appearing slightly to the right of centre of the screen on loading which irritates but doesnt affect anything. I'd like to fix that really.

I think we have a reliable working reproducable setup now. As far as I am concerned next step is to get a DSDT working so we can ditch Voodoo HDA and NullCPUPowerManagement kexts and having working Sleep, Power Management and "Apple" sound. Then we could really say we have this one cracked.

Just ordered a new SSD so will do another rebuild in a couple of days. I multiboot so that just makes each rebuild that bit slower!


EDIT; Dont think we need that 10.8.1 rollback kext either. BTW my install was straight to 10.8.3
 
Top